Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039316
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] StoreServermajoralways2018-09-19 10:182018-10-01 06:01
ReporteraaroncaleroView Statuspublic 
Assigned ToAugustoMauch 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision5673d02fb2af
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomtaal
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039316: MobileAllowedCrossDomainsChecker logs an error for every process executed in backend

DescriptionIn an environment with multiserver configured (Preference Mobile Multi-Server Architecture Enablement = 'Y' at System level, and a Mobile Server configured), executing any process in backend raises an error in the openbravo.log:

469982 [http-bio-8080-exec-10] ERROR org.openbravo.mobile.core.authenticate.MobileAllowedCrossDomainsChecker - Origin null is not allowed
Steps To ReproduceIn a Retail environment:
1. Enable multiserver:
*At System Level, go to the Preference window and create the preference Mobile Multi-Server Architecture Enablement with value Y.
*At Client level, go to the Mobile Servers window and create a new record (url and server key can be anything)
*Restart tomcat so the preference change is taken into account by the system.
2. The issue:
Login in backend
Go to the Sales Order window
Select any Sales Order
Click on the Close process button.
Verify that the following error is raised in the tomcat console/openbravo.log:
469982 [http-bio-8080-exec-10] ERROR org.openbravo.mobile.core.authenticate.MobileAllowedCrossDomainsChecker - Origin null is not allowed, request information: http://localhost:8080/openbravo//SalesOrder/Header_Edition.html-IsPopUpCall=1 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0107035)
hgbot (developer)
2018-09-26 11:52

Repository: erp/devel/pi
Changeset: 5673d02fb2af158cd0f5325a38c83e9b96155e7d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Sep 26 11:51:13 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5673d02fb2af158cd0f5325a38c83e9b96155e7d [^]

Fixes issue 39316: Unneeded error shown in log if origin is empty

The problem was that sometimes the Origin request param is set to "null" (string with "null" as
content). In that case, the null checks were not met, and an actual check against the allowed
origins was done. This check failed and the error was shown in the log.

If the origin is empty, null or "null" the check does not need to be done.

---
M src/org/openbravo/base/secureApp/AllowedCrossDomainsHandler.java
---
(0107042)
hudsonbot (developer)
2018-09-26 19:47

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/95141753a1f0 [^]
Maturity status: Test
(0107083)
mtaal (manager)
2018-10-01 06:01

reviewed

- Issue History
Date Modified Username Field Change
2018-09-19 10:18 aaroncalero New Issue
2018-09-19 10:18 aaroncalero Assigned To => StoreServer
2018-09-19 10:18 aaroncalero Triggers an Emergency Pack => No
2018-09-26 11:51 AugustoMauch Assigned To StoreServer => AugustoMauch
2018-09-26 11:51 AugustoMauch Review Assigned To => mtaal
2018-09-26 11:52 hgbot Checkin
2018-09-26 11:52 hgbot Note Added: 0107035
2018-09-26 11:52 hgbot Status new => resolved
2018-09-26 11:52 hgbot Resolution open => fixed
2018-09-26 11:52 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5673d02fb2af158cd0f5325a38c83e9b96155e7d [^]
2018-09-26 19:47 hudsonbot Checkin
2018-09-26 19:47 hudsonbot Note Added: 0107042
2018-10-01 06:01 mtaal Note Added: 0107083
2018-10-01 06:01 mtaal Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker