Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039268
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2018-09-11 16:462018-09-27 16:26
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revision37eea9b878d6
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039268: Wrong accounting entry when reversing a prepayment against an order that was later invoiced

DescriptionWrong accounting entry when reversing a prepayment against an order that was later invoiced
Steps To ReproduceAs system admin role:
   Set Reverse Payment field from Payment In - Header tab

Compile the window and restart tomcat

As group admin role:
   Create a Sales Order
   Add a Payment in against it
   Post it (depending on the configuration you should post the financial account transaction or the reconciliation) and check customer prepayment account is used
   Create the related Sales Invoice
   Post it and check customer prepayment account is used and balanced
   Reverse the Payment In
   Post it and check customer prepayment account is used again
   Add a new Payment In
   Post it and check customer receivables account is used
   Both accounts get unbalanced
Proposed SolutionCheck if the reverse payment is not considered a prepayment as the order is already invoiced the problem is solved.

Reverse payment should not be considered a prepayment as there is already an invoice book.

Correct posting should be:
- Order - no posting
- Pre-payment
121.00 (In transit account, for instance) DEBIT
121.00 (Customer Prepayment) CREDIT

- Invoice
121.00 (Customer Prepayment) DEBIT
100.00 (Product Revenue) CREDIT
21.00 (Tax Credit ) Credit

- Reverse payment (this is the one that need to be fixed, and do not be considered as prepayment, because there is already an invoice related booked, therefore for this one the value of is prepayment = no)
121.00 (Customer Balance) DEBIT
121.00 (In transit account, for instance) CREDIT

- Therefore new payment posting will be correct.
121.00 (In transit account, for instance) DEBIT
121.00 (Customer Balance) CREDIT
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0106808)
markmm82 (developer)
2018-09-17 16:12

Test Plan:
As system admin role:
   Set displayed the Reverse Payment field from Payment In - Header tab

Compile the window and restart tomcat

As group admin role:
   Create a Sales Order for Alimentos y Supermercados bp.
   Add a Payment in against it
   Post it and check the posting looks like:
     - Pre-payment
     121.00 (In transit account, for instance) DEBIT
     121.00 (Customer Prepayment) CREDIT
   
   Create the related Sales Invoice.
   Post it and check customer prepayment account is used and balanced
     121.00 (Customer Prepayment) DEBIT
     100.00 (Product Revenue) CREDIT
     21.00 (Tax Credit ) Credit
      
   Reverse the Payment In
   Post it and check it is not considered a prepayment.
     121.00 (Customer Balance) DEBIT
     121.00 (In transit account, for instance) CREDIT

   Add a new Payment In
   Post it and check customer receivables account is used
     121.00 (In transit account, for instance) DEBIT
     121.00 (Customer Balance) CREDIT
   All accounts get balanced
(0107040)
hgbot (developer)
2018-09-26 17:59

Repository: erp/devel/pi
Changeset: 37eea9b878d6e7fcd0d9fbe67ac9ce5ab044f25d
Author: Mark <markmm82 <at> gmail.com>
Date: Tue Sep 25 09:44:32 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/37eea9b878d6e7fcd0d9fbe67ac9ce5ab044f25d [^]

Fixes issue 39268: Wrong accounting entry when reversing a prepayment against an
order that was later invoiced

In those cases the reversed payment was considered as prepayment and it was wrong
as the order is invoiced. To fix it the reversed payment detail is set as it is not
a prepayment in this case.

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0107041)
Sandrahuguet (developer)
2018-09-26 18:00

code review + testing OK
(0107054)
hudsonbot (developer)
2018-09-27 16:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d8242c6b0bfe [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-09-11 16:46 ngarcia New Issue
2018-09-11 16:46 ngarcia Assigned To => Triage Finance
2018-09-11 16:46 ngarcia Modules => Core
2018-09-11 16:46 ngarcia Triggers an Emergency Pack => No
2018-09-11 17:20 ngarcia Steps to Reproduce Updated View Revisions
2018-09-11 17:20 ngarcia Proposed Solution updated
2018-09-11 17:21 ngarcia Issue Monitored: networkb
2018-09-11 17:23 rafaroda Issue Monitored: rafaroda
2018-09-11 17:36 Sandrahuguet Assigned To Triage Finance => markmm82
2018-09-11 22:30 markmm82 Status new => scheduled
2018-09-14 18:23 markmm82 Note Added: 0106788
2018-09-17 13:25 psanjuan Proposed Solution updated
2018-09-17 13:27 psanjuan Proposed Solution updated
2018-09-17 15:10 markmm82 Note Deleted: 0106788
2018-09-17 16:12 markmm82 Note Added: 0106808
2018-09-26 17:59 hgbot Checkin
2018-09-26 17:59 hgbot Note Added: 0107040
2018-09-26 17:59 hgbot Status scheduled => resolved
2018-09-26 17:59 hgbot Resolution open => fixed
2018-09-26 17:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/37eea9b878d6e7fcd0d9fbe67ac9ce5ab044f25d [^]
2018-09-26 18:00 Sandrahuguet Review Assigned To => Sandrahuguet
2018-09-26 18:00 Sandrahuguet Note Added: 0107041
2018-09-26 18:00 Sandrahuguet Status resolved => closed
2018-09-26 18:00 Sandrahuguet Fixed in Version => 3.0PR18Q4
2018-09-27 16:26 hudsonbot Checkin
2018-09-27 16:26 hudsonbot Note Added: 0107054


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker