Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039168
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2018-08-22 13:512018-09-12 21:33
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revision686664db43e1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039168: A payment can be reversed more than once with slow network connection

DescriptionA payment can be reversed more than once with slow network connection
Steps To ReproduceAs system admin role:
   Set Reverse Payment field of Payment In - Header tab as Displayed

From command line:
   Stop tomcat
   Compile the window (as the displayed button contains a process)
   Start Tomcat

As group admin role:
   Create a sales order, add a product to it and book it
   Add Payment to it
   Go to Payment In window

   Set the browser's network as Slow 3G in Developer's Tools

   Select the previously created payment
   Click on Reverse Payment
   Add a payment date and OK
   Click Reverse Payment again (it should be made before it is hidden)
   Add a payment date and OK

   Check the original payment has been reversed twice and it should not
   Reversed Payment field in original payment is showing the second payment
   Reversed Payment field in second payment is showing the first payment
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0106550)
markmm82 (developer)
2018-08-30 21:35
edited on: 2018-08-30 21:39

Test Plan:
As system admin role:
   Set Reverse Payment field of Payment In - Header tab as Displayed

From command line:
   Stop tomcat
   Compile the window (as the displayed button contains a process)
   Start Tomcat

As group admin role:
   Create a sales order, add a product to it and book it
   Add Payment to it
   Go to Payment In window

   Set the browser's network as Slow 3G in Developer's Tools

   Select the previously created payment
   Click on Reverse Payment
   Add a payment date and OK
   Click Reverse Payment again (it should be made before it is hidden)
   Add a payment date and OK

   Check the original payment has been reversed just once. It is OK.
   Notice that an error message is shown:
     Error:
     This payment has been already reversed.


Notice it works similar for the Purchase workflow.

(0106655)
hgbot (developer)
2018-09-10 12:10

Repository: erp/devel/pi
Changeset: 686664db43e172291b526199b0e5c47c036be768
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Sep 06 10:14:53 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/686664db43e172291b526199b0e5c47c036be768 [^]

Fixes issue 39168: A payment can be reversed more than once with slow connection

Was possible to reverse a payment more than once with slow network connection.
It was caused because could be a time between the payment is reversed and the button
is hidden where it is possible to execute the process again. As the process of
reversing the payment happens in the server-side and the UI delay happens in the
Front-End the Reverse Payment button is hidden before setting up the parameters
so when the process is executed the second time the payment is already reversed
and linked to the reversed payment.
To avoid this bug, it is validated that the processing payment is not already reversed.
In case it is, then an error message is thrown explaining it is reversed.

---
M modules/org.openbravo.advpaymentmngt/src-db/database/sourcedata/AD_MESSAGE.xml
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/process/FIN_PaymentProcess.java
---
(0106656)
Sandrahuguet (developer)
2018-09-10 12:11

Code review + testing OK
(0106727)
hudsonbot (developer)
2018-09-12 21:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad75d3cb1744 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-08-22 13:51 ngarcia New Issue
2018-08-22 13:51 ngarcia Assigned To => Triage Finance
2018-08-22 13:51 ngarcia Modules => Core
2018-08-22 13:51 ngarcia Triggers an Emergency Pack => No
2018-08-22 13:58 ngarcia Issue Monitored: networkb
2018-08-23 08:48 aferraz Assigned To Triage Finance => AtulOpenbravo
2018-08-24 08:59 aferraz Assigned To AtulOpenbravo => Triage Finance
2018-08-24 22:19 markmm82 Assigned To Triage Finance => markmm82
2018-08-24 22:19 markmm82 Status new => acknowledged
2018-08-28 03:37 markmm82 Status acknowledged => scheduled
2018-08-30 21:35 markmm82 Note Added: 0106550
2018-08-30 21:39 markmm82 Note Edited: 0106550 View Revisions
2018-09-03 09:51 rafaroda Issue Monitored: rafaroda
2018-09-10 12:10 hgbot Checkin
2018-09-10 12:10 hgbot Note Added: 0106655
2018-09-10 12:10 hgbot Status scheduled => resolved
2018-09-10 12:10 hgbot Resolution open => fixed
2018-09-10 12:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/686664db43e172291b526199b0e5c47c036be768 [^]
2018-09-10 12:11 Sandrahuguet Review Assigned To => Sandrahuguet
2018-09-10 12:11 Sandrahuguet Note Added: 0106656
2018-09-10 12:11 Sandrahuguet Status resolved => closed
2018-09-10 12:11 Sandrahuguet Fixed in Version => 3.0PR18Q4
2018-09-12 21:33 hudsonbot Checkin
2018-09-12 21:33 hudsonbot Note Added: 0106727


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker