Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039167
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementminoralways2018-08-22 13:312019-03-28 19:29
ReporteraaroncaleroView Statuspublic 
Assigned Tomarkmm82 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q2
StatusclosedFix in branchFixed in SCM revision2bb85f24ae60
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039167: Characteristics labels in Update Characteristics popup can be clicked and raise a server error

DescriptionThe labels of the product characteristics that appear on the Update Characteristics popup (in the Product Window) can be clicked as if they were a link to another window/entity.
When the name of a characteristic doesn't match the name of an entity, however, a server error is raised and a javascript error is raised on the browser.
Steps To ReproduceLogin in backend: https://livebuilds.openbravo.com/erp_pi_pgsql [^]
Go to the Product Characteristic window and create a record:
*Name: Color
*Go to the Value tab and define two values:
**Red
**Blue
Select the Red value, click on the Add Products button, select the "Cerveza Ale 0,5L" product and click on Done.
Go to the Product window and find the "Cerveza Ale 0,5L" record.
Click on the Update Characteristics button.
Click on the "Color" label.

Verify that the following error appears in the tomcat log:
2018-08-22 13:22:34,150 [ajp-bio-127.0.0.1-8009-exec-80] ERROR org.openbravo.erpCommon.utility.ReferencedLink - Error captured:
org.openbravo.base.util.CheckException: Mapping name: Color not found in runtime model
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0110708)
markmm82 (developer)
2019-03-27 18:19
edited on: 2019-03-27 18:20

Test Plan:
As F&B Group Admin
  Go to the Product Characteristic window and create a record:
    Name: Color
  Go to the Value tab and define two values:
    Red
    Blue
  Select the Red value, click on the Add Products button, select the "Cerveza
  Ale 0,5L" product and click on Done.
  Go to the Product window and find the "Cerveza Ale 0,5L" record.
  Click on the Update Characteristics button.
  Click on the "Color" label.
    Notice you navigate to the Characteristic value with the selected value in the popup, for instance Red.
  Notice there aren't any warning in the browser console neither in eclipse.

(0110899)
hgbot (developer)
2019-03-28 15:12

Repository: erp/devel/pi
Changeset: 2bb85f24ae60921c2291e461d6d88699de94de14
Author: Mark Molina <mark.molina <at> doceleguas.com>
Date: Wed Mar 27 14:17:51 2019 -0300
URL: http://code.openbravo.com/erp/devel/pi/rev/2bb85f24ae60921c2291e461d6d88699de94de14 [^]

Fixes issue 39167: Characteristics labels hyperlink in Update Characteristics
popup can be clicked and raise a server error

Due to an incorrect definition of the target entity and reference column the navigation
from a Characteristic value in the Update Characteristic popup it was unable to redirect
to the right window and an exception was thrown in the backend.
This solution define 'CharacteristicValue' as the target entity and 'name' as referenced column.

---
M web/js/productCharacteristicsProcess.js
---
(0110900)
Sandrahuguet (developer)
2019-03-28 15:13

Code review + testing OK
(0110905)
hudsonbot (developer)
2019-03-28 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/faf4157296e1 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-08-22 13:31 aaroncalero New Issue
2018-08-22 13:31 aaroncalero Assigned To => Triage Finance
2018-08-22 13:31 aaroncalero Modules => Core
2018-08-22 13:31 aaroncalero Triggers an Emergency Pack => No
2019-01-11 10:18 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2019-01-11 11:00 Sandrahuguet Assigned To AtulOpenbravo => markmm82
2019-02-25 03:20 markmm82 Status new => scheduled
2019-03-27 18:19 markmm82 Note Added: 0110708
2019-03-27 18:20 markmm82 Note Edited: 0110708 View Revisions
2019-03-28 15:12 hgbot Checkin
2019-03-28 15:12 hgbot Note Added: 0110899
2019-03-28 15:12 hgbot Status scheduled => resolved
2019-03-28 15:12 hgbot Resolution open => fixed
2019-03-28 15:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2bb85f24ae60921c2291e461d6d88699de94de14 [^]
2019-03-28 15:13 Sandrahuguet Review Assigned To => Sandrahuguet
2019-03-28 15:13 Sandrahuguet Note Added: 0110900
2019-03-28 15:13 Sandrahuguet Status resolved => closed
2019-03-28 15:13 Sandrahuguet Fixed in Version => 3.0PR19Q2
2019-03-28 19:29 hudsonbot Checkin
2019-03-28 19:29 hudsonbot Note Added: 0110905


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker