Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039126
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2018-08-13 14:112018-09-27 18:18
ReporterngarciaView Statuspublic 
Assigned ToSandrahuguet 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revisionf6a34bc225f0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039126: Reconciliation without lines is created if the role does not have access to business partner's organization of the payment

DescriptionReconciliation without lines is created if the role does not have access to business partner's organization of the payment
Steps To ReproduceAs group admin role:
   Create a new Business Partner in F&B International Group
   Create a Payment In for F&B España, S.A. and that business partner
   Add an amount and do not select any document to be paid. Leave the amount as credit
   Check the payment has been deposited in a financial account
   Go to Role window and remove F&B International Group from Organization tab for the current role
   Log out and log in

   Go to Financial Account where the payment was deposited
   Leave the Matching Algorithm empty
   Click on Reconcile
   Select the previously created payment, select Cleared checkbox, edit the Ending Balance and Reconcile

   Check a new reconciliation has been created with Completed status but the transaction related with the payment has not been included on it

   The log shows:
      ERROR org.openbravo.base.exception.OBSecurityException - Organization <id> of object (BusinessPartner(<id>) (name: A)) is not present in OrganizationList [...]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039290 closedAtulOpenbravo Business Partner current balance is wrongly updated when using Reconciliation 

-  Notes
(0106790)
AtulOpenbravo (developer)
2018-09-17 06:42

Test Plan

- Loign as F&B International Group admin role:
- Create a new Business Partner in F&B International Group
- Create a Payment In for F&B España, S.A. and that business partner
- Add an amount =100 and do not select any document to be paid. Leave the amount as credit
- Check the payment has been deposited in a financial account
- Go to Role window and remove F&B International Group from Organization tab for the current role
- Log out and log in
- Go to Financial Account where the payment was deposited
- Leave the Matching Algorithm empty
- Click on Reconcile button
- Select the previously created payment, select Cleared checkbox, edit the Ending Balance and Reconcile
- Check a new reconciliation has been created with Completed status and transaction related with the payment has been included in it.
(0107046)
hgbot (developer)
2018-09-27 12:17

Repository: erp/devel/pi
Changeset: f6a34bc225f0a5e8c8c829664d4e22785574ce15
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Thu Sep 27 12:17:44 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f6a34bc225f0a5e8c8c829664d4e22785574ce15 [^]

Fixed issue 39126 Force flush in reconciliation process

Force flush because eventhandler is executed in the first flush
and data updated in enventhandler needs to be flush in a admin mode block

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ad_actionbutton/Reconciliation.java
---
(0107055)
hudsonbot (developer)
2018-09-27 16:26

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/d8242c6b0bfe [^]
Maturity status: Test
(0107058)
AugustoMauch (developer)
2018-09-27 18:17

Fix reviewed and verified.

Right now there is no way that data created in an event handler is flushed within a setAdminMode block unless a flush is done immediately after

- Issue History
Date Modified Username Field Change
2018-08-13 14:11 ngarcia New Issue
2018-08-13 14:11 ngarcia Assigned To => Triage Finance
2018-08-13 14:11 ngarcia Modules => Core
2018-08-13 14:11 ngarcia Triggers an Emergency Pack => No
2018-08-13 14:13 ngarcia Issue Monitored: networkb
2018-08-14 09:11 dmiguelez Assigned To Triage Finance => AtulOpenbravo
2018-08-14 09:14 AtulOpenbravo Status new => scheduled
2018-09-13 20:28 AtulOpenbravo Relationship added related to 0039290
2018-09-17 06:42 AtulOpenbravo Note Added: 0106790
2018-09-27 12:10 Sandrahuguet Assigned To AtulOpenbravo => Sandrahuguet
2018-09-27 12:17 hgbot Checkin
2018-09-27 12:17 hgbot Note Added: 0107046
2018-09-27 12:17 hgbot Status scheduled => resolved
2018-09-27 12:17 hgbot Resolution open => fixed
2018-09-27 12:17 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f6a34bc225f0a5e8c8c829664d4e22785574ce15 [^]
2018-09-27 16:26 hudsonbot Checkin
2018-09-27 16:26 hudsonbot Note Added: 0107055
2018-09-27 18:18 AugustoMauch Note Added: 0107058
2018-09-27 18:18 AugustoMauch Status resolved => closed
2018-09-27 18:18 AugustoMauch Fixed in Version => 3.0PR18Q4
2018-09-27 18:18 AugustoMauch Review Assigned To => AugustoMauch


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker