Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038816
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajoralways2018-06-22 13:382018-08-08 13:06
ReporteranderarangurenView Statuspublic 
Assigned Tocollazoandy4 
PriorityhighResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revision7d1b4e0de850
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Web browserGoogle Chrome
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038816: Sales Invoice Dimensional Report of a Product Category checked as summary level does not show data.

DescriptionSales Invoice Dimensional Report of a Product Category checked as summary level does not show data.
Steps To Reproduce-Log in the backoffice
-Go to Product Category window and ensure there is a summary level category with some categories below it.
- Go to Sales Invoice Dimensional Report window
- Select in Product Group the summary level checked product category
- Press the HTML Format Button
No data has been found.
TagsNo tags attached.
Attached Filespng file icon NoData.png [^] (37,319 bytes) 2018-06-22 13:38


png file icon SalesInvoiceDimReport.png [^] (104,685 bytes) 2018-06-22 13:39

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0038839 newTriage Finance Reports of a Product Category checked as summary level does not show data. 

-  Notes
(0105456)
collazoandy4 (developer)
2018-06-26 20:54

Test Plan
  As F&B International Group Admin Role
    Go to Product Category window and create a new record:
      Search Key/Name: Summary
      Summary Level: Y
      Set Water, Alcoholic and Fruit juice categories under Summary category
    Go to Sales Invoice Dimensional Report and fill the mandatory fields and select Summary as Product Group
      Launch the report in HTML, PDF and XLS formats, check the report shows data
      Set Comparative Report: Y and fill the mandatory fields
      Launch the report in HTML, PDF and XLS formats, check the report shows data
(0105679)
hgbot (developer)
2018-07-09 15:59

Repository: erp/devel/pi
Changeset: 7d1b4e0de850238cf47004b0520ac9f74a006a84
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jun 26 12:18:58 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/7d1b4e0de850238cf47004b0520ac9f74a006a84 [^]

Fixes issue 38816:Sales Invoice Dimensional Report of a Product Category checked
as summary level does not show data.

If the product category checked as summary with some categories below it is selected
the report doesn't show data because does not take into account the hierarchy

The Report take into account the product category hierarchy to filter the categories

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesComparativeJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesJR.java
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesJR_data.xsql
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesMultiComparativeExtendedJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesMultiComparativeJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesNoComparativeJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
M src/org/openbravo/erpCommon/businessUtility/Tree.java
M src/org/openbravo/erpCommon/businessUtility/Tree_data.xsql
---
(0105681)
Sandrahuguet (developer)
2018-07-09 16:02

Code review + testing OK
(0106209)
hudsonbot (developer)
2018-08-08 13:06

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bfd7a414183a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-06-22 13:38 anderaranguren New Issue
2018-06-22 13:38 anderaranguren Assigned To => Triage Finance
2018-06-22 13:38 anderaranguren File Added: NoData.png
2018-06-22 13:38 anderaranguren Web browser => Google Chrome
2018-06-22 13:38 anderaranguren Modules => Core
2018-06-22 13:38 anderaranguren Triggers an Emergency Pack => No
2018-06-22 13:39 anderaranguren File Added: SalesInvoiceDimReport.png
2018-06-22 13:54 Practics Issue Monitored: Practics
2018-06-25 08:29 Sandrahuguet Assigned To Triage Finance => collazoandy4
2018-06-25 22:18 collazoandy4 Status new => scheduled
2018-06-26 15:58 collazoandy4 Relationship added related to 0038839
2018-06-26 20:54 collazoandy4 Note Added: 0105456
2018-07-09 15:59 hgbot Checkin
2018-07-09 15:59 hgbot Note Added: 0105679
2018-07-09 15:59 hgbot Status scheduled => resolved
2018-07-09 15:59 hgbot Resolution open => fixed
2018-07-09 15:59 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7d1b4e0de850238cf47004b0520ac9f74a006a84 [^]
2018-07-09 16:02 Sandrahuguet Review Assigned To => Sandrahuguet
2018-07-09 16:02 Sandrahuguet Note Added: 0105681
2018-07-09 16:02 Sandrahuguet Status resolved => closed
2018-07-09 16:02 Sandrahuguet Fixed in Version => 3.0PR18Q4
2018-08-08 13:06 hudsonbot Checkin
2018-08-08 13:06 hudsonbot Note Added: 0106209


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker