Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038771
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-06-15 14:522019-01-08 13:51
Reportergorka_gilView Statuspublic 
Assigned Toranjith_qualiantech_com 
PrioritynormalResolutionfixedFixed in Version
StatusresolvedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038771: Test ReimburseCard is failing, not clear if failure of the test or failure in the pos

DescriptionERROR:
The test is failing in line 186 : assertEquals(31.1, rs.getDouble("totaldeposits"), DELTA);

Right now is getting totaldeposits : 0 instead 31.1

DESCRIPTION:
The test do a reimburse of a gift card, and the question if it should create a cash event or not.


DETAILS:
- The tests is in unstable status, so not running at least from February 2.
So a change in the code could be from time ago.
- The tests assumes that it should create a cash event, and this is probably correct, but need to verify if this is correct. Or the functionally has change for a reason, or accident, or simply the test was wrong from the beggining.
Steps To ReproduceRun test ReimburseCard in local.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039780 closedranjith_qualiantech_com Giftcards are not consumed in a reimburse until the related cash management is finally processed in the server 

-  Notes
(0107332)
hgbot (developer)
2018-10-16 13:52

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 7e8784db93445ce848d86fa2766e0f6922664476
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Oct 16 17:22:24 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/7e8784db93445ce848d86fa2766e0f6922664476 [^]

Related to issue 38771 : Cash Total Drop should be updated whe reimburse the gift certificate

* When Gift Certificate is reimburse in Cash Management, reimbursed amount should be added to Cash Withdrawal(totalDrops)

---
M web/org.openbravo.retail.giftcards/js/hooks/preSaveCashManagementsHook.js
---
(0107451)
hgbot (developer)
2018-10-19 07:57

Repository: tools/automation/pi-mobile
Changeset: 0a39f998b03bc70423fe8be2678d737dd06770c0
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Oct 17 11:29:17 2018 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/0a39f998b03bc70423fe8be2678d737dd06770c0 [^]

Verifies issue 38771 : Modified Test 'ReimburseCard'

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/ReimburseCard.java
---
(0108787)
gorka_gil (administrator)
2019-01-02 15:15

Now in quarantine is failing the opposite:
Is expecting 0 but it gets 31.1.


https://ci.openbravo.com/view/retail-qa/job/ret-qa-modules-pgsql-suite1/4546/testReport/junit/org.openbravo.test.mobile.retail.extmodules.selenium.tests.giftcards/ReimburseCard/test/ [^]
(0108811)
hgbot (developer)
2019-01-03 12:00

Repository: tools/automation/pi-mobile
Changeset: 009c5e008b882968d89e140566fd7fa18b4b12ef
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Thu Jan 03 11:59:44 2019 +0100
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/009c5e008b882968d89e140566fd7fa18b4b12ef [^]

Related to issue 38771: disable test till the issue is fixed

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/ReimburseCard.java
---
(0108848)
hgbot (developer)
2019-01-07 18:02

Repository: tools/automation/pi-mobile
Changeset: 83f8e020c5f827bba66d60e52daeb36916d74aa3
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Mon Jan 07 22:31:34 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/83f8e020c5f827bba66d60e52daeb36916d74aa3 [^]

Verifies issue 38771 : Enabled Automated Test 'ReimburseCard'

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/ReimburseCard.java
---
(0108853)
hgbot (developer)
2019-01-08 13:51

Repository: tools/automation/pi-mobile
Changeset: b4dc96109050ee93ec3f1490a014343e364276b9
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 08 18:20:47 2019 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/b4dc96109050ee93ec3f1490a014343e364276b9 [^]

Verifies issue 38771 : Modified Automated Test 'ReimburseCard'

* Removed waitFixOf annotation

---
M src-test/org/openbravo/test/mobile/retail/extmodules/selenium/tests/giftcards/ReimburseCard.java
---

- Issue History
Date Modified Username Field Change
2018-06-15 14:52 gorka_gil New Issue
2018-06-15 14:52 gorka_gil Assigned To => Retail
2018-06-15 14:52 gorka_gil Triggers an Emergency Pack => No
2018-10-15 11:07 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-10-15 11:08 ranjith_qualiantech_com Status new => scheduled
2018-10-16 13:52 hgbot Checkin
2018-10-16 13:52 hgbot Note Added: 0107332
2018-10-19 07:57 hgbot Checkin
2018-10-19 07:57 hgbot Note Added: 0107451
2018-10-19 08:39 ranjith_qualiantech_com Status scheduled => resolved
2018-10-19 08:39 ranjith_qualiantech_com Resolution open => fixed
2018-10-29 11:55 marvintm Review Assigned To => marvintm
2018-10-29 11:55 marvintm Status resolved => closed
2018-10-29 11:55 marvintm Fixed in Version => RR19Q1
2019-01-02 15:15 gorka_gil Note Added: 0108787
2019-01-02 15:15 gorka_gil Status closed => new
2019-01-02 15:15 gorka_gil Resolution fixed => open
2019-01-02 15:15 gorka_gil Fixed in Version RR19Q1 =>
2019-01-03 12:00 hgbot Checkin
2019-01-03 12:00 hgbot Note Added: 0108811
2019-01-04 07:52 ranjith_qualiantech_com Relationship added related to 0039780
2019-01-04 10:46 ranjith_qualiantech_com Status new => scheduled
2019-01-07 18:02 hgbot Checkin
2019-01-07 18:02 hgbot Note Added: 0108848
2019-01-07 18:03 ranjith_qualiantech_com Status scheduled => resolved
2019-01-07 18:03 ranjith_qualiantech_com Resolution open => fixed
2019-01-08 13:51 hgbot Checkin
2019-01-08 13:51 hgbot Note Added: 0108853


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker