Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038552
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Return Receiptmajoralways2018-05-15 23:322018-06-25 22:49
ReportergsuarezView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR18Q3
StatusclosedFix in branchFixed in SCM revisiond9c49a28865b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionRR18Q1.2SCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038552: Error when using Credit to do a Reverse Payment on a Return

DescriptionWhen a Reverse Payment is done on a Return from Customer (for which the money has been returned), the Payment Plan related with the Return remains with incorrect values
Steps To Reproduce1. Process an Order in the Web POS.
2. Return the Order created in the step 1 (Also returning the money)
3. Search in the Web POS the Return generated in the step 2, and generate a Reverse Payment using the button Use Credit.
4. Observe in the ERP that the Payment Plan related with the Return has incorrect values.

For further details you can watch the following video where the issue is reproduced: https://www.youtube.com/watch?v=XwVMftyOBdA&feature=youtu.be [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0105123)
hgbot (developer)
2018-06-13 11:49

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: d9c49a28865b230eae6e3bfe6ef37eeb95289033
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Jun 13 15:18:56 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9c49a28865b230eae6e3bfe6ef37eeb95289033 [^]

Fixed issue 38552 : Validate Payment Schedule Details for Credit payments

* For Credit Payments, Payment Schedule Details Amoount should be updated properly for reverse payments

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
M web/org.openbravo.retail.posterminal/js/model/order.js
---

- Issue History
Date Modified Username Field Change
2018-05-15 23:32 gsuarez New Issue
2018-05-15 23:32 gsuarez Assigned To => Retail
2018-05-15 23:32 gsuarez Triggers an Emergency Pack => No
2018-05-16 08:21 Practics Issue Monitored: Practics
2018-05-30 19:25 gsuarez Summary Error al utilizar crédito para hacer un Pago Inverso sobre una Devolución => Error when using Credit to do a Reverse Payment on a Return
2018-05-30 19:25 gsuarez Description Updated View Revisions
2018-05-30 19:25 gsuarez Steps to Reproduce Updated View Revisions
2018-06-11 12:56 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-06-11 12:56 ranjith_qualiantech_com Status new => scheduled
2018-06-13 11:49 hgbot Checkin
2018-06-13 11:49 hgbot Note Added: 0105123
2018-06-13 11:49 hgbot Status scheduled => resolved
2018-06-13 11:49 hgbot Resolution open => fixed
2018-06-13 11:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/d9c49a28865b230eae6e3bfe6ef37eeb95289033 [^]
2018-06-18 09:32 marvintm Review Assigned To => marvintm
2018-06-18 09:32 marvintm Status resolved => closed
2018-06-18 09:32 marvintm Fixed in Version => RR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker