Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038548
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2018-05-14 18:572018-05-21 18:36
ReporterAtulOpenbravoView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisiond0cc878c5657
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-03-07
Regression introduced in release3.0PR18Q2
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2a79f597da83 [^]
Triggers an Emergency PackNo
Summary

0038548: Default Expression in Selector Field does not work properly

DescriptionDefault expression in the selector field does not work properly.

for eg: In Goods Movement window, Stocked column in grid of Product selector should have default filter as Stocked = Yes

Expression used in reference: "Product Complete" | Defined Selector | Field | Stocked

if (OB.getWindowId() == '800051' ||
    OB.getWindowId() == '800052' ||
    OB.getWindowId() == '800096' ||
    OB.getWindowId() == '800027') {
  false
} else {
    if (OB.isSalesTransaction() == true || OB.getWindowId() == '170') {
      true
    } else {
        false
    }
}

However it does not work in latest pi.
Steps To ReproduceTest Plan

- Go to Goods Movement window and create a new record. Fill mandatory fields
- Go to Lines tab and create a new record.
- Press magnifying glass in Product selector.
- Check default filter in Stocked column of selector does not have filter applied as Stocked = Yes.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00385563.0PR18Q2.1 closedcaristu Default Expression in Selector Field does not work properly 
caused by defect 00380613.0PR18Q2 closedalostale Selector filter expression with OB.isSalesTransaction() doesn't work when called from a Process Definition 
has duplicate defect 0038784 closedplatform Sales order line's product selector doesn't filter by warehouse 
blocks defect 0038522 scheduledAtulOpenbravo Product Selector in Goods Shipment Line should be automatically filtered by the selected product if "Create Lines From" is used. 

-  Notes
(0104559)
hgbot (developer)
2018-05-17 10:20

Repository: erp/devel/pi
Changeset: d0cc878c56579383583de589f4a031563098d47c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu May 17 10:05:57 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d0cc878c56579383583de589f4a031563098d47c [^]

fixes issue 38548: Default Expression in Selector Field does not work properly

  After the changes introduced with[1] the request data is send to the SelectorDefaultFilterActionHandler as part of the POST payload rather than in the query string. This caused that the selector id was not being found in that handler, avoiding the correct processing of the data.

  The problem has been fixed by retrieving the data to process both from the request parameters and content.

[1] https://code.openbravo.com/erp/devel/pi/rev/2a79f597da83870d152ee3176ffa679a01ac19d5 [^]

---
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorDefaultFilterActionHandler.java
---
(0104560)
hgbot (developer)
2018-05-17 10:30

Repository: erp/devel/pi
Changeset: 4b209651d928dfccdad27e585bce7c003c7b5fc6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu May 17 10:28:43 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4b209651d928dfccdad27e585bce7c003c7b5fc6 [^]

related to issue 38548: minor code improvements

  Using the correct alternative when applies:
    - Use isEmpty() to check whether the collection is empty or not
    - Use diamond operator
    - Iterate over the "entrySet" instead of the "keySet"

---
M modules/org.openbravo.userinterface.selector/src/org/openbravo/userinterface/selector/SelectorDefaultFilterActionHandler.java
---
(0104573)
hgbot (developer)
2018-05-17 18:46

Repository: erp/devel/pi
Changeset: 22d3347bafe77dcadc2079753b4d3979bbb0eb34
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu May 17 18:44:14 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/22d3347bafe77dcadc2079753b4d3979bbb0eb34 [^]

related to issue 38548: added test case

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
M src-test/src/org/openbravo/test/datasource/DatasourceTestUtil.java
A src-test/src/org/openbravo/test/selector/TestSelectorDefaultFilterActionHandler.java
---
(0104578)
hudsonbot (developer)
2018-05-17 21:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4e28963f0fe6 [^]
Maturity status: Test
(0104579)
hudsonbot (developer)
2018-05-17 21:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/4e28963f0fe6 [^]
Maturity status: Test
(0104585)
alostale (developer)
2018-05-18 09:06

reviewed + tested
(0104620)
hudsonbot (developer)
2018-05-21 18:36

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/915bf19e1d5b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-05-14 18:57 AtulOpenbravo New Issue
2018-05-14 18:57 AtulOpenbravo Assigned To => platform
2018-05-14 18:57 AtulOpenbravo Modules => Core
2018-05-14 18:57 AtulOpenbravo Triggers an Emergency Pack => No
2018-05-14 18:58 AtulOpenbravo Relationship added caused by 0038061
2018-05-14 19:00 AtulOpenbravo Description Updated View Revisions
2018-05-14 19:02 aferraz Regression level => Production - QA Approved
2018-05-14 19:02 aferraz Regression introduced in release => 3.0PR18Q2
2018-05-14 19:03 aferraz Regression date => 2018-03-07
2018-05-14 19:03 aferraz Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2a79f597da83 [^]
2018-05-14 19:27 aferraz Relationship added blocks 0038522
2018-05-16 09:26 caristu Assigned To platform => caristu
2018-05-16 09:28 caristu Status new => scheduled
2018-05-17 10:20 hgbot Checkin
2018-05-17 10:20 hgbot Note Added: 0104559
2018-05-17 10:20 hgbot Status scheduled => resolved
2018-05-17 10:20 hgbot Resolution open => fixed
2018-05-17 10:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d0cc878c56579383583de589f4a031563098d47c [^]
2018-05-17 10:21 caristu Review Assigned To => alostale
2018-05-17 10:30 hgbot Checkin
2018-05-17 10:30 hgbot Note Added: 0104560
2018-05-17 18:46 hgbot Checkin
2018-05-17 18:46 hgbot Note Added: 0104573
2018-05-17 21:41 hudsonbot Checkin
2018-05-17 21:41 hudsonbot Note Added: 0104578
2018-05-17 21:41 hudsonbot Checkin
2018-05-17 21:41 hudsonbot Note Added: 0104579
2018-05-18 09:06 alostale Note Added: 0104585
2018-05-18 09:06 alostale Status resolved => closed
2018-05-18 09:06 alostale Fixed in Version => 3.0PR18Q3
2018-05-21 18:36 hudsonbot Checkin
2018-05-21 18:36 hudsonbot Note Added: 0104620
2018-06-20 09:48 caristu Relationship added has duplicate 0038784


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker