Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038271
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialhave not tried2018-04-04 16:592018-05-09 19:29
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision5e575bc53464
ProjectionnoneETAnoneTarget Version
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2018-04-04
Regression introduced in releasepi
Regression introduced by commithttp://code.openbravo.com/erp/devel/pi/rev/f0156943cb5e389e280ff5cfc82a62bbcbec97a1 [^]
Triggers an Emergency PackNo
Summary

0038271: pg connections set "PostgreSQL JDBC Driver" as application name

DescriptionAfter fix for 0038269, application name in PostgreSQL is set to "PostgreSQL JDBC Driver", before was not set.
Steps To Reproduce- Start Openbravo
- Execute select * from pg_stat_activity
  -> check application_name field is PostgreSQL JDBC Driver
Proposed SolutionThis is a change introduced in recent jdbc versions [1], having default name is not significant at all, so proposal is to change it to "openbravo"

---
[1] https://github.com/pgjdbc/pgjdbc/pull/668/files#diff-9c1bd193fba088d6998a42dbc12c7b53L284 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0038269 closedalostale parallel export.sampledata can get stuck 

-  Notes
(0103678)
hgbot (developer)
2018-04-04 17:01

Repository: erp/devel/pi
Changeset: 5e575bc53464c7d096a824920f01baa0cee6c4a5
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Apr 04 17:00:51 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5e575bc53464c7d096a824920f01baa0cee6c4a5 [^]

fixed bug 38271: pg connections set "PostgreSQL JDBC Driver" as app name

  New jdbc sets it by default, changed it to "openbravo"

---
M modules/org.openbravo.apachejdbcconnectionpool/src/org/openbravo/apachejdbcconnectionpool/JdbcExternalConnectionPool.java
---
(0103688)
AugustoMauch (developer)
2018-04-05 11:30

Code reviewed and verified
(0104363)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-04-04 16:59 alostale New Issue
2018-04-04 16:59 alostale Assigned To => alostale
2018-04-04 16:59 alostale Modules => Core
2018-04-04 16:59 alostale Regression level => Coding ( Testing )
2018-04-04 16:59 alostale Regression date => 2018-04-04
2018-04-04 16:59 alostale Regression introduced in release => pi
2018-04-04 16:59 alostale Regression introduced by commit => http://code.openbravo.com/erp/devel/pi/rev/f0156943cb5e389e280ff5cfc82a62bbcbec97a1 [^]
2018-04-04 16:59 alostale Triggers an Emergency Pack => No
2018-04-04 16:59 alostale Relationship added caused by 0038269
2018-04-04 16:59 alostale Review Assigned To => AugustoMauch
2018-04-04 17:01 hgbot Checkin
2018-04-04 17:01 hgbot Note Added: 0103678
2018-04-04 17:01 hgbot Status new => resolved
2018-04-04 17:01 hgbot Resolution open => fixed
2018-04-04 17:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5e575bc53464c7d096a824920f01baa0cee6c4a5 [^]
2018-04-05 11:30 AugustoMauch Note Added: 0103688
2018-04-05 11:30 AugustoMauch Status resolved => closed
2018-04-05 11:30 AugustoMauch Fixed in Version => 3.0PR18Q3
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104363


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker