Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038240
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2018-03-28 08:142018-05-09 19:29
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisionfa5700b5eeb2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038240: Wrong average cost for production products, Total Movement Quantity is not correct

DescriptionWrong average cost for production products, Total Movement Quantity is not correct
Steps To ReproduceAs group admin role:
   Unschedule Costing Background Process
   Create a new product in 'F&B International Group'
   Set it as Production
   Add the following prices:
      Be Soft Drinker Price List: 4.06
      Tarifa Bebidas Alegres: 0
      General Sales: 6
   Create a purchase order for 'F&B US East Coast', add 12 units of the product and book it
   Create the related Goods Receipt
   Create a purchase order for 'F&B US East Coast', add 8 units of the product and book it
   Create the related Goods Receipt
   Create a Goods shipment for 'F&B US East Coast', add 10 units of the product and complete it
   Create a purchase order for 'F&B España - Región Norte', add 10 units of the product and book it
   Create the related Goods Receipt

   Schedule the Costing Bacground Process to be run immediately

   Check the latest average cost for the product is 2.71 and it should be 2.03
   Total Movement Quantity is 30 and it should be 20 and Total Stock Valuation is 81.20 and it should be 40.60
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0103919)
collazoandy4 (developer)
2018-04-16 22:25

Test Plan
  As group admin role:
   Unschedule Costing Background Process
   Go to Product window and create a new record:
     Search Key/Name: 38240
     Production: Y
     Create three new records in Price tab:
       Be Soft Drinker Price List: 4.06
       Tarifa Bebidas Alegres: 0
       General Sales: 6
   Create a purchase order for 'F&B US East Coast', add 12 units of the product and book it
   Create the related Goods Receipt
   Create a purchase order for 'F&B US East Coast', add 8 units of the product and book it
   Create the related Goods Receipt
   Create a Goods shipment for 'F&B US East Coast', add 10 units of the product and complete it
   Create a purchase order for 'F&B España - Región Norte', add 10 units of the product and book it
   Create the related Goods Receipt
   Go to Process Request window and schedule the Costing Bacground Process to be run immediately
   Go to Product Costing tab and check:
     The latest average cost is 2.03
     Total Movement Quantity is 20
     Total Stock Valuation is 40.60
(0103974)
hgbot (developer)
2018-04-18 16:35

Repository: erp/devel/pi
Changeset: fa5700b5eeb2c9fb774938ac813763c39dd1c2b1
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Mon Apr 16 15:59:24 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/fa5700b5eeb2c9fb774938ac813763c39dd1c2b1 [^]

Fixes issue 38240: Wrong average cost for production products, Total Movement
Quantity is not correct

Wrong average cost for production products, Total Movement Quantity and Total Stock
Valuation is not correct because the cost for production is calculated at client level
and the stock and stock valuation was filtering by Legal Entity.

Now the stock and stock valuation is filtered by client level for production products

---
M src/org/openbravo/costing/CostingUtils.java
---
(0103975)
dmiguelez (developer)
2018-04-18 16:36

Code Review + Testing Ok
(0104390)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-28 08:14 ngarcia New Issue
2018-03-28 08:14 ngarcia Assigned To => Triage Finance
2018-03-28 08:14 ngarcia Modules => Core
2018-03-28 08:14 ngarcia Triggers an Emergency Pack => No
2018-03-28 08:14 ngarcia Issue Monitored: networkb
2018-04-03 16:08 dmiguelez Assigned To Triage Finance => collazoandy4
2018-04-05 22:47 collazoandy4 Status new => scheduled
2018-04-16 22:25 collazoandy4 Note Added: 0103919
2018-04-18 16:35 hgbot Checkin
2018-04-18 16:35 hgbot Note Added: 0103974
2018-04-18 16:35 hgbot Status scheduled => resolved
2018-04-18 16:35 hgbot Resolution open => fixed
2018-04-18 16:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fa5700b5eeb2c9fb774938ac813763c39dd1c2b1 [^]
2018-04-18 16:36 dmiguelez Review Assigned To => dmiguelez
2018-04-18 16:36 dmiguelez Note Added: 0103975
2018-04-18 16:36 dmiguelez Status resolved => closed
2018-04-18 16:36 dmiguelez Fixed in Version => 3.0PR18Q3
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104390


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker