Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038214
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-03-26 09:162018-05-25 12:30
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionf72f1d84d5b0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038214: -Xdoclint:-missing is also required to build the javadoc in jdk8

DescriptionAs part of the fix for issue 0038130 the "-Xdoclint:-missing" argument was added to the generate.java.doc.jdk9 task.

Using this argument, the javadoc performs all "standard" doclint checks but disables "missing" category. This is also required for generating the javadoc in jdk8.
Steps To Reproduce.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0038130 closedcaristu support JDK 11 
related to defect 0038630 closedcaristu Specify the HTML version to use when building the javadoc 

-  Notes
(0103488)
hgbot (developer)
2018-03-26 09:20

Repository: erp/devel/pi
Changeset: 5a2eed8a9dad170c475f3a85e806d295c88a7e2a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Mar 26 09:19:04 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5a2eed8a9dad170c475f3a85e806d295c88a7e2a [^]

fixes bug 38214: -Xdoclint:-missing required for generate.java.doc.jdk7 task

---
M build.xml
---
(0103491)
hgbot (developer)
2018-03-26 09:26

Repository: erp/devel/pi
Changeset: 83848754ecfdbed1f19b86b76240cd1db6cbc7fb
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Mar 26 09:24:59 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/83848754ecfdbed1f19b86b76240cd1db6cbc7fb [^]

related to bug 38214: revert previous changeset due to a failure in the task

---
M build.xml
---
(0103564)
hgbot (developer)
2018-03-27 13:53

Repository: erp/devel/pi
Changeset: f72f1d84d5b087d1e33dc78fc31d5eb845cc9541
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Mar 27 13:49:57 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f72f1d84d5b087d1e33dc78fc31d5eb845cc9541 [^]

fixes bug 38214: -Xdoclint:-missing required for generate javadoc in jdk8

 - Added -Xdoclint:-missing argument when generating the javadoc, unless we are in jdk7.
 - Unified the generate.java.doc.jdk7 and generate.java.doc.jdk9 tasks, since [1] it is no longer needed to have those separate tasks.

[1] https://code.openbravo.com/erp/devel/pi/rev/c3a604592d8f59346c6a17cc7c511566602dc23c [^]

---
M build.xml
---
(0103617)
alostale (developer)
2018-03-28 17:17

reviewed
(0103628)
hudsonbot (developer)
2018-03-29 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ead4656f507e [^]
Maturity status: Test
(0103630)
hudsonbot (developer)
2018-03-29 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ead4656f507e [^]
Maturity status: Test
(0103636)
hudsonbot (developer)
2018-03-29 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ead4656f507e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-26 09:16 caristu New Issue
2018-03-26 09:16 caristu Assigned To => platform
2018-03-26 09:16 caristu Modules => Core
2018-03-26 09:16 caristu Triggers an Emergency Pack => No
2018-03-26 09:16 caristu Assigned To platform => caristu
2018-03-26 09:17 caristu Relationship added related to 0038130
2018-03-26 09:18 caristu Description Updated View Revisions
2018-03-26 09:18 caristu Description Updated View Revisions
2018-03-26 09:20 hgbot Checkin
2018-03-26 09:20 hgbot Note Added: 0103488
2018-03-26 09:20 hgbot Status new => resolved
2018-03-26 09:20 hgbot Resolution open => fixed
2018-03-26 09:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/5a2eed8a9dad170c475f3a85e806d295c88a7e2a [^]
2018-03-26 09:20 caristu Review Assigned To => alostale
2018-03-26 09:26 hgbot Checkin
2018-03-26 09:26 hgbot Note Added: 0103491
2018-03-26 10:27 caristu Status resolved => new
2018-03-26 10:27 caristu Resolution fixed => open
2018-03-26 10:29 caristu Summary -Xdoclint:-missing is also required for the generate.java.doc.jdk7 task => -Xdoclint:-missing is also required to build the javadoc in jdk8
2018-03-26 10:29 caristu Description Updated View Revisions
2018-03-27 13:53 hgbot Checkin
2018-03-27 13:53 hgbot Note Added: 0103564
2018-03-27 13:53 hgbot Status new => resolved
2018-03-27 13:53 hgbot Resolution open => fixed
2018-03-27 13:53 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/5a2eed8a9dad170c475f3a85e806d295c88a7e2a [^] => http://code.openbravo.com/erp/devel/pi/rev/f72f1d84d5b087d1e33dc78fc31d5eb845cc9541 [^]
2018-03-28 17:17 alostale Note Added: 0103617
2018-03-28 17:17 alostale Status resolved => closed
2018-03-28 17:17 alostale Fixed in Version => 3.0PR18Q2
2018-03-29 13:07 hudsonbot Checkin
2018-03-29 13:07 hudsonbot Note Added: 0103628
2018-03-29 13:07 hudsonbot Checkin
2018-03-29 13:07 hudsonbot Note Added: 0103630
2018-03-29 13:07 hudsonbot Checkin
2018-03-29 13:07 hudsonbot Note Added: 0103636
2018-05-25 12:30 caristu Issue cloned 0038630
2018-05-25 12:30 caristu Relationship added related to 0038630


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker