Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038159
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] I. Performancemajoralways2018-03-16 12:232018-09-25 14:16
ReporterjarmendarizView Statuspublic 
Assigned Tojarmendariz 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revisiona7149d379ac1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038159: Possible memory leak in Referenced Inventory Unbox process

DescriptionAfter some time using the Unbox Window in Referenced Inventory, both the CPU and the memory usage increases until it fills all memory available leaving the system unusable.
Steps To ReproduceAs F&B Admin:
- In Referenced Inventory Type create a new record for F&B US
- In Referenced Inventory create a new record for organization F&B US West. Link to previously created type. Press OK.
- Press the Box button and select any line with any quantity, press OK
- Press the Unbox button
Select the line and use the Storage Bin selector. After a time the CPU and memory usage starts to increase.
TagsPerformance
Attached Filespng file icon heap.png [^] (55,988 bytes) 2018-03-16 12:52

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00380393.0PR18Q2 closedjarmendariz Organization filtering issues in Process Definition selectors 

-  Notes
(0103316)
jarmendariz (developer)
2018-03-16 13:00

Attached dev tool's performance monitor shows js heap memory during ~1 minute of Unbox button usage.

In the following link, there are js head dumps before, during, and after the memory leak:

https://drive.google.com/open?id=1mYBmtD9GmCv1ESO2pWLf6BMQTkAWR6_5 [^]
(0106957)
hgbot (developer)
2018-09-24 12:26

Repository: erp/devel/pi
Changeset: a7149d379ac19c9857de5adc89c9a69dfa1b4548
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Mon Sep 24 10:25:19 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/a7149d379ac19c9857de5adc89c9a69dfa1b4548 [^]

Fixed issue 38159: Memory leak in referenced inventory unbox process

The leak is caused by an invalid call of fireOnPause method on selector
with a targetRecordId (when clicking from the looking glass icon of a field).
This call gives an invalid delay value that causes the timeout to be called
indefinitely.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0106994)
AugustoMauch (developer)
2018-09-25 10:41

Code reviewed and verified
(0107016)
hudsonbot (developer)
2018-09-25 14:16

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c4e1d4ba022d [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-16 12:23 jarmendariz New Issue
2018-03-16 12:23 jarmendariz Assigned To => platform
2018-03-16 12:23 jarmendariz Modules => Core
2018-03-16 12:23 jarmendariz Triggers an Emergency Pack => No
2018-03-16 12:51 jarmendariz Relationship added related to 0038039
2018-03-16 12:52 jarmendariz File Added: heap.png
2018-03-16 12:53 jarmendariz Steps to Reproduce Updated View Revisions
2018-03-16 13:00 jarmendariz Note Added: 0103316
2018-03-16 13:00 jarmendariz Steps to Reproduce Updated View Revisions
2018-03-20 09:23 jarmendariz Assigned To platform => jarmendariz
2018-03-20 16:37 alostale Tag Attached: Performance
2018-03-23 12:25 alostale Status new => acknowledged
2018-03-23 12:25 alostale Priority normal => urgent
2018-09-24 12:18 jarmendariz Status acknowledged => scheduled
2018-09-24 12:26 hgbot Checkin
2018-09-24 12:26 hgbot Note Added: 0106957
2018-09-24 12:26 hgbot Status scheduled => resolved
2018-09-24 12:26 hgbot Resolution open => fixed
2018-09-24 12:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a7149d379ac19c9857de5adc89c9a69dfa1b4548 [^]
2018-09-24 12:27 jarmendariz Review Assigned To => AugustoMauch
2018-09-25 10:41 AugustoMauch Note Added: 0106994
2018-09-25 10:41 AugustoMauch Status resolved => closed
2018-09-25 10:41 AugustoMauch Fixed in Version => 3.0PR18Q4
2018-09-25 14:16 hudsonbot Checkin
2018-09-25 14:16 hudsonbot Note Added: 0107016


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker