Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038096
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-03-09 15:092018-03-16 17:29
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision853f7336072d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038096: Is not possible to disable the access for a widget by deactivating the role access

DescriptionIs not possible to disable the access for a widget by deactivating the role access
Steps To Reproduce1) Go to the [Role] window
2) Move to the "Widget Class Access" tab
3) Set as not active the record for the "Invoices to pay" widget, note that this is a widget which is not accessible anonymously
4) Logout and login
5) Note that it is possible to add the widget into the Workspace
Proposed SolutionIn MyOpenbravoComponent, add the filter for the is active field.

Note that although this code was refactored with the Login Performance Improvements project[1], this is not a regression because before that project the is active flag was not being taken into account neither. See[2].

[1] https://issues.openbravo.com/view.php?id=35980 [^]
[2] https://code.openbravo.com/erp/devel/pi/diff/9bd5115544c9/modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoComponent.java#l1.141 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0035980 closedcaristu Improve the time spent to load the widgets after log-in 

-  Notes
(0103277)
hgbot (developer)
2018-03-15 11:04

Repository: erp/devel/pi
Changeset: 853f7336072d664918728ecd8de2c9290c2843d9
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Mar 15 11:03:52 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/853f7336072d664918728ecd8de2c9290c2843d9 [^]

fixes bug 38096: Allow to disable role access for a widget by deactivating it

---
M modules/org.openbravo.client.myob/src/org/openbravo/client/myob/MyOpenbravoComponent.java
---
(0103302)
alostale (developer)
2018-03-16 08:57

reviewed + tested
(0103326)
hudsonbot (developer)
2018-03-16 17:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/5323533018b6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-09 15:09 caristu New Issue
2018-03-09 15:09 caristu Assigned To => caristu
2018-03-09 15:09 caristu Modules => Core
2018-03-09 15:09 caristu Triggers an Emergency Pack => No
2018-03-09 15:09 caristu Proposed Solution updated
2018-03-09 15:14 caristu Proposed Solution updated
2018-03-09 15:15 caristu Relationship added related to 0035980
2018-03-15 11:04 hgbot Checkin
2018-03-15 11:04 hgbot Note Added: 0103277
2018-03-15 11:04 hgbot Status new => resolved
2018-03-15 11:04 hgbot Resolution open => fixed
2018-03-15 11:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/853f7336072d664918728ecd8de2c9290c2843d9 [^]
2018-03-15 11:04 caristu Review Assigned To => alostale
2018-03-16 08:57 alostale Note Added: 0103302
2018-03-16 08:57 alostale Status resolved => closed
2018-03-16 08:57 alostale Fixed in Version => 3.0PR18Q3
2018-03-16 09:00 alostale Fixed in Version 3.0PR18Q3 => 3.0PR18Q2
2018-03-16 17:29 hudsonbot Checkin
2018-03-16 17:29 hudsonbot Note Added: 0103326


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker