Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038095
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] DB Pool Logging Utilitiesminorhave not tried2018-03-09 14:332018-03-14 19:32
ReporterjarmendarizView Statuspublic 
Assigned Tojarmendariz 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision58e71342e8e0
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Tocaristu
Regression introduced in release
Summary

0038095: Handle new Exceptions thrown by ExternalConnectionPool.getInstance

DescriptionDue to changes to remove warnings and deprecations in JDK9, ExternalConnectionPool.getInstance (used in MeasurePerformance.java) throws an instance of ReflectiveOperationException. This should be handled or explicitly thrown by the method that uses it.
Steps To ReproduceSee above
Proposed SolutionAdd ReflectiveOperationException to the Exceptions thrown by setInterceptor()
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037943 closedjarmendariz Openbravo ERP JDK 9: remove [deprecation] newInstance() in Class warnings 
related to defect 0038000 closedjarmendariz Openbravo ERP API change for ExternalConnectionPool.getInstance(String) method due to [deprecation] newInstance() warning removal 

-  Notes
(0103180)
hgbot (developer)
2018-03-13 09:49

Repository: erp/mods/org.openbravo.util.db
Changeset: 58e71342e8e0b1ab7dd4d871b8d0e75d98375dc3
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Fri Mar 09 14:58:16 2018 +0100
URL: http://code.openbravo.com/erp/mods/org.openbravo.util.db/rev/58e71342e8e0b1ab7dd4d871b8d0e75d98375dc3 [^]

Fixed bug 38095: Handle new Exception thrown by newInstance

JDK 9 fixed replaced ExternalConnectionPool.getInstance exceptions
to a ReflectiveOperationException. Modified the setInterceptor method
to explicitly throw this Exception.

---
M src-test/org/openbravo/util/db/MeasurePerformance.java
---
(0103254)
caristu (developer)
2018-03-14 19:30
edited on: 2018-03-14 19:31

Reviewed. Fix included in version 0.1.300[1].

[1] http://centralrepository.openbravo.com/openbravo/org.openbravo.forge.ui/ForgeModuleVersionDetail?moduleVersionId=0BFB358D3083426CA3164A050417E4EB [^]


- Issue History
Date Modified Username Field Change
2018-03-09 14:33 jarmendariz New Issue
2018-03-09 14:33 jarmendariz Assigned To => platform
2018-03-09 14:34 jarmendariz Relationship added related to 0037943
2018-03-09 14:41 jarmendariz Status new => scheduled
2018-03-13 09:49 hgbot Checkin
2018-03-13 09:49 hgbot Note Added: 0103180
2018-03-13 09:49 hgbot Status scheduled => resolved
2018-03-13 09:49 hgbot Resolution open => fixed
2018-03-13 09:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.util.db/rev/58e71342e8e0b1ab7dd4d871b8d0e75d98375dc3 [^]
2018-03-13 09:51 jarmendariz Review Assigned To => caristu
2018-03-14 19:18 caristu Relationship added related to 0038000
2018-03-14 19:30 caristu Note Added: 0103254
2018-03-14 19:30 caristu Status resolved => closed
2018-03-14 19:31 caristu Note Edited: 0103254 View Revisions
2018-03-14 19:32 caristu Assigned To platform => jarmendariz


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker