Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038085
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2018-03-08 15:542018-03-29 13:07
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision1c30cd9ab986
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038085: Prices in Invoice lines of discounts copied by Copy Lines process are updated to 0 when completing if a price adjustment exists

DescriptionPrices in Invoice lines of discounts copied by Copy Lines process are updated to 0 when completing if a price adjustment exists and price includes taxes

The problem is that the grosspricestd is 0 and M_PROMOTION_CALCULATE function transfers it to gross_unit_price column
Steps To ReproduceAs group admin role:
   Create a new record in Discounts and Promotions window:
      Discount/Promotion Type: Price Adjustment
      Starting Date: today
      Included...: Only those defined (the discount will not applicable as we are not going to include any record in the tabs)
   Create a Sales Order
   Select a price list set as Price Includes Tax
   Add a product and a basic discount to it
   Book it
   Launch Create Invoices From Orders process and select the previously create order
   Check the invoice is correct
   Create a new Sales Invoice header
   Launch Copy Lines process and select previously created invoice
   Complete it and check prices in Discount line are updated to 0
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036969 closedmarkmm82 Purchase order lines created from Requisitions are created with 0 price if price list includes taxes and a discount is defined 
related to defect 0037314 closedcollazoandy4 Gross Unit Price is updated to 0 if a sales invoice line from a Return Material Receipt is modified and price includes taxes 
related to defect 0037960 closedmarkmm82 When not stocked product is exploded before booking the order and price includes taxes, Gross Unit Price is updated to 0 

-  Notes
(0103247)
markmm82 (developer)
2018-03-14 17:22

Test Plan:
    As group admin role:
   Create a new record in Discounts and Promotions window:
      Discount/Promotion Type: Price Adjustment
      Starting Date: today
      Included...: Only those defined (the discount will not applicable as we are not going to include any record in the tabs)
   Create a Sales Order
   Select a price list set as Price Includes Tax
   Add a product and a basic discount to it
   Book it
   Launch Create Invoices From Orders process and select the previously create order
   Check the invoice is correct
   Create a new Sales Invoice header
   Launch Copy Lines process and select previously created invoice
   Complete it and check prices in Discount line still the same and all invoice values are correct
(0103489)
hgbot (developer)
2018-03-26 09:20

Repository: erp/devel/pi
Changeset: 1c30cd9ab98620fcb18afda5ca737c989bf2d4ca
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Mar 22 10:16:12 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/1c30cd9ab98620fcb18afda5ca737c989bf2d4ca [^]

Fixes issue 38085: Prices in Invoice lines of discounts copied by Copy Lines
process are updated to 0 when completing if a price adjustment exists.

The problem is happening when we are copying the invoice line with the basic
discount, in the Copy Lines process and M_PROMOTION_CALCULATE function resets the
price for this line too. As lines with basic discount have zero grosspricestd,
gross_unit_price and line_gross_amount are set to zero too.

We should avoid to reset prices in the M_PROMOTION_CALCULATE function for those
lines related to basic discounts. They are the invoice lines related to an invoice
discount, or those when product is related to a basic discount.

---
M src-db/database/model/functions/M_PROMOTION_CALCULATE.xml
M src/org/openbravo/erpCommon/ad_actionButton/CopyFromInvoice_data.xsql
---
(0103490)
dmiguelez (developer)
2018-03-26 09:21

Code Review + Testing Ok
(0103629)
hudsonbot (developer)
2018-03-29 13:07

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ead4656f507e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-08 15:54 ngarcia New Issue
2018-03-08 15:54 ngarcia Assigned To => Triage Finance
2018-03-08 15:54 ngarcia Modules => Core
2018-03-08 15:54 ngarcia Triggers an Emergency Pack => No
2018-03-08 15:55 ngarcia Issue Monitored: networkb
2018-03-08 15:55 ngarcia Relationship added related to 0036969
2018-03-08 15:55 ngarcia Relationship added depends on 0037314
2018-03-08 15:55 ngarcia Relationship added depends on 0037960
2018-03-08 15:58 ngarcia Description Updated View Revisions
2018-03-08 16:01 ngarcia Relationship replaced related to 0037314
2018-03-08 16:01 ngarcia Relationship replaced related to 0037960
2018-03-08 17:47 dmiguelez Assigned To Triage Finance => markmm82
2018-03-14 17:22 markmm82 Note Added: 0103247
2018-03-14 17:30 markmm82 Status new => scheduled
2018-03-26 09:20 hgbot Checkin
2018-03-26 09:20 hgbot Note Added: 0103489
2018-03-26 09:20 hgbot Status scheduled => resolved
2018-03-26 09:20 hgbot Resolution open => fixed
2018-03-26 09:20 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1c30cd9ab98620fcb18afda5ca737c989bf2d4ca [^]
2018-03-26 09:21 dmiguelez Review Assigned To => dmiguelez
2018-03-26 09:21 dmiguelez Note Added: 0103490
2018-03-26 09:21 dmiguelez Status resolved => closed
2018-03-26 09:21 dmiguelez Fixed in Version => 3.0PR18Q2
2018-03-29 13:07 hudsonbot Checkin
2018-03-29 13:07 hudsonbot Note Added: 0103629


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker