Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038041
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajoralways2018-03-05 14:552018-03-13 17:23
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision3cb50b0b2a6b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-04-12
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
Triggers an Emergency PackNo
Summary

0038041: Cannot log in in the application if the log in warehouse name contains an apostrophe (')

DescriptionCannot log in in the application if the log in warehouse name contains an apostrophe (')
Steps To ReproduceAs group admin role:
   Go to Warehouse and Storage Bins window and modify the warehouse name of the login warehouse from España Región Norte to España' Región Norte

   Log out and log in
   Check the following error message is shown in the browser:

Uncaught SyntaxError: Unexpected identifier - https://livebuilds.openbravo.com/erp_pi_pgsql/org.openbravo.client.kernel/OBCLKER_Kernel/SessionDynamic:... [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00380863.0PR18Q1.1 closedcaristu Cannot log in in the application if the log in warehouse name contains an apostrophe (') 
depends on backport 00380873.0PR17Q4.2 closedcaristu Cannot log in in the application if the log in warehouse name contains an apostrophe (') 
caused by feature request 0035553 closedcaristu Improve scalability of the login process 

-  Notes
(0103113)
hgbot (developer)
2018-03-09 08:48

Repository: erp/devel/pi
Changeset: 3cb50b0b2a6bff2324225a49338ac0789d8e0f31
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 09 08:37:05 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/3cb50b0b2a6bff2324225a49338ac0789d8e0f31 [^]

fixes bug 38041: Can't login if the user profile widget data contains apostrophes

  The JS object used to populate the user profile widget, was being generated without escaping the data properly which could result in a wrong object definition in case of having special characters like apostrophes (').

  To fix this issue we are now using the "js_string" built-in in the .ftl in order to escape the identifiers and labels of the user profile with the escaping rules of the JS language.

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/navigationbarcomponents/templates/user-info.js.ftl
---
(0103116)
alostale (developer)
2018-03-09 10:17

reviewed + tested
(0103136)
hgbot (developer)
2018-03-09 13:56

Repository: erp/devel/pi
Changeset: 75ffdc8078c1d21f977300e8acf57ce3f059b158
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 09 13:53:24 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/75ffdc8078c1d21f977300e8acf57ce3f059b158 [^]

related to issue 38041: added testing infrastructure

---
M src-test/src/org/openbravo/test/security/UserInfoSessionDataTest.java
---
(0103141)
hudsonbot (developer)
2018-03-09 15:25

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ba66b7d07a7b [^]
Maturity status: Test
(0103209)
hudsonbot (developer)
2018-03-13 17:23

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/1d3ccc92fab6 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-05 14:55 ngarcia New Issue
2018-03-05 14:55 ngarcia Assigned To => Triage Finance
2018-03-05 14:55 ngarcia Modules => Core
2018-03-05 14:55 ngarcia Resolution time => 1522015200
2018-03-05 14:55 ngarcia Triggers an Emergency Pack => No
2018-03-05 14:58 ngarcia Priority urgent => immediate
2018-03-05 16:54 caristu Assigned To Triage Finance => caristu
2018-03-05 16:57 caristu Regression level => Production - Confirmed Stable
2018-03-05 16:57 caristu Regression date => 2017-04-12
2018-03-05 16:57 caristu Regression introduced in release => 3.0PR17Q3
2018-03-05 16:57 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/c17655a6fb3ffb29cdd5d73073615ba9d60cd941 [^]
2018-03-05 16:57 caristu Relationship added causes 0035553
2018-03-05 16:58 caristu Relationship deleted causes 0035553
2018-03-05 16:58 caristu Relationship added caused by 0035553
2018-03-08 19:21 caristu Status new => scheduled
2018-03-08 19:21 caristu Status scheduled => acknowledged
2018-03-08 19:23 caristu Status acknowledged => scheduled
2018-03-09 08:48 hgbot Checkin
2018-03-09 08:48 hgbot Note Added: 0103113
2018-03-09 08:48 hgbot Status scheduled => resolved
2018-03-09 08:48 hgbot Resolution open => fixed
2018-03-09 08:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3cb50b0b2a6bff2324225a49338ac0789d8e0f31 [^]
2018-03-09 10:17 alostale Review Assigned To => alostale
2018-03-09 10:17 alostale Note Added: 0103116
2018-03-09 10:17 alostale Status resolved => closed
2018-03-09 10:17 alostale Fixed in Version => 3.0PR18Q2
2018-03-09 13:56 hgbot Checkin
2018-03-09 13:56 hgbot Note Added: 0103136
2018-03-09 15:25 hudsonbot Checkin
2018-03-09 15:25 hudsonbot Note Added: 0103141
2018-03-13 17:23 hudsonbot Checkin
2018-03-13 17:23 hudsonbot Note Added: 0103209


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker