Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037914
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Zoho Reports Integrationminorhave not tried2018-02-14 13:532018-03-16 08:55
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisiond654c2156052
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toalostale
Regression introduced in release
Summary

0037914: Fix deprecation warnings in Zoho Integration after HttpClient and HttpClient Mime libraries upgrade

DescriptionWith issue 0037912 both HttpClient and HttpClient Mime libraries have been upgraded to version 4.5.5.

With this change the ZohoIntegration class uses a deprecated API. It should be adapted to make use of the new API provided by these libraries.
Steps To ReproduceIn description.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0037912 closedcaristu Openbravo ERP Upgrade Apache HttpComponents 

-  Notes
(0102406)
hgbot (developer)
2018-02-14 16:01

Repository: erp/pmods/org.openbravo.utility.zoho
Changeset: 68c43a1e688b5b4866c7d94ae9e6a277e92c0bc8
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Feb 14 15:59:47 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.utility.zoho/rev/68c43a1e688b5b4866c7d94ae9e6a277e92c0bc8 [^]

related to issue 37914: initial code cleanup
  - Use convention names for constants
  - Removed commented out code
  - Remove the declaration of thrown exception 'org.apache.http.client.ClientProtocolException' which is a subclass of the already thrown 'java.io.IOException'
  - Use diamond operator
  - Updated copyright year

---
M src/org/openbravo/utility/zoho/process/ZohoIntegration.java
---
(0102407)
hgbot (developer)
2018-02-14 16:17

Repository: erp/pmods/org.openbravo.utility.zoho
Changeset: 53b857f636b06b5eee13748ec1a88640b88d83be
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Feb 14 16:17:39 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.utility.zoho/rev/53b857f636b06b5eee13748ec1a88640b88d83be [^]

related to issue 37914: additional cleanup

  - Avoid nested if

---
M src/org/openbravo/utility/zoho/process/ZohoIntegration.java
---
(0102409)
hgbot (developer)
2018-02-14 16:55

Repository: erp/pmods/org.openbravo.utility.zoho
Changeset: d654c215605299ddd4fe1a4fbc59356797e348f6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Feb 14 16:33:23 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.utility.zoho/rev/d654c215605299ddd4fe1a4fbc59356797e348f6 [^]

fixes bug 37914: Deprecation warns after HttpClient and HttpClient Mime upgrade

  Both HttpClient and HttpClient Mime libraries used in core have been upgraded to version 4.5.5. See[1]. Due to this upgrade, the Zoho Integration was using a deprecated API. This has been fixed with the following changes:

  - Replaced the usage of DefaultHttpClient with CloseableHttpClient. Besides, we now use a try-with-resources stament to auto close the client.
  - Replaced the usage of MultipartEntity with MultipartEntityBuilder.
  - Minor readability improvement: The variable 'r' in getAuthToken has been renamed to 'response'.


[1] https://code.openbravo.com/erp/devel/pi/rev/e549accfb295a054297a63c891bb17db81257877 [^]

---
M src/org/openbravo/utility/zoho/process/ZohoIntegration.java
---
(0102826)
caristu (developer)
2018-02-23 13:21
edited on: 2018-02-23 13:30

New version 0.1.300[1] published. Updated dependency with core to PR18Q2[2].

[1]
http://centralrepository.openbravo.com/openbravo/org.openbravo.forge.ui/ForgeModuleVersionDetail?moduleVersionId=AE5143D306DF47968D05C1F9A2E098B2 [^]
[2] https://code.openbravo.com/erp/pmods/org.openbravo.utility.zoho/rev/76159c93ac33 [^]

(0103301)
alostale (developer)
2018-03-16 08:55

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-02-14 13:53 caristu New Issue
2018-02-14 13:53 caristu Assigned To => caristu
2018-02-14 13:53 caristu Relationship added related to 0037912
2018-02-14 16:01 hgbot Checkin
2018-02-14 16:01 hgbot Note Added: 0102406
2018-02-14 16:17 hgbot Checkin
2018-02-14 16:17 hgbot Note Added: 0102407
2018-02-14 16:42 caristu Summary Fix deprecation warnings in Zoho Integration after HttpClient library upgrade => Fix deprecation warnings in Zoho Integration after HttpClient and HttpClient Mime libraries upgrade
2018-02-14 16:42 caristu Description Updated View Revisions
2018-02-14 16:55 hgbot Checkin
2018-02-14 16:55 hgbot Note Added: 0102409
2018-02-14 16:55 hgbot Status new => resolved
2018-02-14 16:55 hgbot Resolution open => fixed
2018-02-14 16:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.utility.zoho/rev/d654c215605299ddd4fe1a4fbc59356797e348f6 [^]
2018-02-23 13:21 caristu Note Added: 0102826
2018-02-23 13:22 caristu Review Assigned To => alostale
2018-02-23 13:30 caristu Note Edited: 0102826 View Revisions
2018-03-16 08:55 alostale Note Added: 0103301
2018-03-16 08:55 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker