Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037873
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2018-02-09 15:062018-02-13 19:39
ReportermalsasuaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityimmediateResolutionfixedFixed in VersionRR18Q2
StatusclosedFix in branchFixed in SCM revisionf760497d9332
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression levelProduction - QA Approved
Regression date2017-07-04
Regression introduced in releaseRR17Q4
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8e04e7615f772b1de03f344fa01c920932dd08ab [^]
Triggers an Emergency PackNo
Summary

0037873: when a invoice is created from POS, the date account is set with hours, mins and secs

Descriptionwhen a invoice is created from POS (by cashup or directly), the dateaccount is set with hours, minutes and secconds, and it should be a truncated date.

For example, the current date is "09/02/2018 14:25:17", and it should be "09/02/2018 00:00:00"

Also, date invoice should be a truncated date, but it is happening from a long time, previous to 17Q1

Steps To ReproducePOS:
. new receipt with the option "invoice this receipt"
. complete it

Database:
. the c_invoice.dateacct created is set with HH:MM:SS

POS:
. new receipt without the option "invioce this receipt"
. do cashup

Database:
. the c_invoice.dateacct created is set with HH:MM:SS
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0037886RR18Q1 closedRetail when a invoice is created from POS, the date account is set with hours, mins and secs 
depends on backport 0037887RR17Q4.1 closedRetail when a invoice is created from POS, the date account is set with hours, mins and secs 
caused by defect 0036367 closedranjith_qualiantech_com When a layaway is paid, the accounting and creation date is the order date and it should be when the order is paid completely 

-  Notes
(0102340)
hgbot (developer)
2018-02-13 07:21

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: f760497d9332e124ffd1c70fa541335278f05822
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 13 11:51:08 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f760497d9332e124ffd1c70fa541335278f05822 [^]

Fixed issue 37873 : Invoices should be created without time in accounting date and invoice date fields

* Time should be truncated fom Date while creating invoice through cashup or receipt

---
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor.java
M src/org/openbravo/retail/posterminal/OrderGroupingProcessor_data.xsql
M src/org/openbravo/retail/posterminal/OrderLoader.java
---
(0102341)
hgbot (developer)
2018-02-13 07:21

Repository: tools/automation/pi-mobile
Changeset: b9118cca7463ffa49e058c5ff1cd241536842184
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Feb 13 11:51:16 2018 +0530
URL: http://code.openbravo.com/tools/automation/pi-mobile/rev/b9118cca7463ffa49e058c5ff1cd241536842184 [^]

Verifies issue 37873 : Added automated test 'I37873_VerfiyInvoiceDate'

---
A src-test/org/openbravo/test/mobile/retail/pack/selenium/tests/receipts/I37873_VerfiyInvoiceDate.java
---

- Issue History
Date Modified Username Field Change
2018-02-09 15:06 malsasua New Issue
2018-02-09 15:06 malsasua Assigned To => Retail
2018-02-09 15:06 malsasua Regression introduced in release => RR17Q4
2018-02-09 15:06 malsasua Triggers an Emergency Pack => No
2018-02-12 14:05 ranjith_qualiantech_com Relationship added caused by 0036367
2018-02-12 14:06 ranjith_qualiantech_com Regression level => Production - QA Approved
2018-02-12 14:06 ranjith_qualiantech_com Regression date => 2017-07-04
2018-02-12 14:06 ranjith_qualiantech_com Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/8e04e7615f772b1de03f344fa01c920932dd08ab [^]
2018-02-12 14:08 marvintm Status new => scheduled
2018-02-12 14:09 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-02-13 07:21 hgbot Checkin
2018-02-13 07:21 hgbot Note Added: 0102340
2018-02-13 07:21 hgbot Status scheduled => resolved
2018-02-13 07:21 hgbot Resolution open => fixed
2018-02-13 07:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/f760497d9332e124ffd1c70fa541335278f05822 [^]
2018-02-13 07:21 hgbot Checkin
2018-02-13 07:21 hgbot Note Added: 0102341
2018-02-13 19:39 marvintm Review Assigned To => marvintm
2018-02-13 19:39 marvintm Status resolved => closed
2018-02-13 19:39 marvintm Fixed in Version => RR18Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker