Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037872
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2018-02-09 14:562018-02-22 18:19
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionaf39974bd6a5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037872: Error when opening a child tab, which have filters applied, from another window

DescriptionError when opening a child tab, which have filters applied, from another window
Steps To ReproduceHaving an activated instance:

1) Open G/L Journal window and:
 - Use as filter the column 'Period' on the G/L journal tab
 - Use as filter the column 'General Ledger' on the Header tab
 - Use as filter the column 'Account' on the Lines tab

2) Save the record as 'test' and use it as default, then close the window

3) Open a record on the 'Lines' tab programatically by running this command on the developer tools console:
OB.Utilities.openDirectView('161', 'C_ValidCombination_ID', 'FinancialMgmtGLJournalLine', 'FF1F677803C244A69A629F9D0FA900B9')

4) The following error is shown:

ISC_Combined.js:254 Uncaught TypeError: Cannot read property 'getEditForm' of undefined
    at _2.loadFilterAuxiliaryCache (4198c78b36779605b83051fedf741940.js:2107)
    at _2.setViewState (4198c78b36779605b83051fedf741940.js:2105)
    at Object.OB.Personalization.applyViewDefinitionToView (4198c78b36779605b83051fedf741940.js:2692)
    at Object.OB.Personalization.applyViewDefinition (4198c78b36779605b83051fedf741940.js:2684)
    at _2.setPersonalization (4198c78b36779605b83051fedf741940.js:1477)
    at _2.setWindowSettings (4198c78b36779605b83051fedf741940.js:1459)
    at _2.callback (4198c78b36779605b83051fedf741940.js:1445)
    at _2.isc_c_Class_fireCallback [as fireCallback] (ISC_Combined.js:254)
    at _2.isc_c_Class__fireActionsOnPause [as $cm] (ISC_Combined.js:259)
    at _2.isc_c_Class_fireCallback [as fireCallback] (ISC_Combined.js:254)
TagsNo tags attached.
Attached Files? file icon ErrorChildTab.mp4 [^] (2,301,753 bytes) 2018-02-09 14:56

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037587 closedjarmendariz Open on tab does not work on Tree type windows when using auxiliary inputs in display logic 

-  Notes
(0102343)
hgbot (developer)
2018-02-13 08:43

Repository: erp/devel/pi
Changeset: af39974bd6a5700b25ade2426e43d75c3a565e7b
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Feb 13 08:43:38 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/af39974bd6a5700b25ade2426e43d75c3a565e7b [^]

fixes bug 37872: Error when directly open a child record whose tab has filters

 When direct opening a child record whose tab already has a filter applied (because of a previously created saved view) a JS error was being thrown in the loadFilterAuxiliaryCache function. This was caused because the form of the filter editor was not present yet. To prevent this error, we are now checking whether that form exists before continue with the execution of the loadFilterAuxiliaryCache function.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0102344)
hgbot (developer)
2018-02-13 08:47

Repository: erp/devel/pi
Changeset: d6507984d6512652b328128b52d348c5e54d7985
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Feb 13 08:47:07 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d6507984d6512652b328128b52d348c5e54d7985 [^]

related to issue 37872: Add missing check for filter edit form existence

  Added also this missing check in updateSelectedCountDisplay function.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-view-grid.js
---
(0102461)
alostale (developer)
2018-02-16 12:44

reviewed + tested
(0102747)
hudsonbot (developer)
2018-02-22 18:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test
(0102748)
hudsonbot (developer)
2018-02-22 18:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-02-09 14:56 JONHM New Issue
2018-02-09 14:56 JONHM Assigned To => platform
2018-02-09 14:56 JONHM File Added: ErrorChildTab.mp4
2018-02-09 14:56 JONHM Modules => Core
2018-02-09 14:56 JONHM Triggers an Emergency Pack => No
2018-02-09 15:10 caristu Status new => acknowledged
2018-02-09 15:10 caristu Assigned To platform => caristu
2018-02-09 15:10 caristu Status acknowledged => scheduled
2018-02-12 09:39 caristu Steps to Reproduce Updated View Revisions
2018-02-12 13:29 caristu Relationship added related to 0037587
2018-02-13 08:43 hgbot Checkin
2018-02-13 08:43 hgbot Note Added: 0102343
2018-02-13 08:43 hgbot Status scheduled => resolved
2018-02-13 08:43 hgbot Resolution open => fixed
2018-02-13 08:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/af39974bd6a5700b25ade2426e43d75c3a565e7b [^]
2018-02-13 08:47 hgbot Checkin
2018-02-13 08:47 hgbot Note Added: 0102344
2018-02-13 08:51 caristu Review Assigned To => alostale
2018-02-16 12:44 alostale Note Added: 0102461
2018-02-16 12:44 alostale Status resolved => closed
2018-02-16 12:44 alostale Fixed in Version => 3.0PR18Q2
2018-02-22 18:19 hudsonbot Checkin
2018-02-22 18:19 hudsonbot Note Added: 0102747
2018-02-22 18:19 hudsonbot Checkin
2018-02-22 18:19 hudsonbot Note Added: 0102748


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker