Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037766
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2018-01-30 11:152018-02-22 18:18
ReporterpramodkumarView Statuspublic 
Assigned Tocollazoandy4 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision79e59dce5573
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-01-10
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/49e2bc878d1e [^]
Triggers an Emergency PackNo
Summary

0037766: Sales Invoice Dimensional Report in Excel - error 0/0

DescriptionIf Sales Invoice Dimensional report is executed in excel (pdf is working fine) with invoices that have a total amount of zero an error is raising:


24df6f05 2018-01-26 13:45:58,345 [ajp-bio-127.0.0.1-8009-exec-1] ERROR org.openbravo.erpCommon.ad_reports.ReportInvoiceCustomerDimensionalAnalysesJR - Error
captured:
javax.servlet.ServletException: Error evaluating expression :
Source text : $V{totalProfit}.divide($V{totalAmt}, 10, BigDecimal.ROUND_HALF_UP).multiply( new BigDecimal("100") ).multiply(new BigDecimal($V{totalProfit}.signum()))
at org.openbravo.base.secureApp.HttpSecureAppServlet.renderJR(HttpSecureAppServlet.java:1306)
at org.openbravo.base.secureApp.HttpSecureAppServlet.renderJR(HttpSecureAppServlet.java:1205)
at org.openbravo.erpCommon.ad_reports.ReportInvoiceCustomerDimensionalAnalysesJR.printPageHtml(ReportInvoiceCustomerDimensionalAnalysesJR.java:1036)
at org.openbravo.erpCommon.ad_reports.ReportInvoiceCustomerDimensionalAnalysesJR.doPost(ReportInvoiceCustomerDimensionalAnalysesJR.java:299)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:646)
at org.openbravo.base.HttpBaseServlet.serviceInitialized(HttpBaseServlet.java:228)
at org.openbravo.base.secureApp.HttpSecureAppServlet.service(HttpSecureAppServlet.java:462)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:727)
Steps To Reproduce1.Create any sales invoices with zero amount
2.Open sales invoice dimensional reports and pass the minimum parameter to get the report corresponding to customers.
3.Select the excel format report(Pdf working fine).

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00377813.0PR18Q1 closedcollazoandy4 Sales Invoice Dimensional Report in Excel - error 0/0 
depends on backport 00377823.0PR17Q4.1 closedcollazoandy4 Sales Invoice Dimensional Report in Excel - error 0/0 
caused by feature request 0033206 closedairaceburu More Sales Invoice Dimensional Report Totals 

-  Notes
(0102097)
collazoandy4 (developer)
2018-01-31 17:34

Test Plan
  Go to Sales Invoice window and create a new record:
    Business Partner: Alimentos y Supermercados, S.A
    Create a new record in Lines tab:
      Product: Agua sin Gas 1L
      Net Unit Price: 0
    Complete the invoice
  Create another record in header tab:
    Business Partner: Alimentos y Supermercados, S.A
    Create a new record in Lines tab:
      Product: Bebida Energética 0,5L
    Complete the invoice
  Go to Sales Invoice Dimensional Report window and set:
    From/To Date: Today
    Organization: F&B España Region Norte
    Dimensions: Product
    Check that the report is shown (The two previous invoices) in all the three formats (HTML, PDF, EXCEL) without any error
(0102102)
hgbot (developer)
2018-02-01 09:55

Repository: erp/devel/pi
Changeset: 1036387e70120a45b378f29300bf5590ad7e322d
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jan 30 17:11:54 2018 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/1036387e70120a45b378f29300bf5590ad7e322d [^]

Fixes issue 37766: Sales Invoice Dimensional Report in Excel - error 0/0

A division by zero was taking place when the total amount of the invoice is zero

A validation was added to avoid division by zero when total amount is zero.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
---
(0102103)
hgbot (developer)
2018-02-01 09:55

Repository: erp/devel/pi
Changeset: be19769dbaea3c64737e8f21f960b37549cae36f
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Feb 01 09:53:27 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/be19769dbaea3c64737e8f21f960b37549cae36f [^]

Related to Issue 37766. Code review changes.

Changed comparison to work as other outputs (PDF, HTML).
If the totalAmount is zero, then the margin is zero.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
---
(0102104)
hgbot (developer)
2018-02-01 09:55

Repository: erp/backports/3.0PR18Q1
Changeset: 05baa2c353ce551b12cc59de8288ea62c6ee6614
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jan 30 17:11:54 2018 -0500
URL: http://code.openbravo.com/erp/backports/3.0PR18Q1/rev/05baa2c353ce551b12cc59de8288ea62c6ee6614 [^]

Fixes issue 37766: Sales Invoice Dimensional Report in Excel - error 0/0

A division by zero was taking place when the total amount of the invoice is zero

A validation was added to avoid division by zero when total amount is zero.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
---
(0102105)
hgbot (developer)
2018-02-01 09:55

Repository: erp/backports/3.0PR18Q1
Changeset: d9b6eab2cbe943f9a4cb454423211ebfcffb2d58
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Feb 01 09:53:27 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR18Q1/rev/d9b6eab2cbe943f9a4cb454423211ebfcffb2d58 [^]

Related to Issue 37766. Code review changes.

Changed comparison to work as other outputs (PDF, HTML).
If the totalAmount is zero, then the margin is zero.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
---
(0102106)
hgbot (developer)
2018-02-01 09:55

Repository: erp/backports/3.0PR17Q4.1
Changeset: 79e59dce5573cc18fcc9a0802d969431e7bff2c3
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jan 30 17:11:54 2018 -0500
URL: http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/79e59dce5573cc18fcc9a0802d969431e7bff2c3 [^]

Fixes issue 37766: Sales Invoice Dimensional Report in Excel - error 0/0

A division by zero was taking place when the total amount of the invoice is zero

A validation was added to avoid division by zero when total amount is zero.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
---
(0102107)
hgbot (developer)
2018-02-01 09:55

Repository: erp/backports/3.0PR17Q4.1
Changeset: 4f6f953c426099933159401ad6cbb8b9ff5e502a
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Feb 01 09:53:27 2018 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/4f6f953c426099933159401ad6cbb8b9ff5e502a [^]

Related to Issue 37766. Code review changes.

Changed comparison to work as other outputs (PDF, HTML).
If the totalAmount is zero, then the margin is zero.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoiceCustomerDimensionalAnalysesXLS.jrxml
---
(0102112)
dmiguelez (developer)
2018-02-01 10:00

Code Review + Testing Ok
(0102703)
hudsonbot (developer)
2018-02-22 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test
(0102704)
hudsonbot (developer)
2018-02-22 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-01-30 11:15 pramodkumar New Issue
2018-01-30 11:15 pramodkumar Assigned To => Triage Finance
2018-01-30 11:15 pramodkumar Modules => Core
2018-01-30 11:15 pramodkumar Triggers an Emergency Pack => No
2018-01-30 16:35 egoitz Type design defect => defect
2018-01-30 16:35 egoitz Steps to Reproduce Updated View Revisions
2018-01-30 16:48 egoitz Regression level => Production - Confirmed Stable
2018-01-30 16:54 jpcalvente Issue Monitored: jpcalvente
2018-01-30 17:16 jfrances Issue Monitored: jfrances
2018-01-30 17:33 dmiguelez Assigned To Triage Finance => collazoandy4
2018-01-30 22:09 collazoandy4 Status new => scheduled
2018-01-30 23:26 collazoandy4 Status scheduled => feedback
2018-01-30 23:27 collazoandy4 Status feedback => scheduled
2018-01-30 23:28 collazoandy4 Regression introduced by commit => 49e2bc878d1e
2018-01-30 23:34 collazoandy4 Regression date => 2017-01-10
2018-01-30 23:34 collazoandy4 Regression introduced by commit 49e2bc878d1e => https://code.openbravo.com/erp/devel/pi/rev/49e2bc878d1e [^]
2018-01-31 17:34 collazoandy4 Note Added: 0102097
2018-02-01 09:55 hgbot Checkin
2018-02-01 09:55 hgbot Note Added: 0102102
2018-02-01 09:55 hgbot Status scheduled => resolved
2018-02-01 09:55 hgbot Resolution open => fixed
2018-02-01 09:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/1036387e70120a45b378f29300bf5590ad7e322d [^]
2018-02-01 09:55 hgbot Checkin
2018-02-01 09:55 hgbot Note Added: 0102103
2018-02-01 09:55 hgbot Checkin
2018-02-01 09:55 hgbot Note Added: 0102104
2018-02-01 09:55 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/1036387e70120a45b378f29300bf5590ad7e322d [^] => http://code.openbravo.com/erp/backports/3.0PR18Q1/rev/05baa2c353ce551b12cc59de8288ea62c6ee6614 [^]
2018-02-01 09:55 hgbot Checkin
2018-02-01 09:55 hgbot Note Added: 0102105
2018-02-01 09:55 hgbot Checkin
2018-02-01 09:55 hgbot Note Added: 0102106
2018-02-01 09:55 hgbot Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR18Q1/rev/05baa2c353ce551b12cc59de8288ea62c6ee6614 [^] => http://code.openbravo.com/erp/backports/3.0PR17Q4.1/rev/79e59dce5573cc18fcc9a0802d969431e7bff2c3 [^]
2018-02-01 09:55 hgbot Checkin
2018-02-01 09:55 hgbot Note Added: 0102107
2018-02-01 10:00 dmiguelez Review Assigned To => dmiguelez
2018-02-01 10:00 dmiguelez Note Added: 0102112
2018-02-01 10:00 dmiguelez Status resolved => closed
2018-02-01 10:00 dmiguelez Fixed in Version => 3.0PR18Q2
2018-02-01 19:43 dmitry_mezentsev Relationship added caused by 0033206
2018-02-22 18:18 hudsonbot Checkin
2018-02-22 18:18 hudsonbot Note Added: 0102703
2018-02-22 18:18 hudsonbot Checkin
2018-02-22 18:18 hudsonbot Note Added: 0102704


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker