Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037543
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajorsometimes2017-12-22 11:012018-01-19 10:16
ReporterJONHMView Statuspublic 
Assigned Torqueralta 
PriorityhighResolutionfixedFixed in VersionRR18Q2
StatusclosedFix in branchFixed in SCM revision2942fcbbaa9b
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037543: Error in module script UpdateCashupReport because name column has 60 chars length

DescriptionThere is an error in module script UpdateCashupReport (insertCashManagementEvents method) when description field from 'fin_finacc_transaction' table have more than 60 chars, because 'name' column length from 'OBPOS_Paymentcashup_Events' table has only 60 chars.
Steps To Reproduceupdate to 3.0RR17Q2 having descriptions in fin_finacc_transaction with more than 60 chars

It shows message: ERROR: value too long for type character varying(60)
Proposed SolutionOption 1) Change the 'name' column length of OBPOS_Paymentcashup_Events table from 60 to 255 chars

Option 2) Limit the lenght of the description to 60 chars when importing:
line 73: substr(trans.description, 60),

https://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/file/tip/src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/UpdateCashupReport_data.xsql#l73 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 0037678RR18Q1 closedrqueralta Error in module script UpdateCashupReport because name column has 60 chars length 
depends on backport 0037679RR17Q4.1 closedrqueralta Error in module script UpdateCashupReport because name column has 60 chars length 
depends on backport 0037680RR17Q3.3 closedrqueralta Error in module script UpdateCashupReport because name column has 60 chars length 
has duplicate defect 0038423 closedrqueralta error executing module script UpdateCashupReport when there are transactions with decription lenght higher than 60 

-  Notes
(0101602)
hgbot (developer)
2018-01-05 15:45

Repository: erp/pmods/org.openbravo.retail.posterminal
Changeset: 2942fcbbaa9ba592b760e06d204f51add4238d0b
Author: Rafael Queralta Pozo <rqueralta <at> nauta.cu>
Date: Tue Dec 26 11:44:54 2017 -0500
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2942fcbbaa9ba592b760e06d204f51add4238d0b [^]

Fixed issue 37543: Error in module script UpdateCashupReport because name column
has 60 chars length

---
M build/classes/org/openbravo/retail/posterminal/modulescript/UpdateCashupReportData.class
M src-util/modulescript/src/org/openbravo/retail/posterminal/modulescript/UpdateCashupReport_data.xsql
---

- Issue History
Date Modified Username Field Change
2017-12-22 11:01 JONHM New Issue
2017-12-22 11:01 JONHM Assigned To => Retail
2017-12-22 11:01 JONHM Triggers an Emergency Pack => No
2017-12-22 11:02 JONHM Steps to Reproduce Updated View Revisions
2017-12-26 14:31 rqueralta Assigned To Retail => rqueralta
2017-12-26 14:32 rqueralta Status new => scheduled
2018-01-05 15:45 hgbot Checkin
2018-01-05 15:45 hgbot Note Added: 0101602
2018-01-05 15:45 hgbot Status scheduled => resolved
2018-01-05 15:45 hgbot Resolution open => fixed
2018-01-05 15:45 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/2942fcbbaa9ba592b760e06d204f51add4238d0b [^]
2018-01-09 13:54 marvintm Review Assigned To => marvintm
2018-01-09 13:54 marvintm Status resolved => closed
2018-01-09 13:54 marvintm Fixed in Version => RR18Q2
2018-01-19 10:16 marvintm Status closed => new
2018-01-19 10:16 marvintm Resolution fixed => open
2018-01-19 10:16 marvintm Fixed in Version RR18Q2 =>
2018-01-19 10:16 marvintm Status new => scheduled
2018-01-19 10:16 marvintm Status scheduled => resolved
2018-01-19 10:16 marvintm Fixed in Version => RR18Q2
2018-01-19 10:16 marvintm Resolution open => fixed
2018-01-19 10:16 marvintm Status resolved => closed
2018-04-25 08:36 ranjith_qualiantech_com Relationship added has duplicate 0038423


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker