Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037523
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementminoralways2017-12-20 14:302018-01-03 12:39
ReportervmromanosView Statuspublic 
Assigned Tocollazoandy4 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision045519e056d3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2017-11-07
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9f110baef4461d80ca48f92485ce3e4fd3a42ac0#l2.7 [^]
Triggers an Emergency PackNo
Summary

0037523: Product selector filters by Non-Stocked products in Goods Movement window

DescriptionAfter changing the Goods Movement window definition from Sales to Purchase, the goods movement line product selector now filters by default by Stocked=No which has no sense.

Before this change in the window definition the default filter was Stocked=Yes, which makes sense.
Steps To ReproduceGo to Goods Movement window and create a new record. Fill mandatory fields
Go to Lines tab and create a new record.
Press magnifying glass in Product selector.
Check default filter is Stocked=No, but it should be Stocked=Yes
Proposed SolutionImprove "Product Complete" selector to properly manage the Default Expression in Stocked field for Goods Movement window
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0036828 closeddmiguelez Scroll bar of 'Goods Movement' selector disappears in newest MacOS environments. 

-  Notes
(0101257)
collazoandy4 (developer)
2017-12-26 18:23

Test Plan
  As F&B International Group Admin Role
    Go to Goods Movement window and create a new record. Fill mandatory fields
      Create a new record in Lines tab
        Press magnifying glass in Product selector.
        Check default filter is Stocked=Yes
(0101278)
hgbot (developer)
2017-12-28 11:26

Repository: erp/devel/pi
Changeset: 045519e056d3e1af30f4164e8b1cf33e9a6a0ecd
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Fri Dec 22 17:38:18 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/045519e056d3e1af30f4164e8b1cf33e9a6a0ecd [^]

Fixes issue 37523:Product selector filters by Non-Stocked products in Goods
Movement window

The Stocked field of product select is filtering to true if the window is sales
transaction. The field Default expression was modified to take into account the
Goods Movement window and sets to true the field value

---
M src-db/database/sourcedata/OBUISEL_SELECTOR_FIELD.xml
---
(0101279)
vmromanos (developer)
2017-12-28 11:27

Code review + testing OK
(0101537)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-12-20 14:30 vmromanos New Issue
2017-12-20 14:30 vmromanos Assigned To => Triage Finance
2017-12-20 14:30 vmromanos Modules => Core
2017-12-20 14:30 vmromanos Triggers an Emergency Pack => No
2017-12-20 14:31 vmromanos Relationship added caused by 0036828
2017-12-20 14:32 vmromanos Regression level => Pre packaging ( pi )
2017-12-20 14:32 vmromanos Regression date => 2017-11-07
2017-12-20 14:32 vmromanos Regression introduced in release => pi
2017-12-20 14:32 vmromanos Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9f110baef4461d80ca48f92485ce3e4fd3a42ac0#l2.7 [^]
2017-12-20 14:33 vmromanos Description Updated View Revisions
2017-12-22 17:30 collazoandy4 Assigned To Triage Finance => collazoandy4
2017-12-22 17:34 collazoandy4 Status new => scheduled
2017-12-26 18:23 collazoandy4 Note Added: 0101257
2017-12-28 11:26 hgbot Checkin
2017-12-28 11:26 hgbot Note Added: 0101278
2017-12-28 11:26 hgbot Status scheduled => resolved
2017-12-28 11:26 hgbot Resolution open => fixed
2017-12-28 11:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/045519e056d3e1af30f4164e8b1cf33e9a6a0ecd [^]
2017-12-28 11:27 vmromanos Review Assigned To => vmromanos
2017-12-28 11:27 vmromanos Note Added: 0101279
2017-12-28 11:27 vmromanos Status resolved => closed
2017-12-28 11:27 vmromanos Fixed in Version => 3.0PR18Q1
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101537


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker