Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037162
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfaceminoralways2017-10-25 16:172018-01-03 12:39
Reporterinaki_garciaView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision67878ed5e392
ProjectionnoneETAnoneTarget Version
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037162: [RR17Q4] [AWO] Bad spacing in the Order Line field of a Task record

DescriptionThe Line No. string that is part Order Line field in the More Information section of a Task record has unnecessary spacing preceding it, as shown in the picture.
Steps To ReproducePRECONDITION
- The AWO (Advanced Warehouse Operation) module must be installed

0. Log in to the backend (ERP) as user Openbravo
1. Create a Purchase Order, and book it
2. Click on the Receive process button, and click on Done. One or more Tasks should be created, depending on the amount of items added to the order
3. Go to the Task window and open a record
4. Click on the More Information section. NOTICE that the value in the Order Line field is displayed with some padding blank spaces

-------------------------------------------------------------------------------
An easier way to reproduce the same:

1. As system admin, go to the [Tables and Columns] table, and navigate to the "C_InvoiceLine" table in the header.
2. Move to the "Columns" subtab and select the "C_OrderLine" column. Change the reference of this column to "TableDir"
3. Recompile and restart tomcat
4. Go to the [Sales Invoice] window and select any invoice already booked.
5. Move to the "Lines" tab, expand the "More Information" window and notice that the problem can be seen in the "Sales Order Line" field.
TagsNo tags attached.
Attached Filespng file icon order_line_items_not_correctly_spaced.png [^] (141,262 bytes) 2017-10-25 16:17


? file icon queryIdentifier.sql [^] (1,022 bytes) 2017-11-23 19:30

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0100692)
caristu (developer)
2017-11-23 19:28
edited on: 2017-11-24 08:46

The problem is caused by the way the identifier is calculated for the Table/TableDir references. The getValueInComboReference() method in the UIDefinition class builds the identifier based on a query like the one attached (queryIdentifier.sql) which adds extra blank spaces to the computed identifier (being in PostgreSQL, not in Oracle).

Note that the following query executed in PostgreSQL is adding some padding blank spaces to the result:

SELECT TO_CHAR(CAST(1 AS INTEGER)) FROM DUAL

This is because this function is defined in the prescript-PostgreSQL.sql to return the result with the following pattern: '999999999999D'.

Note that while this issue is not solved, it can be workarounded by using a search/obuisel_selector reference because using these kind of references the identifiers are generated in a different way: using the IdentifierProvider.

(0100755)
hgbot (developer)
2017-11-28 10:18

Repository: erp/devel/pi
Changeset: 67878ed5e392624e7bf35a606c2bbd1390b97305
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Nov 28 10:09:09 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/67878ed5e392624e7bf35a606c2bbd1390b97305 [^]

fixes issue 37162: wrong spacing for combo with identifiers that use integers

  Having a table with at least one integer as identifier and a combo reference (Table/TableDir) referencing to that table, fields using that reference were printed with some extra blank spaces.

  This was happening because the integer values were casted and the to_char(integer) function created for PostgresSQL[1] is adding some formatting which causes to print the result with those extra blank spaces.

  To avoid this problem integer identifiers in combo references are handled now in the same way as the rest of numeric references.

[1] https://code.openbravo.com/erp/devel/pi/file/tip/src-db/database/model/prescript-PostgreSql.sql#l272 [^]

---
M src/org/openbravo/reference/ui/UIReferenceUtility.java
---
(0100881)
alostale (developer)
2017-12-01 10:14

reviewed + tested
(0101466)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-25 16:17 inaki_garcia New Issue
2017-10-25 16:17 inaki_garcia Assigned To => platform
2017-10-25 16:17 inaki_garcia File Added: order_line_items_not_correctly_spaced.png
2017-10-25 16:17 inaki_garcia Modules => Core
2017-10-25 16:17 inaki_garcia Triggers an Emergency Pack => No
2017-11-23 19:22 caristu Steps to Reproduce Updated View Revisions
2017-11-23 19:28 caristu Note Added: 0100692
2017-11-23 19:28 caristu Steps to Reproduce Updated View Revisions
2017-11-23 19:28 caristu Steps to Reproduce Updated View Revisions
2017-11-23 19:29 caristu Note Edited: 0100692 View Revisions
2017-11-23 19:30 caristu File Added: queryIdentifier.sql
2017-11-23 19:30 caristu Note Edited: 0100692 View Revisions
2017-11-23 19:30 caristu Status new => acknowledged
2017-11-24 08:03 caristu Note Edited: 0100692 View Revisions
2017-11-24 08:03 caristu Note Edited: 0100692 View Revisions
2017-11-24 08:04 caristu Note Edited: 0100692 View Revisions
2017-11-24 08:04 caristu Note Edited: 0100692 View Revisions
2017-11-24 08:12 caristu Note Edited: 0100692 View Revisions
2017-11-24 08:13 caristu Steps to Reproduce Updated View Revisions
2017-11-24 08:46 caristu Note Edited: 0100692 View Revisions
2017-11-28 10:18 hgbot Checkin
2017-11-28 10:18 hgbot Note Added: 0100755
2017-11-28 10:18 hgbot Status acknowledged => resolved
2017-11-28 10:18 hgbot Resolution open => fixed
2017-11-28 10:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/67878ed5e392624e7bf35a606c2bbd1390b97305 [^]
2017-11-28 10:18 caristu Assigned To platform => caristu
2017-11-28 10:18 caristu Review Assigned To => alostale
2017-12-01 10:14 alostale Note Added: 0100881
2017-12-01 10:14 alostale Status resolved => closed
2017-12-01 10:14 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101466


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker