Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037132
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2017-10-20 10:412018-01-03 12:38
ReportermaiteView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionce36c56e53d7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037132: Should not be possible tor register invoice document related with an order having different business partner

DescriptionProblem is reproducible in both sales and purchase flows
Steps To Reproduce1. Create Sales Order for "Alimentos y Supermercados, S.A", Invoice Terms "Immediate". Add any product and process order
2. Create Sales Invoice for "Hoteles Buenas Noches, S.A."
3. Run Create Lines From, click on Business Partner Selector and set "Alimentos y Supermercados, S.A". Expand "Order" combo and realize that you are able to select previous order, which is wrong.

If you add lines and process the invoice you can verify via database that fin_payment_scheduledetail information is wrong because

This is affecting different flows where "fin_payment_scheduledetail.c_bpartner_id" is considered because, in that case, only one details exists related with order and invoice having different bp
Proposed Solutionimplement similar fix that issue https://issues.openbravo.com/view.php?id=26833 [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0026833 closedAtulOpenbravo Business partner in goods shipment is editable when generating picking list and the picking can be processed 

-  Notes
(0100007)
AtulOpenbravo (developer)
2017-10-23 21:20

- Login as F&B International Group Admin role.
- Create Sales Order for "Alimentos y Supermercados, S.A", Invoice Terms "Immediate". Add any product and process order
- Create Sales Invoice for "Hoteles Buenas Noches, S.A."
- Run Create Lines From.
- Realize that user cannot select business partner any more. It is set with default value as the business partner in the header.
(0100143)
hgbot (developer)
2017-10-30 13:25

Repository: erp/devel/pi
Changeset: ce36c56e53d7031b5885b1a44b1268701dbef0a0
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue Oct 24 00:53:03 2017 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/ce36c56e53d7031b5885b1a44b1268701dbef0a0 [^]

Fixes Issue 37132:Should not be possible to register invoice document related with an
order having different business partner

In sales / purchase invoice, business partner selector button and input type text
is disabled in Create Lines From popup window.

---
M src/org/openbravo/erpCommon/ad_actionButton/CreateFrom_Invoice.html
---
(0100302)
dmiguelez (developer)
2017-11-07 12:22

Code Review + Testing Ok
(0101363)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-20 10:41 maite New Issue
2017-10-20 10:41 maite Assigned To => Triage Finance
2017-10-20 10:41 maite Modules => Core
2017-10-20 10:41 maite Triggers an Emergency Pack => No
2017-10-20 10:42 maite Relationship added related to 0026833
2017-10-20 10:43 maite Proposed Solution updated
2017-10-23 12:51 dmiguelez Assigned To Triage Finance => AtulOpenbravo
2017-10-23 21:20 AtulOpenbravo Status new => scheduled
2017-10-23 21:20 AtulOpenbravo Note Added: 0100007
2017-10-30 13:25 hgbot Checkin
2017-10-30 13:25 hgbot Note Added: 0100143
2017-10-30 13:25 hgbot Status scheduled => resolved
2017-10-30 13:25 hgbot Resolution open => fixed
2017-10-30 13:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ce36c56e53d7031b5885b1a44b1268701dbef0a0 [^]
2017-11-07 12:22 dmiguelez Review Assigned To => dmiguelez
2017-11-07 12:22 dmiguelez Note Added: 0100302
2017-11-07 12:22 dmiguelez Status resolved => closed
2017-11-07 12:22 dmiguelez Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101363


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker