Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037005
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-10-04 19:152018-01-03 12:38
ReportervmromanosView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionb29f889862c9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037005: Error importing C_UOM translation

DescriptionWhen you try to import the es_ES translation for Core (and probably any other Core's translation) you get these errors while importing the C_UOM translation:

 [java] 24261 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Litre',UOMSymbol='l ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='023A83E2F6FB41F3A76A822078AE9F72' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24262 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Square Centimeter',UOMSymbol='cm²',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='03A1ED8702974DE68E44C5771229D750' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24263 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Unidad',UOMSymbol='Un ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='100' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24264 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Hora',UOMSymbol='h ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='101' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24265 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Día',UOMSymbol='d ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='102' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24266 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Minutos',Description='(unidad menor para asignación de recursos)',UOMSymbol='min',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='103' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24267 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Día laborable',Description='8 horas',UOMSymbol='D ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='104' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24268 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Semana',UOMSymbol='s ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='105' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24269 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Mes',Description='30 días',UOMSymbol='m ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='106' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24270 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Mes laborable',Description='20 días',UOMSymbol='m ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='107' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24271 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Año',UOMSymbol='A ',Updated=now(),IsTranslated='Y' WHERE C_UOM_ID='108' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24271 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Ounce',UOMSymbol='oz ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='2EBC93C05D75431E9EEFB29CEC76F244' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24272 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Square Inch',UOMSymbol='in²',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='40B0E154EF704F839D5A7DEFD721D41A' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24273 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Yard',UOMSymbol='yd ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='53E0B852279845AE8DA2879F18E9B3D9' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24274 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Meter',UOMSymbol='M ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='54E1CF8449474628BEA191E0532EEC3E' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24275 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Cubic Meter',UOMSymbol='m³ ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='6B3B437CB42D452FA04E098D52138888' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24276 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Gallon (US)',UOMSymbol='gl ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='6CB1469F8167467BABD40DABE043D829' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24277 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Pound',UOMSymbol='Lb ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='6FA87C4EE1FD4C86940A5F2E47C429DA' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24278 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Kilogram',UOMSymbol='kg ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='72BA247D31F745F3AF11F74A5E2CCBEF' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24279 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Metric Ton',UOMSymbol='T ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='72C8EB9E3001414D901DE48C985163CF' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24280 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Kilometer',UOMSymbol='km ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='A8AE303C482B454081EC39ED47377398' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24281 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Centimeter',UOMSymbol='cm ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='ADF850C3E6E9413B9F9EEA5C87456073' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24282 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Millimeter',UOMSymbol='mm ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='B648C32ED9304B4A87C5997CB69D7B72' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24283 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Square Foot',UOMSymbol='f² ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='BB118F8584D64FCBB5F897A2EBE56AE8' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24284 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Cubic Centimeter',UOMSymbol='cm³',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='BCC599A13E0640A6823A0CF9ED3CDB9E' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24285 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Gram',UOMSymbol='g ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='BD53EA48AAD04ADB8361B374367E42EB' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24286 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Cubic Foot',UOMSymbol='f³ ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='D492A98D34814D1C85568C4D1CE12B55' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24287 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Mile',UOMSymbol='mi ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='E2DFB5559E414F85BC7C800BF0DD4E14' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24288 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Foot',UOMSymbol='ft ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='F59613ADEC7F404E8142FC7477B7C04D' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24289 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Inch',UOMSymbol='in ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='F9AD53BEDA3D4A32BECF44030C281EF2' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24289 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationHandler - Not Found - UPDATE C_UOM_Trl SET Name='Square Meter',UOMSymbol='m² ',Updated=now(),IsTranslated='N' WHERE C_UOM_ID='FDFFCA35AB8041F6957989FA93F8C3ED' AND AD_Language='es_ES' AND AD_Client_ID='0'
     [java] 24290 [main] INFO org.openbravo.erpCommon.ad_forms.TranslationManager - importTrl - Updated=0 - from file C_UOM_TRL_es_ES.xml



The import translation process continues after the previous error messages are logged (which is the right behavior).
Only C_UOM table seems to be affected.
Steps To Reproduce1- Clone the https://code.openbravo.com/erp/mods/org.openbravo.localization.spain.referencedata.translation.esES [^] repository inside the modules/ directory.
2- Inside the new module directory, execute: hg up tip (Select the latest branch-> translations for Openbravo 3.0)
3- Run ant install.source
4- Verify the error messages are logged when importing C_UOM table from module "Translation: Spanish-Spain (es_ES) español-España"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0099774)
inigosanchez (developer)
2017-10-05 11:02

Tested in 3.0PR15Q4. Issue is not a regression.
(0099844)
hgbot (developer)
2017-10-10 10:04

Repository: erp/devel/pi
Changeset: b29f889862c9bed4f25eb99596182544e2a796ed
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Oct 09 12:39:56 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b29f889862c9bed4f25eb99596182544e2a796ed [^]

Fixed issue 37005: Error importing C_UOM translation

The problem was discovered when you was trying to import the es_ES translation for Core. Running install.source
task (having org.openbravo.localization.spain.referencedata.translation.esES module in the instance) some C_UOM
translations were not found. The problem was the order in wich translations were applied. (Before the import of
standard reference data).

The ApplyModule task import the data first for any translation modules. Then ApplyModule task import the reference
data modules. This order is wrong because some translations could be depend on the reference data.

Now the problem has been resolved by take into account this situation. Now, the import of the reference data are
done at first. Then the translations are applied.

---
M src/org/openbravo/erpCommon/modules/ApplyModule.java
---
(0099880)
alostale (developer)
2017-10-13 08:07

reviewed + tested
(0101321)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-04 19:15 vmromanos New Issue
2017-10-04 19:15 vmromanos Assigned To => platform
2017-10-04 19:15 vmromanos Modules => Core
2017-10-04 19:15 vmromanos Triggers an Emergency Pack => No
2017-10-05 11:02 inigosanchez Note Added: 0099774
2017-10-06 10:24 inigosanchez Status new => scheduled
2017-10-06 10:24 inigosanchez Assigned To platform => inigosanchez
2017-10-09 11:21 inigosanchez Summary Error importing C_UOM translation => Error importinghg up tip C_UOM translation
2017-10-09 11:21 inigosanchez Steps to Reproduce Updated View Revisions
2017-10-09 12:41 inigosanchez Summary Error importinghg up tip C_UOM translation => Error importing C_UOM translation
2017-10-10 09:56 inigosanchez Review Assigned To => alostale
2017-10-10 09:56 inigosanchez Steps to Reproduce Updated View Revisions
2017-10-10 10:04 hgbot Checkin
2017-10-10 10:04 hgbot Note Added: 0099844
2017-10-10 10:04 hgbot Status scheduled => resolved
2017-10-10 10:04 hgbot Resolution open => fixed
2017-10-10 10:04 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b29f889862c9bed4f25eb99596182544e2a796ed [^]
2017-10-13 08:07 alostale Note Added: 0099880
2017-10-13 08:07 alostale Status resolved => closed
2017-10-13 08:07 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101321


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker