Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036953
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-09-26 13:202017-09-27 18:42
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision9233e24043d1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2017-09-15
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/0c8047a2daa39f0c4daacccad122b69517a203e0 [^]
Triggers an Emergency PackNo
Summary

0036953: Can not create records in Organization window sub-tabs

DescriptionIs not possible to create a record in the Organization window sub-tabs.
Steps To Reproduce1) Log-in as F&B International Group Admin role
2) Open the [Organization] window
3) Select any organization, for example "F&B España - Región Norte"
4) Navigate to the Warehouse tab, notice that is not possible to create a new record
Proposed SolutionIt must be take into account that tabs based in the Organization entity will not have an "organization" property.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0036725 closedAugustoMauch Should not be possible to create new data when user is not able to edit existent data 

-  Notes
(0099599)
hgbot (developer)
2017-09-26 16:46

Repository: erp/devel/pi
Changeset: 9233e24043d174f520a04445e7b668547d16b8e0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 26 16:23:03 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/9233e24043d174f520a04445e7b668547d16b8e0 [^]

fixes issue 36953: Can not create records in Organization window sub-tabs

  The check created to prevent the creation of new records in a sub-tab that does not show the organization field when the role does not have access to the header's org was not taking into account the case where the parent tab is showing the Organization entity itself.

  In that case, the parent tab will not have an organization property and as it was not being found the logic was hidding the save options in the UI.

  To fix this problem, that check is skipped when the parent tab refers to the Organization entity. This can be done safely as in this case, the organization field of the records in the child tabs will always have the same value of the organization field in the parent tab.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0099613)
hudsonbot (developer)
2017-09-27 00:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f8aef32786fd [^]
Maturity status: Test
(0099639)
AugustoMauch (developer)
2017-09-27 18:42

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2017-09-26 13:20 caristu New Issue
2017-09-26 13:20 caristu Assigned To => platform
2017-09-26 13:20 caristu Modules => Core
2017-09-26 13:20 caristu Regression level => Pre packaging ( pi )
2017-09-26 13:20 caristu Regression date => 2017-09-15
2017-09-26 13:20 caristu Regression introduced in release => pi
2017-09-26 13:20 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/0c8047a2daa39f0c4daacccad122b69517a203e0 [^]
2017-09-26 13:20 caristu Triggers an Emergency Pack => No
2017-09-26 13:20 caristu Relationship added caused by 0036725
2017-09-26 13:21 caristu Proposed Solution updated
2017-09-26 13:21 caristu Assigned To platform => caristu
2017-09-26 14:20 caristu Status new => scheduled
2017-09-26 16:46 hgbot Checkin
2017-09-26 16:46 hgbot Note Added: 0099599
2017-09-26 16:46 hgbot Status scheduled => resolved
2017-09-26 16:46 hgbot Resolution open => fixed
2017-09-26 16:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9233e24043d174f520a04445e7b668547d16b8e0 [^]
2017-09-26 16:46 caristu Review Assigned To => AugustoMauch
2017-09-27 00:09 hudsonbot Checkin
2017-09-27 00:09 hudsonbot Note Added: 0099613
2017-09-27 18:42 AugustoMauch Note Added: 0099639
2017-09-27 18:42 AugustoMauch Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker