Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036796
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-09-05 17:562017-09-21 16:49
ReporterdmiguelezView Statuspublic 
Assigned Todmiguelez 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision704736d841a9
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression levelQA functional test
Regression date2017-04-07
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/094c025e0735 [^]
Triggers an Emergency PackNo
Summary

0036796: Not possible to receive a Return Material for a Bin in a not available status

DescriptionIt is not possible to receive a Return Material for a Bin in a not available status. However, this restriction should only be applied when the stock is leaving the Warehouse, not when is entering it)
Steps To ReproduceLogin as F&B Admin

1.-
Go to Goods Shipment window and create a new record with:
* Organization: F&B US West Coast
* Business Partner: Healthy Food Supermarkets, Co.
* Rest of the fields as defaulted
Move to Lines Tab and create a new record with:
* Product: Cola
* Movement Quantity: 10
* Storage Bin: WC-0-0-0
* Rest of the fields as defaulted
Click on complete button and the Ok

2.-
Go to Warehouse and Storage Bins window
* Select US West Coast Warehouse
Move to Storage Bins Tab
* Select WC-0-0-0 Strorage bin
Click on Change Status button and select Blocked. Click on Done.

3.-
Go to Return from Customer Window and create a new record with:
* Organization: F&B US West Coast
* Business Partner: Healthy Food Supermarkets, Co.
* Rest of the fields as defaulted
Click on Pick/Edit Lines
* Select the record with the same document number and Product as the Goods Shipment created previously
* Set 10 as returned in the grid
click on done and then on Book and Ok.

4.-
Go to Return Material Receipt Window and create a new record with:
* Organization: F&B US West Coast
* Business Partner: Healthy Food Supermarkets, Co.
* Rest of the fields as defaulted
Click on Pick/Edit Lines
* Select the record with the same document number and Product as the Return From Customer created previously
* Set 10 as returned in the grid
click on done and then on Complete and Ok.

The process fails with the message:
In line 10 the Storage Bin of the Line has a Not Available Inventory Status. It is not opssible to issue a Product from a Not Available Storage Bin
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00367983.0PR17Q3 closeddmiguelez Not possible to receive a Return Material for a Bin in a not available status 
caused by feature request 0036086 closeddmiguelez Add Inventory Status functionality 

-  Notes
(0098841)
dmiguelez (developer)
2017-09-05 17:57

Test Plan

First Test:

Login as F&B Admin

1.-
Go to Goods Shipment window and create a new record with:
* Organization: F&B US West Coast
* Business Partner: Healthy Food Supermarkets, Co.
* Rest of the fields as defaulted
Move to Lines Tab and create a new record with:
* Product: Cola
* Movement Quantity: 10
* Storage Bin: WC-0-0-0
* Rest of the fields as defaulted
Click on complete button and the Ok

2.-
Go to Warehouse and Storage Bins window
* Select US West Coast Warehouse
Move to Storage Bins Tab
* Select WC-0-0-0 Strorage bin
Click on Change Status button and select Blocked. Click on Done.

3.-
Go to Return from Customer Window and create a new record with:
* Organization: F&B US West Coast
* Business Partner: Healthy Food Supermarkets, Co.
* Rest of the fields as defaulted
Click on Pick/Edit Lines
* Select the record with the same document number and Product as the Goods Shipment created previously
* Set 10 as returned in the grid
click on done and then on Book and Ok.

4.-
Go to Return Material Receipt Window and create a new record with:
* Organization: F&B US West Coast
* Business Partner: Healthy Food Supermarkets, Co.
* Rest of the fields as defaulted
Click on Pick/Edit Lines
* Select the record with the same document number and Product as the Return From Customer created previously
* Set 10 as returned in the grid
click on done and then on Complete and Ok.

The process is completed successfully
(0098845)
dmiguelez (developer)
2017-09-05 18:02
edited on: 2017-09-05 18:02

Second test plan:

Login as F&B Admin

1.-
Go to Warehouse and Storage Bins window
* Select US East Coast Warehouse
Move to Storage Bins Tab
* Select EC-0-0-0 Strorage bin
Click on Change Status button and select Blocked. Click on Done.

2.-
Go to Goods Receipt window and create a new record with:
* Organization: F&B US East Coast
* Business Partner: Be Soft Drinker, Inc.
* Rest of the fields as defaulted
Move to Lines Tab and create a new record with:
* Product: Ale Beer
* Movement Quantity: 10
* Storage Bin: EC-0-0-0
* Rest of the fields as defaulted
Click on complete button and the Ok

3.-
Go to Return to Vendor Window and create a new record with:
* Organization: F&B US East Coast
* Business Partner: Be Soft Drinker, Inc.
* Rest of the fields as defaulted
Click on Pick/Edit Lines
* Select the record with the same document number and Product as the Goods Shipment created previously
* Set 10 as returned in the grid
click on done and then on Book and Ok.

4.-
Go to Return to Vendor Shipment Window and create a new record with:
* Organization: F&B US East Coast
* Business Partner: Be Soft Drinker, Inc.
* Rest of the fields as defaulted
Click on Pick/Edit Lines
* Select the record with the same document number and Product as the Return From Customer created previously
* Set 10 as returned in the grid
click on done and then on Complete and Ok.

The process fails with the message:
In line 10 the Storage Bin of the Line has a Not Available Inventory Status. It is not opssible to issue a Product from a Not Available Storage Bin

5.-
Go to Warehouse and Storage Bins window
* Select US East Coast Warehouse
Move to Storage Bins Tab
* Select EC-0-0-0 Strorage bin
Click on Change Status button and select Available. Click on Done.

6.-
Move back to Return To Vendor Shipment and select the previous record.
Complete the document and now the process is successful

(0098856)
hgbot (developer)
2017-09-06 08:51

Repository: erp/devel/pi
Changeset: 704736d841a9c576a92c1083d7bc4f982ec709c9
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Tue Sep 05 18:46:27 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/704736d841a9c576a92c1083d7bc4f982ec709c9 [^]

Fixes Issue 36796. Check that the Inventory Status of the Bin has the
Available flag checked for Goods Shipments and Return To Vendor Shipments
(outgoing warehouse transactions in the M_INOUT_POST)

---
M src-db/database/model/functions/M_INOUT_POST.xml
---
(0098867)
aferraz (developer)
2017-09-06 16:56

Code review OK
(0099362)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-09-05 17:56 dmiguelez New Issue
2017-09-05 17:56 dmiguelez Assigned To => Triage Finance
2017-09-05 17:56 dmiguelez Modules => Core
2017-09-05 17:56 dmiguelez Triggers an Emergency Pack => No
2017-09-05 17:57 dmiguelez Note Added: 0098841
2017-09-05 18:02 dmiguelez Note Added: 0098845
2017-09-05 18:02 dmiguelez Note Edited: 0098845 View Revisions
2017-09-05 18:09 dmiguelez Regression level => QA functional test
2017-09-05 18:09 dmiguelez Regression date => 2017-04-07
2017-09-05 18:09 dmiguelez Regression introduced in release => main
2017-09-05 18:09 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/094c025e0735 [^]
2017-09-05 18:47 dmiguelez Status new => scheduled
2017-09-05 18:47 dmiguelez Assigned To Triage Finance => dmiguelez
2017-09-06 08:51 hgbot Checkin
2017-09-06 08:51 hgbot Note Added: 0098856
2017-09-06 08:51 hgbot Status scheduled => resolved
2017-09-06 08:51 hgbot Resolution open => fixed
2017-09-06 08:51 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/704736d841a9c576a92c1083d7bc4f982ec709c9 [^]
2017-09-06 09:04 aferraz Relationship added caused by 0036086
2017-09-06 16:56 aferraz Review Assigned To => aferraz
2017-09-06 16:56 aferraz Note Added: 0098867
2017-09-06 16:56 aferraz Status resolved => closed
2017-09-06 16:56 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099362


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker