Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036716
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-08-25 09:132017-09-21 16:49
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision40963c034a8f
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036716: Tree grid visibility stops working when opening a record in form view and returning to tree view

DescriptionTree grid visibility stops working when opening a record in form view and returning to tree view
Steps To Reproduce1) Open 'Organization' window and press the button "Toggle tree view visibility" on the toolbar
2) Expand some records
3) Open 'F&B International Group' organization in form view and press close button in order to return to the tree view.
--> The functionality is not working anymore
TagsNo tags attached.
Attached Files? file icon treeViewIssue.mp4 [^] (2,215,518 bytes) 2017-08-25 09:13

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0098646)
JONHM (developer)
2017-08-25 09:14

Attached is a video with the steps to reproduce
(0098688)
hgbot (developer)
2017-08-29 10:29

Repository: erp/devel/pi
Changeset: 40963c034a8f7f71f7da2118b8ccea3c4caf51e4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 29 10:10:18 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/40963c034a8f7f71f7da2118b8ccea3c4caf51e4 [^]

fixes bug 36716: Tree view stops working when returning back from form view

When opening the form view of a tree view node, Smartclient copies the values of the node properties into the form but skipping the properties involved in the tree management (these properties the child nodes are also not copied).

When returning back from the form view, the tree node is refreshed with the values of the properties stored in the form. This caused the lost of the tree information of the child nodes because, as mentioned before, the tree properties were not copied when opening the form view.

Apart from the skipped properties, the tree information of the child nodes should not have changed in form view. Therefore, to fix the problem now we do not override the children information when returning from the form view.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-view-grid.js
---
(0098766)
alostale (developer)
2017-09-01 08:38

code reviewed + tested
(0099338)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-08-25 09:13 JONHM New Issue
2017-08-25 09:13 JONHM Assigned To => platform
2017-08-25 09:13 JONHM File Added: treeViewIssue.mp4
2017-08-25 09:13 JONHM Modules => Core
2017-08-25 09:13 JONHM Triggers an Emergency Pack => No
2017-08-25 09:13 JONHM Note Added: 0098645
2017-08-25 09:14 JONHM Note Deleted: 0098645
2017-08-25 09:14 JONHM Note Added: 0098646
2017-08-29 09:52 caristu Assigned To platform => caristu
2017-08-29 10:29 hgbot Checkin
2017-08-29 10:29 hgbot Note Added: 0098688
2017-08-29 10:29 hgbot Status new => resolved
2017-08-29 10:29 hgbot Resolution open => fixed
2017-08-29 10:29 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/40963c034a8f7f71f7da2118b8ccea3c4caf51e4 [^]
2017-08-29 10:33 caristu Review Assigned To => alostale
2017-09-01 08:38 alostale Note Added: 0098766
2017-09-01 08:38 alostale Status resolved => closed
2017-09-01 08:38 alostale Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099338


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker