Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036681
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 05. Production managementmajoralways2017-08-21 15:072017-09-21 16:49
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisiond66d496bf117
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036681: Insufficient stock in Create Standards Process of Work Effort - Production Run tab if decimal quantities are consumed

DescriptionInsufficient stock in Create Standards Process of Work Effort - Production Run tab if decimal quantities are consumed and the stock is not in the same locator

The problem is that in M_GET_STOCK_PARAM function v_Quantity variable does not accept decimals:

v_Quantity NUMERIC(10);

and the next records from M_STOCK_PROPOSED table are deleted in the following piece of code:

      IF (v_qtyaux <= 0) THEN
        DELETE FROM m_stock_proposed
        WHERE ad_pinstance_id = p_uuid
          AND (priority > cur_warehouse.priority
              OR isfinal = 'N');
        EXIT;
      END IF;
Steps To ReproduceAs group admin role:
   Create a new warehouse for F&B España Region Norte
   Add a locator to it
   Increase its Relative Priority to 100
   Assign it as on hand warehouse to F&B España Region Norte organization

   Create a new product: consumed
   Set it as production
   Add 4 units of it in Region Norte warehouse
   Add more units of it in the new created warehouse

   Create a new product: produced
   Set it as production
   Create a record in Manufacturing tab for España Norte org and any locator

   Create an Activity
   Create a Process Plan, Version and Operation
   Set Create Standards to 'N'
   Add 4.4 units of the previously created product to be consumed (P-)
   Add 1 unit of the previously created product to be produced (P+)

   Create a Work Requirement for that Process Plan and process it (Quantity: 1)
   Create Work Effort
   Go to Work Effort - Production Run tab, set Completed Quantity to 1 and Create Standards
   You will get the following error:
      Insufficient stock:: <productName>
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036690 closedmarkmm82 Insufficient stock in Create Standards Process of Work Effort - Production Run tab if stock is in different priority warehouses 

-  Notes
(0098637)
markmm82 (developer)
2017-08-24 20:05

Test Plan 1:

As group admin role:
   Create a new warehouse for F&B España Region Norte
   Add a locator to it
   Increase its Relative Priority to 100
   Assign it as on hand warehouse to F&B España Region Norte organization

   Create a new product: consumed
   Set it as production
   Add 4 units of it in Region Norte warehouse
   Add more units of it in the new created warehouse

   Create a new product: produced
   Set it as production
   Assign a locator to it in the Manufacturing tab

   Create an Activity
   Create a Process Plan, Version and Operation
   Set Create Standards to 'N'
   Add 4.4 units of the previously created product to be consumed (P-)
   Add 1 unit of the previously created product to be produced (P+)

   Create a Work Requirement for that Process Plan and process it (Quantity: 1)
   Create Work Effort
   Go to Work Effort - Production Run tab, set Completed Quantity to 1
   Run Create Standards process.
   Notice it finishes successfully.
(0098650)
hgbot (developer)
2017-08-25 12:03

Repository: erp/devel/pi
Changeset: d66d496bf11717dd0e50bdb729b0b74fdd61e5fb
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Aug 24 13:14:38 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/d66d496bf11717dd0e50bdb729b0b74fdd61e5fb [^]

Fixes issue 36681: Insufficient stock in Create Standards Process of Work Effort

The problem was that in M_GET_STOCK_PARAM function v_Quantity variable does not
accept decimals and when quantity is decreased on iterations decimals are ignored
and the next records from M_STOCK_PROPOSED table are deleted.

To fix that, the v_Quantity variable has been declared as NUMBER to accept decimals.

---
M src-db/database/model/functions/M_GET_STOCK_PARAM.xml
---
(0098651)
aferraz (developer)
2017-08-25 12:03

Code review + Testing OK
(0099330)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-08-21 15:07 ngarcia New Issue
2017-08-21 15:07 ngarcia Assigned To => Triage Finance
2017-08-21 15:07 ngarcia Modules => Core
2017-08-21 15:07 ngarcia Triggers an Emergency Pack => No
2017-08-21 15:09 ngarcia Description Updated View Revisions
2017-08-21 15:09 ngarcia Issue Monitored: networkb
2017-08-22 08:49 aferraz Assigned To Triage Finance => markmm82
2017-08-22 12:58 ngarcia Issue cloned 0036690
2017-08-22 12:59 ngarcia Relationship added related to 0036690
2017-08-22 13:00 ngarcia Steps to Reproduce Updated View Revisions
2017-08-23 23:56 markmm82 Status new => scheduled
2017-08-24 20:05 markmm82 Note Added: 0098637
2017-08-25 12:01 aferraz Steps to Reproduce Updated View Revisions
2017-08-25 12:03 hgbot Checkin
2017-08-25 12:03 hgbot Note Added: 0098650
2017-08-25 12:03 hgbot Status scheduled => resolved
2017-08-25 12:03 hgbot Resolution open => fixed
2017-08-25 12:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d66d496bf11717dd0e50bdb729b0b74fdd61e5fb [^]
2017-08-25 12:03 aferraz Review Assigned To => aferraz
2017-08-25 12:03 aferraz Note Added: 0098651
2017-08-25 12:03 aferraz Status resolved => closed
2017-08-25 12:03 aferraz Fixed in Version => 3.0PR17Q4
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099330


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker