Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036662
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-08-17 14:582017-10-06 12:37
ReportermalsasuaView Statuspublic 
Assigned Tomarvintm 
PrioritynormalResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision1839f70ac77a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomigueldejuana
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036662: first search in product tab is very slow

Descriptionin some cases, the first search of product is very slow. The rest of searchs is quick

It happens with all entities, not only for product. And it happens the first time because the database has not been cached yet.
Steps To Reproducein a environment with big volume:
. do login in POS
. delete the Operative System cache to force to read the database files from disk, no from cache:
sudo su -
sync; echo 3 > /proc/sys/vm/drop_caches;
. search a product, in "search" tab -> it takes a long time
. search a product again -> it is very quick
TagsNo tags attached.
Attached Filesdiff file icon issue36662.diff [^] (4,610 bytes) 2017-09-04 15:38 [Show Content]
diff file icon issue36662-2.diff [^] (1,576 bytes) 2017-09-04 15:38 [Show Content]
diff file icon issue36662_q1.diff [^] (4,512 bytes) 2017-09-11 11:44 [Show Content]
diff file icon issue36662-2_q1.diff [^] (1,514 bytes) 2017-09-11 11:44 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0040496 newRetail first search of business partner selector is very slow 

-  Notes
(0098939)
jorge-garcia (developer)
2017-09-11 13:04

Waiting for confirmation from the customer that everything works as expected
(0099754)
hgbot (developer)
2017-10-04 10:12

Repository: erp/pmods/org.openbravo.mobile.core
Changeset: 1839f70ac77ade8361766dd7cfb6b76bffe00c33
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Wed Oct 04 09:56:22 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1839f70ac77ade8361766dd7cfb6b76bffe00c33 [^]

Fixed issue 36662. Forced precaching of local database models.
Now for every model stored in the local database, a full query will be triggered during login. This seems to be not very expensive in terms of performance, and at the same time seems to force the caching of database files by the operating system, so that subsequent queries are then much faster. The main goal is to prevent the system from initially responding very slowly when the cashier needs to start creating tickets.

---
M src-db/database/sourcedata/AD_MESSAGE.xml
M web/org.openbravo.mobile.core/source/data/ob-dal.js
---
(0099794)
migueldejuana (developer)
2017-10-06 12:37

Tested and reviewed

- Issue History
Date Modified Username Field Change
2017-08-17 14:58 malsasua New Issue
2017-08-17 14:58 malsasua Assigned To => Retail
2017-08-17 14:58 malsasua Resolution time => 1504735200
2017-08-17 14:58 malsasua Triggers an Emergency Pack => No
2017-08-28 23:18 egoitz Issue Monitored: egoitz
2017-09-04 15:38 marvintm File Added: issue36662.diff
2017-09-04 15:38 marvintm File Added: issue36662-2.diff
2017-09-11 11:44 marvintm File Added: issue36662_q1.diff
2017-09-11 11:44 marvintm File Added: issue36662-2_q1.diff
2017-09-11 13:04 jorge-garcia Note Added: 0098939
2017-09-11 13:04 jorge-garcia Assigned To Retail => malsasua
2017-09-11 13:04 jorge-garcia Status new => feedback
2017-09-25 18:27 malsasua Status feedback => new
2017-10-02 13:06 malsasua Assigned To malsasua => Retail
2017-10-04 10:12 marvintm Assigned To Retail => marvintm
2017-10-04 10:12 hgbot Checkin
2017-10-04 10:12 hgbot Note Added: 0099754
2017-10-04 10:12 hgbot Status new => resolved
2017-10-04 10:12 hgbot Resolution open => fixed
2017-10-04 10:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/1839f70ac77ade8361766dd7cfb6b76bffe00c33 [^]
2017-10-06 12:37 migueldejuana Review Assigned To => migueldejuana
2017-10-06 12:37 migueldejuana Note Added: 0099794
2017-10-06 12:37 migueldejuana Status resolved => closed
2017-10-06 12:37 migueldejuana Fixed in Version => pi
2019-03-29 14:19 JONHM Relationship added related to 0040496


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker