Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036659
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-08-17 13:172017-09-21 16:49
ReporterngarciaView Statuspublic 
Assigned Tomarkmm82 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revisioneedde20727c8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036659: [Costing Migration Process]: Closing inventories are not leaving stock valuation to 0

Description[Costing Migration Process]: Closing inventories are not leaving stock valuation to 0

In calculateCosts function of CostingMigrationProcess class, in order to adjust the cost of the last transaction, the movementqty is wrongly compared with the stock (movementqty will be negative when stock is positive):

        if (trx.getMovementQuantity().compareTo(totalStock) == 0) {
          // Last transaction adjusts remaining cost amount.
          trxCost = totalCost;
        }
Steps To Reproduce*
Proposed SolutionChange in CostingMigrationProcess.java:

if (trx.getMovementQuantity().compareTo(totalStock) == 0) {
  // Last transaction adjusts remaining cost amount.
  trxCost = totalCost;
}

with:

if (trx.getMovementQuantity().negate().compareTo(totalStock) == 0) {
  // Last transaction adjusts remaining cost amount.
  trxCost = totalCost;
}
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0036642 newTriage Finance [Costing Migration Process] Stock valuation should be updated to 0 when the stock of the product is 0 
related to defect 0036675 closedmarkmm82 [Costing Migration Process]: Transactions related with closing inventory lines do not have an entry in Transaction Cost tab 

-  Notes
(0098535)
hgbot (developer)
2017-08-18 08:37

Repository: erp/devel/pi
Changeset: eedde20727c8bf0ef1c4228dfc7fc29a1bbd89b3
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Aug 17 10:35:39 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/eedde20727c8bf0ef1c4228dfc7fc29a1bbd89b3 [^]

Fixes issue 36659: Closing inventories are not leaving stock valuation to 0

When Costing Migration Process is executed closing inventories are not leaving
stock valuation to 0. In calculateCosts function of CostingMigrationProcess class,
in order to adjust the cost of the last transaction, the movementqty was wrongly
compared with the stock because it doesn't take into account that movementqty will
be negative (as it belongs to closing inventory transactions) when stock is positive.

To fix it, the movement quantity is negated when comparing with stock.

---
M src/org/openbravo/costing/CostingMigrationProcess.java
---
(0098536)
aferraz (developer)
2017-08-18 08:48

Code review OK
(0099312)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-08-17 13:17 ngarcia New Issue
2017-08-17 13:17 ngarcia Assigned To => Triage Finance
2017-08-17 13:17 ngarcia Modules => Core
2017-08-17 13:17 ngarcia Triggers an Emergency Pack => No
2017-08-17 13:17 ngarcia Issue Monitored: networkb
2017-08-17 13:20 ngarcia Relationship added related to 0036642
2017-08-17 13:27 aferraz Assigned To Triage Finance => markmm82
2017-08-17 13:28 aferraz Proposed Solution updated
2017-08-17 13:34 aferraz Proposed Solution updated
2017-08-17 16:10 markmm82 Status new => scheduled
2017-08-18 08:37 hgbot Checkin
2017-08-18 08:37 hgbot Note Added: 0098535
2017-08-18 08:37 hgbot Status scheduled => resolved
2017-08-18 08:37 hgbot Resolution open => fixed
2017-08-18 08:37 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/eedde20727c8bf0ef1c4228dfc7fc29a1bbd89b3 [^]
2017-08-18 08:48 aferraz Review Assigned To => aferraz
2017-08-18 08:48 aferraz Note Added: 0098536
2017-08-18 08:48 aferraz Status resolved => closed
2017-08-18 08:48 aferraz Fixed in Version => 3.0PR17Q4
2017-08-21 11:40 ngarcia Relationship added related to 0036675
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099312


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker