Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036190
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSmajoralways2017-06-07 12:222017-06-20 18:39
ReporterasiermartirenaView Statuspublic 
Assigned Toasiermartirena 
PriorityhighResolutionfixedFixed in VersionRR17Q3
StatusclosedFix in branchFixed in SCM revision9d30fa666e27
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Regression levelPre packaging ( pi )
Regression date2017-06-01
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/20f098a38af83037f878fdaea5c8f05105031703 [^]
Triggers an Emergency PackNo
Summary

0036190: Is not possible to generate credit notes

DescriptionIt's not possible to generate credit notes.

The problem is that the process which generates a credit note tries to access to the context information, which is not accessible in import entries processes because these processes don't have a session.
Steps To ReproduceGo to the Web POS.

Create a ticket with a negative amount.
Pay with credit notes.
Both order nor the credit note are not created.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0036010 closedasiermartirena The order and payment is not set in some gift card transactions 

-  Notes
(0097192)
hgbot (developer)
2017-06-07 13:24

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 9d30fa666e27b76f63d71204336f546b82f5a4d0
Author: Asier Martirena <asier.martirena <at> openbravo.com>
Date: Wed Jun 07 13:23:43 2017 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/9d30fa666e27b76f63d71204336f546b82f5a4d0 [^]

Fixed issue 36190: Is not possible to generate credit notes.

The problem is that the process which generates a credit note tries to access to the context information, which is not accessible in import entries processes because these processes don't have a session.

---
M src/org/openbravo/retail/giftcards/GiftCardModel.java
M src/org/openbravo/retail/giftcards/hooks/GiftCardHookUtils.java
---
(0097537)
Sandrahuguet (developer)
2017-06-20 18:39

Code review and testing OK

- Issue History
Date Modified Username Field Change
2017-06-07 12:22 asiermartirena New Issue
2017-06-07 12:22 asiermartirena Assigned To => asiermartirena
2017-06-07 12:22 asiermartirena Regression level => Coding ( Testing )
2017-06-07 12:22 asiermartirena Regression date => 2017-06-01
2017-06-07 12:22 asiermartirena Regression introduced in release => pi
2017-06-07 12:22 asiermartirena Triggers an Emergency Pack => No
2017-06-07 12:48 dmitry_mezentsev Regression level Coding ( Testing ) => Production - QA Approved
2017-06-07 12:56 dmitry_mezentsev Regression level Production - QA Approved => Pre packaging ( pi )
2017-06-07 13:24 hgbot Checkin
2017-06-07 13:24 hgbot Note Added: 0097192
2017-06-07 13:24 hgbot Status new => resolved
2017-06-07 13:24 hgbot Resolution open => fixed
2017-06-07 13:24 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/9d30fa666e27b76f63d71204336f546b82f5a4d0 [^]
2017-06-19 14:02 asiermartirena Relationship added caused by 0036010
2017-06-20 08:53 Sandrahuguet Review Assigned To => Sandrahuguet
2017-06-20 15:35 Sandrahuguet Regression introduced by commit => https://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/20f098a38af83037f878fdaea5c8f05105031703 [^]
2017-06-20 18:39 Sandrahuguet Note Added: 0097537
2017-06-20 18:39 Sandrahuguet Status resolved => closed
2017-06-20 18:39 Sandrahuguet Fixed in Version => RR17Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker