Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035688
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminorhave not tried2017-04-04 16:132017-07-19 13:19
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q1.1
StatusclosedFix in branchFixed in SCM revisionf5b269a1418a
ProjectionnoneETAnoneTarget Version3.0PR17Q1.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2016-09-14
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/b23043be4cf63ad3ce1fd35047ece43b4530c3bd [^]
Triggers an Emergency PackNo
Summary

0035688: It is not possible to delete a record in tree view

DescriptionIt is not possible to delete a record in tree view. An error is thrown in console:
ISC_Combined.js:1410 Uncaught RangeError: Maximum call stack size exceeded
    at _2.isc_c_Comm__cloneObject [as $362] (ISC_Combined.js:3003)
    at _2.isc_c_Comm__clone [as $360] (ISC_Combined.js:3002)
    at _2.isc_c_Comm__cloneObject [as $362] (ISC_Combined.js:3003)
    at _2.isc_c_Comm__clone [as $360] (ISC_Combined.js:3002)
    at _2.isc_c_Comm__cloneArray [as $361] (ISC_Combined.js:3002)
    at _2.isc_c_Comm__clone [as $360] (ISC_Combined.js:3001)
    at _2.isc_c_Comm__cloneObject [as $362] (ISC_Combined.js:3003)
    at _2.isc_c_Comm__clone [as $360] (ISC_Combined.js:3002)
    at _2.isc_c_Comm__cloneObject [as $362] (ISC_Combined.js:3003)
    at _2.isc_c_Comm__clone [as $360] (ISC_Combined.js:3002)
Steps To Reproduce- Log in as F&B International Group Admin
- Go to [Account Tree] window.
- Select "F&B International Group" record and go to [Element Value] subtab.
- Open tree view by clicking in "Toggle Tree Grid Visibility" button.
- Open PL | Profit & Loss node and select leaf node: Total Other Income (Expense). Delete it.

Note than leaf node is not removed properly. An error is thrown in console.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0035686 closedinigosanchez It is not possible to delete a record in tree view 

-  Notes
(0095904)
hgbot (developer)
2017-04-07 12:02

Repository: erp/backports/3.0PR17Q1.1
Changeset: f5b269a1418aadd1d15f3fd52fba5fc4583462af
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Apr 07 12:01:36 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q1.1/rev/f5b269a1418aadd1d15f3fd52fba5fc4583462af [^]

Fixed issue 35688: It is not possible to delete a record in tree view

The problem was related with Pre Delete Client Side Event Handler. The problem was
that a isc.clone method didn't work as expected. isc.clone method create a deep
clone of an object that can be edited without affecting the original but does not
handle looping references (will infinite loop). For this reason, in case of clone
currentGrid.getSelection() object in tree view an error was thrown.

In order to fix this problem, isc.shallowClone is used instead of isc.clone. This
method handle looping references properly.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0095932)
caristu (developer)
2017-04-10 13:07

Code review + testing OK.

- Issue History
Date Modified Username Field Change
2017-04-04 16:15 inigosanchez Type defect => backport
2017-04-04 16:15 inigosanchez Target Version => 3.0PR17Q1.1
2017-04-07 11:44 inigosanchez Review Assigned To => caristu
2017-04-07 12:02 hgbot Checkin
2017-04-07 12:02 hgbot Note Added: 0095904
2017-04-07 12:02 hgbot Status scheduled => resolved
2017-04-07 12:02 hgbot Resolution open => fixed
2017-04-07 12:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q1.1/rev/f5b269a1418aadd1d15f3fd52fba5fc4583462af [^]
2017-04-10 13:07 caristu Note Added: 0095932
2017-04-10 13:07 caristu Status resolved => closed
2017-04-10 13:07 caristu Fixed in Version => 3.0PR17Q1.1
2017-07-19 13:19 alostale Assigned To platform => inigosanchez


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker