Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035498
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-03-13 18:582017-03-22 18:41
ReportermaiteView Statuspublic 
Assigned Tomcobas 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision987adac146a2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035498: Not possible to post Goods Receipt when using "Book Using Purchase Order Price" and order is Voided

DescriptionWhen configuring Product as "Book Using Purchase Order Price", it is not possible to post goods receipt document (it is set as "Document disabled for accounting") in case Purchase Order is voided before receipt is posted.

According with documentation (http://wiki.openbravo.com/wiki/Product [^]) "product price is required for posting", which is still set in Purchase Order Line
Steps To Reproduce1. Configure Product as "Expense type" and "Book using purchase order price"
2. Register Purchase Order using this product and process
3. Register related Goods Receipt using "Create lines from" previous order and process. Not post the receipt
4. Access Purchase Order and run "Reactivate" process. After that run "Void" process. Realize that "Ordered qty" has been set to 0
5. Access Goods Receipt and try to post it. Error "Document disabled for accounting" will be raised
Proposed SolutionSeems that getDocumentConfirmation method in DocInOut.java class is checking existence of line net amount instead of unit price
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0095052)
mcobas (developer)
2017-03-15 15:37

1. Go to Product screen and create one new.
   1.1 Configure Product as "Expense type" and "Book using purchase order price".
   1.2 Sale checkbox = unselected.
2. Register a Purchase Order using previous product and process.
3. Register related Goods Receipt using "Create lines from" previous order and process.
   3.1 Not post the receipt.
4. Go to previous Purchase Order and run "Reactivate" process.
   4.1 Run "Reactivate" process.
   4.2 After that run "Void" process.
   4.3 Notice that "Ordered qty" has been set to 0.
5. Go to previous Goods Receipt.
   5.1 Run "Post" process.
6. Notice that open a new screen named "Journal Entries Report" which shows the ledger entries created for the document.
(0095499)
hgbot (developer)
2017-03-22 12:01

Repository: erp/devel/pi
Changeset: 987adac146a2f02834f05ce1870256dc3b330c77
Author: Miguel <martencobasmiguel <at> gmail.com>
Date: Wed Mar 15 10:45:37 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/987adac146a2f02834f05ce1870256dc3b330c77 [^]

Fixes issue 35498: Error while posting a Good Receipt related an Order is Void

The error is caused because when post a Goods Receipt using
"Book Using Purchase Order Price" and order is Voided, is being used
the net amount of the line corresponding to the Order instead of the net price.

To solve this problem, consider the proposed solution by modifying the
getDocumentConfirmation method so that it takes into account the net price
of the line instead of its net amount.

---
M src/org/openbravo/erpCommon/ad_forms/DocInOut.java
---
(0095500)
hgbot (developer)
2017-03-22 12:02

Repository: erp/devel/pi
Changeset: 1d1a20c06e8cdfee1ca23bf7ce320738b82850c6
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Wed Mar 22 11:55:56 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1d1a20c06e8cdfee1ca23bf7ce320738b82850c6 [^]

Related to issue 35498: Code review improvements

Transaction cost should be Goods Receipt Line movement quantity * Purchase Order Line net unit price.

---
M src/org/openbravo/erpCommon/ad_forms/DocInOut.java
---
(0095501)
aferraz (developer)
2017-03-22 12:05

Code review + Testing OK
(0095515)
hudsonbot (developer)
2017-03-22 18:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fdc639ebd8e0 [^]
Maturity status: Test
(0095516)
hudsonbot (developer)
2017-03-22 18:41

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/fdc639ebd8e0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-13 18:58 maite New Issue
2017-03-13 18:58 maite Assigned To => Triage Finance
2017-03-13 18:58 maite Modules => Core
2017-03-13 18:58 maite Triggers an Emergency Pack => No
2017-03-13 18:58 maite Issue Monitored: networkb
2017-03-14 17:09 markmm82 Assigned To Triage Finance => mcobas
2017-03-15 15:31 markmm82 Status new => scheduled
2017-03-15 15:37 mcobas Note Added: 0095052
2017-03-22 12:01 hgbot Checkin
2017-03-22 12:01 hgbot Note Added: 0095499
2017-03-22 12:01 hgbot Status scheduled => resolved
2017-03-22 12:01 hgbot Resolution open => fixed
2017-03-22 12:01 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/987adac146a2f02834f05ce1870256dc3b330c77 [^]
2017-03-22 12:02 hgbot Checkin
2017-03-22 12:02 hgbot Note Added: 0095500
2017-03-22 12:05 aferraz Review Assigned To => aferraz
2017-03-22 12:05 aferraz Note Added: 0095501
2017-03-22 12:05 aferraz Status resolved => closed
2017-03-22 12:05 aferraz Fixed in Version => 3.0PR17Q2
2017-03-22 18:41 hudsonbot Checkin
2017-03-22 18:41 hudsonbot Note Added: 0095515
2017-03-22 18:41 hudsonbot Checkin
2017-03-22 18:41 hudsonbot Note Added: 0095516


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker