Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035493
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Y. DBSourceManagerminorhave not tried2017-03-13 09:172017-03-17 08:52
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision2c18bf970368
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2017-01-11
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/47c768943f70d1c674cb0a2701faf29edde3da84 [^]
Triggers an Emergency PackNo
Summary

0035493: missing log info when check consistency fails

DescriptionWhen exporting database, PL code is checked to ensure it is consistently exported. When there are inconsistencies it only logs some basic info, but it misses the actual problems.

The problem is caused because export.database uses OBLogAppender to log information. This class stores the information about where to log in ThreadLocals, now check consistency is performed in different threads, so the logs generated from these other threads are not displayed.
Steps To Reproduce1. Set core in development
2. Do modifications to some PL to force to be inconsistently exported:
  * ie. change
      IF TG_OP = 'DELETE' THEN RETURN OLD; ELSE RETURN NEW; END IF;
    to lower case
      IF tg_op = 'DELETE' THEN RETURN OLD; ELSE RETURN NEW; END IF;
3. Export database
  Check the log doesn't indicate the differences you'd get.
Proposed SolutionIt does not make sense anymore to continue using OBLogAppender for export.datbase: replace it with a standard ConsoleAppender.
TagsNo tags attached.
Attached Filesdiff file icon 35493-2.diff [^] (862 bytes) 2017-03-13 12:10 [Show Content]
diff file icon 35493-1.diff [^] (1,348 bytes) 2017-03-13 12:11 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035492 closedalostale error checking pl consistency 
related to defect 0035490 closedshuehner SystemService logValidationResults logs a ERROR line always if there are no errors (shows in export.database) 
caused by feature request 00346543.0PR17Q2 closedalostale some performance improvements in DBSM tasks 
related to design defect 0035503 acknowledgedplatform tomcat pool can't be used in cli tasks 

-  Notes
(0094989)
hgbot (developer)
2017-03-14 09:23

Repository: erp/devel/pi
Changeset: 7e2800bad2ba3ea0f9a48cc28f661e81ba2460ce
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 14 09:21:07 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/7e2800bad2ba3ea0f9a48cc28f661e81ba2460ce [^]

fixed bug 35492, fixed bug 35493: new dbsm

  Includes:
    * 35492 - Fixes PG trigger translation consistency:
               - incorrect casting from Trigger to Function
               - use correct translator for triggers
    * 35493 - Missing log info in export.database:
               - replaced OBLogAppender which is not required by standard
                 ConsoleAppender
               - changed layout so that time and log level (INFO, WARN...) is
                 displayed

---
M src-db/database/lib/dbsourcemanager.jar
---
(0094990)
hgbot (developer)
2017-03-14 09:23

Repository: erp/devel/pi
Changeset: afcca1baf74cece5355d02eab7f97188b5b4f022
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Mar 14 09:22:54 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/afcca1baf74cece5355d02eab7f97188b5b4f022 [^]

related to issue 35493, related to issue 35503

  Don't display warn message when tomcat pool cannot be used unless log level is
  set to debug.

  It is expected not to be possible to use it from CLI, because now export.database
  uses standard ConsoleAppender, this message was now visible in logs.

---
M src/org/openbravo/dal/core/SessionHandler.java
---
(0094993)
hgbot (developer)
2017-03-14 09:25

Repository: erp/devel/dbsm-main
Changeset: 2c18bf970368346a63be240ae4bdfa720c40abfc
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Mar 13 14:08:29 2017 +0100
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/2c18bf970368346a63be240ae4bdfa720c40abfc [^]

fixed bug 35493: missing log info when check consistency fails

  Using now standard ConsoleAppender for logging instead of OBLogAppender which
  does not handle properly logging in multi-thread.

---
M src/org/openbravo/ddlutils/task/BaseDalInitializingTask.java
---
(0095295)
hudsonbot (developer)
2017-03-15 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095296)
hudsonbot (developer)
2017-03-15 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095352)
caristu (developer)
2017-03-17 08:52

Code reviewed + testing OK: differences can be seen now in the log.

- Issue History
Date Modified Username Field Change
2017-03-13 09:17 alostale New Issue
2017-03-13 09:17 alostale Assigned To => platform
2017-03-13 09:17 alostale Modules => Core
2017-03-13 09:17 alostale Triggers an Emergency Pack => No
2017-03-13 09:17 alostale Relationship added related to 0035492
2017-03-13 09:17 alostale Relationship added related to 0035490
2017-03-13 09:59 alostale Steps to Reproduce Updated View Revisions
2017-03-13 10:00 alostale Steps to Reproduce Updated View Revisions
2017-03-13 12:04 alostale Relationship added caused by 0034654
2017-03-13 12:05 alostale Regression level => Pre packaging ( pi )
2017-03-13 12:05 alostale Regression date => 2017-01-11
2017-03-13 12:05 alostale Regression introduced in release => pi
2017-03-13 12:05 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/47c768943f70d1c674cb0a2701faf29edde3da84 [^]
2017-03-13 12:05 alostale Priority normal => immediate
2017-03-13 12:05 alostale Severity major => minor
2017-03-13 12:05 alostale Review Assigned To => caristu
2017-03-13 12:06 alostale Assigned To platform => alostale
2017-03-13 12:06 alostale Status new => acknowledged
2017-03-13 12:09 alostale Description Updated View Revisions
2017-03-13 12:09 alostale Proposed Solution updated
2017-03-13 12:10 alostale File Added: 35493-1.diff
2017-03-13 12:10 alostale File Added: 35493-2.diff
2017-03-13 12:11 alostale File Deleted: 35493-1.diff
2017-03-13 12:11 alostale File Added: 35493-1.diff
2017-03-13 14:10 shuehner Issue Monitored: shuehner
2017-03-14 09:16 alostale Relationship added related to 0035503
2017-03-14 09:23 hgbot Checkin
2017-03-14 09:23 hgbot Note Added: 0094989
2017-03-14 09:23 hgbot Status acknowledged => resolved
2017-03-14 09:23 hgbot Resolution open => fixed
2017-03-14 09:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7e2800bad2ba3ea0f9a48cc28f661e81ba2460ce [^]
2017-03-14 09:23 hgbot Checkin
2017-03-14 09:23 hgbot Note Added: 0094990
2017-03-14 09:25 hgbot Checkin
2017-03-14 09:25 hgbot Note Added: 0094993
2017-03-14 09:25 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/7e2800bad2ba3ea0f9a48cc28f661e81ba2460ce [^] => http://code.openbravo.com/erp/devel/dbsm-main/rev/2c18bf970368346a63be240ae4bdfa720c40abfc [^]
2017-03-15 20:22 hudsonbot Checkin
2017-03-15 20:22 hudsonbot Note Added: 0095295
2017-03-15 20:22 hudsonbot Checkin
2017-03-15 20:22 hudsonbot Note Added: 0095296
2017-03-17 08:52 caristu Note Added: 0095352
2017-03-17 08:52 caristu Status resolved => closed
2017-03-17 08:52 caristu Fixed in Version => 3.0PR17Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker