Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035489
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] E. Translationmajoralways2017-03-10 21:162017-03-17 10:38
ReporterrbianchiniView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revisione625fac3bb60
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR16Q3.2SCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035489: Wrong priority between different possible translations

DescriptionWhen you have an especific translation for a static text in a repport (registered in ad_textinterfaces with the filename column pointing to the repport) and there is a general translation for the same static text, the query that returns the possible translations prioritizes the general translation over the specific translation
Steps To Reproduce1 - Install the Localization pack Spain (EspaƱa) - 3.5.0 - English (USA) Module
2 - Install org.openbravo.bugTraslation module (attached)
3 - Execute the following update query in database:
       update ad_textinterfaces_trl set text = 'Nombre2', istranslated='Y' where ad_textinterfaces_id in (select ti.ad_textinterfaces_id from ad_textinterfaces ti where filename='/org/openbravo/bugTranslation/ad_reports/EXAM_example2.jrxml' and text='Name');
4 - Log in ERP and select Spanish language
5 - open product list menu entry and click "aceptar" button
6 - Open the created report and realizes that the column "Nombre" should be "Nombre2"
Proposed SolutionEdit the query in file TextInterfacesData.java, function selectText(ConnectionProvider connectionProvider, String htmlFile, String language) and prioritizes the first select in the union
TagsNo tags attached.
Attached Files? file icon org.openbravo.bugTranslation-1.0.0.obx [^] (13,850 bytes) 2017-03-10 21:16

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0094997)
hgbot (developer)
2017-03-14 13:02

Repository: erp/devel/pi
Changeset: e625fac3bb60025cd96988dfbf76f48e457a11d6
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Mon Mar 13 14:22:51 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e625fac3bb60025cd96988dfbf76f48e457a11d6 [^]

Fixed issue 35489: Wrong priority between different possible translations

The problem was when you have an especific translation for a static text in a report (registered
in ad_textinterfaces with the filename column pointing to the repport) and there was a general
translation for the same static text. In this situation, the query that returns the possible
translations prioritizes the general translation over the specific translation.

The problem has been fixed by edit the query and prioritizes a especific translation for a static
text in a report instead of the general translation. Besides it have been removed some unnecessary
lines of code.

---
M src-core/src/org/openbravo/uiTranslation/TextInterfacesData.java
---
(0095298)
hudsonbot (developer)
2017-03-15 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095359)
alostale (developer)
2017-03-17 10:38

code reviewed + tested

- Issue History
Date Modified Username Field Change
2017-03-10 21:16 rbianchini New Issue
2017-03-10 21:16 rbianchini Assigned To => platform
2017-03-10 21:16 rbianchini File Added: org.openbravo.bugTranslation-1.0.0.obx
2017-03-10 21:16 rbianchini Modules => Core
2017-03-10 21:16 rbianchini Triggers an Emergency Pack => No
2017-03-13 09:39 inigosanchez Assigned To platform => inigosanchez
2017-03-13 13:45 inigosanchez Status new => scheduled
2017-03-14 13:02 hgbot Checkin
2017-03-14 13:02 hgbot Note Added: 0094997
2017-03-14 13:02 hgbot Status scheduled => resolved
2017-03-14 13:02 hgbot Resolution open => fixed
2017-03-14 13:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/e625fac3bb60025cd96988dfbf76f48e457a11d6 [^]
2017-03-14 13:03 inigosanchez Review Assigned To => alostale
2017-03-15 20:22 hudsonbot Checkin
2017-03-15 20:22 hudsonbot Note Added: 0095298
2017-03-17 10:38 alostale Note Added: 0095359
2017-03-17 10:38 alostale Status resolved => closed
2017-03-17 10:38 alostale Fixed in Version => 3.0PR17Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker