Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035485
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POSminoralways2017-03-10 14:292017-06-21 17:42
Reportergorka_gilView Statuspublic 
Assigned Togorka_gil 
PrioritynormalResolutionopenFixed in Version
StatusnewFix in branchFixed in SCM revisionb6c9537cf708
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToSandrahuguet
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035485: Doing login in a multiprice list terminal with remote configured, do a product query without filters that is not needed

DescriptionWhen doing login in the web pos should not be needed to do any search of products, especially in remote mode that should not do any background query not needed to increase server load.

Also after the fix of issue 35383, the empty query of products is not allowed in remote configurations, so this makes some selenium tests to fail.
Steps To Reproduce- Configure remote:
http://wiki.openbravo.com/wiki/Retail:Configuration_Guide#Remote_Data_Preferences [^]
- Login in a multiprice list terminal (for example: MPL1)
http://localhost:8080/openbravo/web/org.openbravo.retail.posterminal/?terminal=MPL1 [^]
- In the developers tolls of chrome in network tab can be seen a request like this on login:
http://localhost:8080/openbravo/org.openbravo.mobile.core.service.jsonrest/org.openbravo.retail.posterminal.master.Product?[...] [^]
Proposed SolutionOn login, it is created a new ticket.
If is a multiprice list terminal, this new trigger launch an event price list change.
This triggers a new search, and since is just after login is a search with empty values.

The proposed fix, is in the event of search, check if is remote and if so don't do the search. And do a clear of search, to ensure that don't remains old data.

Other approach could be to also don't do the search in local, but this would break the functionality in local since the empty search is allowed in local.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035383 resolvedgorka_gil Magnifying glass in product search should be disabled in remote mode if no filter is applied 
related to defect 0035945 closedjorge-garcia Extra Product requests done using Multipricelist functionality 
has duplicate defect 0031561 closedRetail When multi price list is set an extra product action search is done 

-  Notes
(0097491)
gorka_gil (administrator)
2017-06-19 18:38

Fixed in the issue https://issues.openbravo.com/view.php?id=35383 [^]

Now in the change price list event checks if we are in remote, and if so don't execute the search.

This is the diff of the change:

https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/diff/b6c9537cf708/web/org.openbravo.mobile.core/source/retail/component/ob-retail-searchproductcharacteristic.js [^]

[ is a part of this commit https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/b6c9537cf70812867b38097956f098104ad49293 [^] ]
(0097561)
Sandrahuguet (developer)
2017-06-21 17:42

The fix is not working for all cases:
-Enable all remote preferences
-Login in the webPOS using MPL1 terminal
-Search by "avalanche"
-Change the business partner to "Mara Palliot" , notice that the search is cleaned and in normal mode the search is done again

- Issue History
Date Modified Username Field Change
2017-03-10 14:29 gorka_gil New Issue
2017-03-10 14:29 gorka_gil Assigned To => gorka_gil
2017-03-10 14:29 gorka_gil Triggers an Emergency Pack => No
2017-03-10 14:30 gorka_gil Relationship added related to 0035383
2017-03-10 14:36 gorka_gil Status new => scheduled
2017-06-19 18:30 gorka_gil Relationship added related to 0036276
2017-06-19 18:30 gorka_gil Relationship deleted related to 0036276
2017-06-19 18:38 gorka_gil Note Added: 0097491
2017-06-19 18:38 gorka_gil Status scheduled => resolved
2017-06-19 18:38 gorka_gil Resolution open => fixed
2017-06-19 18:38 gorka_gil Fixed in SCM revision => https://code.openbravo.com/erp/pmods/org.openbravo.mobile.core/rev/b6c9537cf70812867b38097956f098104ad49293 [^]
2017-06-21 09:25 Sandrahuguet Relationship added has duplicate 0031561
2017-06-21 09:26 Sandrahuguet Review Assigned To => Sandrahuguet
2017-06-21 17:37 Sandrahuguet Relationship added related to 0035945
2017-06-21 17:42 Sandrahuguet Note Added: 0097561
2017-06-21 17:42 Sandrahuguet Status resolved => new
2017-06-21 17:42 Sandrahuguet Resolution fixed => open


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker