Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035397
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-03-01 16:482017-03-15 20:21
ReporteregoitzView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision4fd058dfb0fd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2015-11-17
Regression introduced in release3.0PR16Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2c0caa49fcc0792e77c29ad705fe662b1eaf12d3 [^]
Triggers an Emergency PackNo
Summary

0035397: Not possible to get on the webservice regions of a country when those are defined to client 0.

DescriptionHaving both the countrys and regions (and translations) defined for Client System (0), when getting using xml rest webservices the information for the country, the regions are not shown on the response.
Steps To Reproduce-Access as system adminitrator and define a new region for country spain
-Logout and login with QA testing client.
-Go to the country and region window and see on the region tab that the new region for spain is shown.
-Access to the webservice
/ws/dal/Country/106
and the region is not shown.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00353983.0PR17Q1 closedcaristu Not possible to get on the webservice regions of a country when those are defined to client 0. 
depends on backport 00353993.0PR16Q4.3 closedcaristu Not possible to get on the webservice regions of a country when those are defined to client 0. 
depends on backport 00354003.0PR16Q3.6 closedcaristu Not possible to get on the webservice regions of a country when those are defined to client 0. 
caused by defect 0029683 closedcaristu web services do not filter by organization in System/Clients Entities 

-  Notes
(0094670)
hgbot (developer)
2017-03-01 18:30

Repository: erp/devel/pi
Changeset: 4fd058dfb0fdcb6b5f2687ddd339d7f9ce2a225e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Mar 01 18:29:35 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4fd058dfb0fdcb6b5f2687ddd339d7f9ce2a225e [^]

fixes issue 35397: Check readable clients for child properties using DAL WS

Fix for issue 0029683 was introducing a security check to avoid showing child properties which belong to a client different from the current client. But this fix was preventing to display some readable objects like master data defined at system level (client 0).

Therefore this security check has been improved and now it is verified if the child property is defined for a client which is readable for the current role.

---
M src/org/openbravo/dal/xml/EntityXMLConverter.java
M src/org/openbravo/service/rest/DalWebService.java
---
(0094671)
hgbot (developer)
2017-03-01 19:24

Repository: erp/devel/pi
Changeset: d930e8fe2e334a511534d528ff36c8f05124a15a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Mar 01 19:23:44 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d930e8fe2e334a511534d528ff36c8f05124a15a [^]

related to issue 35397: prevent NullPointerException

---
M src/org/openbravo/dal/xml/EntityXMLConverter.java
---
(0094674)
hgbot (developer)
2017-03-02 09:17

Repository: erp/devel/pi
Changeset: 27a80e687a9af2244473b5e4ed5ba0c6a5d199f8
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Mar 02 09:15:07 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/27a80e687a9af2244473b5e4ed5ba0c6a5d199f8 [^]

related to issue 35397: Added new test case

---
M src-test/src/org/openbravo/test/AllWebserviceTests.java
A src-test/src/org/openbravo/test/webservice/WSReadableClientsTest.java
---
(0094721)
alostale (developer)
2017-03-03 10:39

code reviewed + tested
(0094722)
hgbot (developer)
2017-03-03 10:51

Repository: erp/devel/pi
Changeset: e349ce84e2317d4bf8bfc315bcc227f16a50cdb0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Mar 03 10:49:49 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e349ce84e2317d4bf8bfc315bcc227f16a50cdb0 [^]

related to issue 35397: add missing javadoc information

---
M src/org/openbravo/dal/xml/EntityXMLConverter.java
---
(0095243)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095244)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095246)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095253)
hudsonbot (developer)
2017-03-15 20:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-03-01 16:48 egoitz New Issue
2017-03-01 16:48 egoitz Assigned To => platform
2017-03-01 16:48 egoitz Modules => Core
2017-03-01 16:48 egoitz Triggers an Emergency Pack => No
2017-03-01 17:29 caristu Regression level => Production - Confirmed Stable
2017-03-01 17:29 caristu Regression date => 2015-11-17
2017-03-01 17:29 caristu Regression introduced in release => 3.0PR16Q1
2017-03-01 17:29 caristu Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2c0caa49fcc0792e77c29ad705fe662b1eaf12d3 [^]
2017-03-01 17:29 caristu Assigned To platform => caristu
2017-03-01 17:29 caristu Severity major => minor
2017-03-01 17:30 caristu Status new => scheduled
2017-03-01 18:02 caristu Relationship added caused by 0029683
2017-03-01 18:30 hgbot Checkin
2017-03-01 18:30 hgbot Note Added: 0094670
2017-03-01 18:30 hgbot Status scheduled => resolved
2017-03-01 18:30 hgbot Resolution open => fixed
2017-03-01 18:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4fd058dfb0fdcb6b5f2687ddd339d7f9ce2a225e [^]
2017-03-01 19:24 hgbot Checkin
2017-03-01 19:24 hgbot Note Added: 0094671
2017-03-02 09:17 hgbot Checkin
2017-03-02 09:17 hgbot Note Added: 0094674
2017-03-02 10:20 caristu Review Assigned To => alostale
2017-03-03 10:39 alostale Note Added: 0094721
2017-03-03 10:39 alostale Status resolved => closed
2017-03-03 10:39 alostale Fixed in Version => 3.0PR17Q2
2017-03-03 10:51 hgbot Checkin
2017-03-03 10:51 hgbot Note Added: 0094722
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095243
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095244
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095246
2017-03-15 20:21 hudsonbot Checkin
2017-03-15 20:21 hudsonbot Note Added: 0095253


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker