Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035385
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-02-28 16:522017-03-25 01:51
ReporterngarciaView Statuspublic 
Assigned Toluisrs8608 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revisionee5bf188484a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035385: Error is shown when posting a goods movement with a transaction cost of 0

DescriptionError is shown when posting a goods movement with a transaction cost of 0
Steps To ReproduceAs group admin role:
   Create a new product
   Add a purchase price of 0 to it
   Create a goods receipt and add it
   Create a goods movement and move it from one storage bin to another
   Launch the costing background process and check it finishes successfully
   Try to Post it and check Posted error is shown
   try to Unpost it without selecting 'Delete accounting entry' option and check NoFactAccct error is shown
   try to Unpost it selecting 'Delete accounting entry' option and check Delete failed error is shown
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00265033.0PR14Q3 closedAtulOpenbravo When trying to post a Physical Inventory with total cost = 0, Post status should be "Disabled for Accounting" 

-  Notes
(0095341)
luisrs8608 (developer)
2017-03-16 17:46
edited on: 2017-03-23 15:25

Test Plan to test Goods Movement with zero transaction cost, with uncalculated cost and non-zero cost

As group admin role:
1. Create a new product.
2. Add a purchase price of 0 to it.
3. Create a goods receipt and add it.
4. Create a goods movement and move it from one storage bin to another.
5. Launch the costing background process and check it finishes successfully.
6. Try to Post it and check a Error message is shown: "Document disabled for accounting" and the status of the document was changed to Document Disabled.

7. Create a goods receipt and add a product with purchase price different to 0.
8. Create a goods movement and move it from one storage bin to another.
9. Try to Post it and check a Error message is shown: "The cost of the product has not been calculated".

10. Create a goods receipt and add a product with purchase price different to 0.
11. Create a goods movement and move it from one storage bin to another.
12. Launch the costing background process and check it finishes successfully.
13. Click in Post. The status of the document was changed to Posted.

(0095563)
hgbot (developer)
2017-03-24 15:10

Repository: erp/devel/pi
Changeset: ee5bf188484a37280cb6fac9463e0e1bd12d2869
Author: Luis <luisrs8608 <at> gmail.com>
Date: Thu Mar 23 09:49:00 2017 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/ee5bf188484a37280cb6fac9463e0e1bd12d2869 [^]

Fixes issue 35385: Error is shown when posting a Goods Movement with a 0 cost

When it was a matter of posting a Goods Movements with zero cost, it showed
'Posted error', and in spite of this it was tried to post the document leaving
it in an inconsistent state, when testing the option Unpost an exception was
fired because it was to eliminate the lines When these were not created.

To solve this when it comes to posting a Goods Movements, it is validated that
all lines of this have a cost other than zero or cost null, in case this
condition is not met, the document is changed to Document Disabled and returned
False interrupting the post process since the cost of its lines has zero value.

---
M src/org/openbravo/erpCommon/ad_forms/DocMovement.java
---
(0095564)
aferraz (developer)
2017-03-24 15:20

Code review + Testing OK
(0095580)
hudsonbot (developer)
2017-03-25 01:51

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/a169bf5db5fd [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-28 16:52 ngarcia New Issue
2017-02-28 16:52 ngarcia Assigned To => Triage Finance
2017-02-28 16:52 ngarcia Modules => Core
2017-02-28 16:52 ngarcia Triggers an Emergency Pack => No
2017-02-28 16:53 ngarcia Issue Monitored: networkb
2017-02-28 16:58 ngarcia Relationship added related to 0026503
2017-02-28 17:53 markmm82 Assigned To Triage Finance => AtulOpenbravo
2017-03-07 20:32 markmm82 Assigned To AtulOpenbravo => mcobas
2017-03-15 16:52 luisrs8608 Assigned To mcobas => luisrs8608
2017-03-15 16:57 luisrs8608 Status new => scheduled
2017-03-16 17:46 luisrs8608 Note Added: 0095341
2017-03-23 15:10 luisrs8608 Note Edited: 0095341 View Revisions
2017-03-23 15:25 luisrs8608 Note Edited: 0095341 View Revisions
2017-03-23 15:26 luisrs8608 Note Added: 0095534
2017-03-23 15:28 luisrs8608 Note Added: 0095535
2017-03-23 15:29 luisrs8608 Note Added: 0095536
2017-03-24 15:09 aferraz Note Deleted: 0095534
2017-03-24 15:09 aferraz Note Deleted: 0095535
2017-03-24 15:09 aferraz Note Deleted: 0095536
2017-03-24 15:10 hgbot Checkin
2017-03-24 15:10 hgbot Note Added: 0095563
2017-03-24 15:10 hgbot Status scheduled => resolved
2017-03-24 15:10 hgbot Resolution open => fixed
2017-03-24 15:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ee5bf188484a37280cb6fac9463e0e1bd12d2869 [^]
2017-03-24 15:20 aferraz Review Assigned To => aferraz
2017-03-24 15:20 aferraz Note Added: 0095564
2017-03-24 15:20 aferraz Status resolved => closed
2017-03-24 15:20 aferraz Fixed in Version => 3.0PR17Q2
2017-03-25 01:51 hudsonbot Checkin
2017-03-25 01:51 hudsonbot Note Added: 0095580


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker