Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035335
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2017-02-22 10:562017-03-15 20:20
ReporterngarciaView Statuspublic 
Assigned Tomarvintm 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision1e7495658970
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release3.0PR16Q3
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035335: Price Adjustments are not applied in Purchase Flow

DescriptionPrice Adjustments are not applied in Purchase Flow
Steps To ReproduceAs group admin role:
   Create a new record in Discounts and Promotions window:
      Discount/Promotion Type: Price Adjustment
      Starting Date: today
      Included ...: All excluding defined (in order to be applied always)
      Discount %: 50
   Create a Sales Order, add a product to it and check Net Unit Price field is updated with the discount
   Create a Sales Invoice, add a product to it and check Net Unit Price field is updated with the discount
   Create a Purchase Order, add a product to it and check Net Unit Price field is not updated with the discount. This is wrong
   Create a Sales Invoice, add a product to it and check Net Unit Price field is not updated with the discount. This is wrong
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00353733.0PR17Q1 closedmarvintm Openbravo ERP Price Adjustments are not applied in Purchase Flow 
depends on backport 00353743.0PR16Q4.3 closedmarvintm Openbravo ERP Price Adjustments are not applied in Purchase Flow 
caused by defect 0032544 closedshivum039 Retail Modules automatic discounts are applied in backoffice purchase flow 

-  Notes
(0094646)
marvintm (developer)
2017-02-27 19:00

Changes for the following issues will be reverted:

https://issues.openbravo.com/view.php?id=32544 [^]
https://issues.openbravo.com/view.php?id=34103 [^]
(0094647)
hgbot (developer)
2017-02-27 19:02

Repository: erp/devel/pi
Changeset: 109cbdd69e7c0c0d053b93fa3cbc38e08a1e296c
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Feb 27 18:52:09 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/109cbdd69e7c0c0d053b93fa3cbc38e08a1e296c [^]

Fixed issue 35335. Reenable automatic discounts in purchase flows.

---
M src-db/database/model/functions/M_PROMOTION_ADJUSTMENT.xml
M src/org/openbravo/erpCommon/businessUtility/PriceAdjustment.java
---
(0094648)
hgbot (developer)
2017-02-27 19:02

Repository: erp/devel/pi
Changeset: 1e74956589706b5fc7ea6fa7c92cc5414d5c2068
Author: Antonio Moreno <antonio.moreno <at> openbravo.com>
Date: Mon Feb 27 18:52:27 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1e74956589706b5fc7ea6fa7c92cc5414d5c2068 [^]

Fixed issue 35335. Reenable automatic discounts in purchase flows.

---
M src-db/database/model/functions/M_PROMOTION_ADJUSTMENT.xml
---
(0095238)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095239)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-22 10:56 ngarcia New Issue
2017-02-22 10:56 ngarcia Assigned To => Triage Finance
2017-02-22 10:56 ngarcia Modules => Core
2017-02-22 10:56 ngarcia Regression introduced in release => 3.0PR16Q3
2017-02-22 10:56 ngarcia Triggers an Emergency Pack => No
2017-02-22 11:00 ngarcia Relationship added caused by 0032544
2017-02-22 11:08 Practics Issue Monitored: Practics
2017-02-22 13:22 heccam Issue Monitored: heccam
2017-02-22 15:57 plujan Issue Monitored: plujan
2017-02-24 14:54 vmromanos Assigned To Triage Finance => Retail
2017-02-27 19:00 marvintm Note Added: 0094646
2017-02-27 19:02 hgbot Checkin
2017-02-27 19:02 hgbot Note Added: 0094647
2017-02-27 19:02 hgbot Status new => resolved
2017-02-27 19:02 hgbot Resolution open => fixed
2017-02-27 19:02 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/109cbdd69e7c0c0d053b93fa3cbc38e08a1e296c [^]
2017-02-27 19:02 hgbot Checkin
2017-02-27 19:02 hgbot Note Added: 0094648
2017-02-27 19:02 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/109cbdd69e7c0c0d053b93fa3cbc38e08a1e296c [^] => http://code.openbravo.com/erp/devel/pi/rev/1e74956589706b5fc7ea6fa7c92cc5414d5c2068 [^]
2017-02-28 07:58 marvintm Status resolved => new
2017-02-28 07:58 marvintm Resolution fixed => open
2017-02-28 07:58 marvintm Status new => scheduled
2017-02-28 07:58 marvintm Status scheduled => resolved
2017-02-28 07:58 marvintm Fixed in Version => 3.0PR17Q2
2017-02-28 07:58 marvintm Resolution open => fixed
2017-03-01 15:17 marvintm Assigned To Retail => marvintm
2017-03-06 16:55 guilleaer Review Assigned To => guilleaer
2017-03-06 16:55 guilleaer Status resolved => closed
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095238
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095239


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker