Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035330
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2017-02-21 16:482017-03-15 20:19
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revisiond202b98c89e8
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035330: [Negative Stock Correction]: Warehouse is not taken into account to check if stock was negative previous to an stock increase

Description[Negative Stock Correction]: Warehouse is not taken into account to check if stock was negative previous to an stock increase.

The problem is that when calling the getStockOnTransactionDate and getValuedStockOnTransactionDate functions in CostingServer class, a new CostingAlgorithm is being created and its costDimensions are null
Steps To ReproduceAs group admin role:
   Set the Enable Negative Stock Corrections preference to Y
   Select the Allow negative stock option at Client level
   Validate a Costing Rule in F&B España S.A. with warehouse dimension selected
   Create a new product
   Create a purchase order
   Add 10 units of the previously created product with a price of 5
   Create the goods receipt in España Region Norte warehouse from it
   Create a purchase order
   Add 10 units of the previously created product with a price of 5
   Create the goods receipt in España Region Sur warehouse from it
   Create the goods shipment of 15 units in España Region Norte warehouse
   Create a purchase order
   Add 10 units of the previously created product with a price of 2
   Create the goods receipt in España Region Norte warehouse from it
   Launch the Costing Background process and check it finishes successfully
   Check the new entry in Costing tab for Region Norte warehouse is negative because a negative stock correction was not done and it should have be done
Proposed SolutionSet costingAlgorithm variable as a global variable inside CostingServer class.
Call CostingAlgorithm.init() method only inside getCostingAlgorithm() method.
Call getCostingAlgorithm() method only inside CostingServer.init() method.
Thus, new CostingAlgorithm instances will only be created and initialized when creating a new CostingServer instance.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0036758 newTriage Finance After validating a costing rule with warehouse dimension, remaining stock valuation could exist on each warehouse but not global 
blocks defect 0035337 closedcollazoandy4 [Negative Stock Correction]: Costing Background Process finishes with error if Warehouse dimension is selected in costing rule 

-  Notes
(0094531)
ngarcia (developer)
2017-02-22 12:14

Customer data should be corrected
(0094581)
hgbot (developer)
2017-02-23 18:21

Repository: erp/devel/pi
Changeset: d202b98c89e82fdbbb614891ef22b27d5e93d6ec
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Feb 23 12:49:01 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/d202b98c89e82fdbbb614891ef22b27d5e93d6ec [^]

Fixes issue 35330: CostingAlgorithm not properly initialized

Set costingAlgorithm variable as a global variable inside CostingServer class.
Call CostingAlgorithm.init() method only inside getCostingAlgorithm() method.
Call getCostingAlgorithm() method only inside CostingServer.init() method.
Thus, new CostingAlgorithm instances will only be created and initialized when creating a new CostingServer instance.

---
M src/org/openbravo/costing/CostingServer.java
---
(0094588)
markmm82 (developer)
2017-02-23 19:23

Code review + Testing OK
(0095226)
hudsonbot (developer)
2017-03-15 20:19

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-21 16:48 ngarcia New Issue
2017-02-21 16:48 ngarcia Assigned To => Triage Finance
2017-02-21 16:48 ngarcia Modules => Core
2017-02-21 16:48 ngarcia Triggers an Emergency Pack => No
2017-02-21 16:49 ngarcia Description Updated View Revisions
2017-02-21 16:49 ngarcia Issue Monitored: networkb
2017-02-21 16:56 ngarcia Proposed Solution updated
2017-02-22 12:07 ngarcia Relationship added blocks 0035337
2017-02-22 12:15 ngarcia Note Added: 0094531
2017-02-22 15:55 egoitz Issue Monitored: egoitz
2017-02-22 17:12 markmm82 Assigned To Triage Finance => collazoandy4
2017-02-23 14:27 aferraz Proposed Solution updated
2017-02-23 18:21 hgbot Checkin
2017-02-23 18:21 hgbot Note Added: 0094581
2017-02-23 18:21 hgbot Status new => resolved
2017-02-23 18:21 hgbot Resolution open => fixed
2017-02-23 18:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d202b98c89e82fdbbb614891ef22b27d5e93d6ec [^]
2017-02-23 18:26 markmm82 Note Added: 0094584
2017-02-23 19:23 markmm82 Note Deleted: 0094584
2017-02-23 19:23 markmm82 Review Assigned To => markmm82
2017-02-23 19:23 markmm82 Note Added: 0094588
2017-02-23 19:23 markmm82 Status resolved => closed
2017-02-23 19:23 markmm82 Fixed in Version => 3.0PR17Q2
2017-03-15 20:19 hudsonbot Checkin
2017-03-15 20:19 hudsonbot Note Added: 0095226
2017-09-08 14:48 aferraz Relationship added related to 0036758


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker