Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035302
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2017-02-17 14:422017-03-15 20:21
ReporternataliagView Statuspublic 
Assigned Toluisrs8608 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision43a3e127a044
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035302: When you change the organization of a product category, it is not changed from the node of the product category tree.

DescriptionWhen you change the organization of a product category, it is not changed from the node of the product category tree.
Steps To Reproduce1- Go to “SQL Query” window in backend using the System administrator role.
2- Execute this query:
select tn.ad_treenode_id
        from M_Product_Category pc, ad_treenode tn
        where pc.ad_org_id <> tn.ad_org_id
        and pc.M_Product_Category_ID = tn.node_id

3- Any result is shown, because all the organizations of the product categories are the same as the organization of the product category tree node.
4- Now, go to “Product Category” window using The White Valley Group Admin and select a record, for example “Camping”. Change its category and set it as “Posets Store” and save it.
5- Execute again the query of step 2. Now, a result is shown, because the organization of the product category has been changed but not the node’s category of its tree. As consequence, this inconsistent categories are not show in webPOS.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0094772)
markmm82 (developer)
2017-03-06 18:02
edited on: 2017-03-07 17:13

Test plan

1- Go to “SQL Query” window in backend using the System administrator role.
2- Execute this query:
select tn.ad_treenode_id
        from M_Product_Category pc, ad_treenode tn
        where pc.ad_org_id <> tn.ad_org_id
        and pc.M_Product_Category_ID = tn.node_id

3- Any result is shown, because all the organizations of the product categories are the same as the organization of the product category tree node.
4- Now, go to “Product Category” window using The White Valley Group Admin and select a record, for example “Camping”. Change its organization and set it as “Posets Store” and save it.
5- Execute again the query of step 2 and notice that any result is shown, because all the organizations of the product categories has been updated and are the same as the new organization of the product category tree node.

(0094807)
hgbot (developer)
2017-03-07 17:46

Repository: erp/devel/pi
Changeset: 43a3e127a0440605a36591138fa18a10cf0e1f28
Author: Luis <luisrs8608 <at> gmail.com>
Date: Mon Mar 06 09:51:37 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/43a3e127a0440605a36591138fa18a10cf0e1f28 [^]

Fixes issue 35302: Updated the node's organization of the product category tree.

When you change the organization of a product category, it is not changed from
the node of the product category tree. As consequence, categories are not shown
in webPOS.

To solve this, when the product category's organization is changed, the node's organization of the
product category tree is updated too.

---
M src-db/database/model/triggers/M_PRODUCT_CATEGORY_TRG.xml
---
(0094808)
markmm82 (developer)
2017-03-07 17:49

Code review + Testing OK
(0095275)
hudsonbot (developer)
2017-03-15 20:21

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-17 14:42 nataliag New Issue
2017-02-17 14:42 nataliag Assigned To => Triage Finance
2017-02-17 14:42 nataliag Modules => Core
2017-02-17 14:42 nataliag Triggers an Emergency Pack => No
2017-02-20 18:33 markmm82 Assigned To Triage Finance => collazoandy4
2017-03-06 18:02 markmm82 Note Added: 0094772
2017-03-06 18:02 markmm82 Status new => scheduled
2017-03-07 17:13 markmm82 Note Edited: 0094772 View Revisions
2017-03-07 17:46 hgbot Checkin
2017-03-07 17:46 hgbot Note Added: 0094807
2017-03-07 17:46 hgbot Status scheduled => resolved
2017-03-07 17:46 hgbot Resolution open => fixed
2017-03-07 17:46 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/43a3e127a0440605a36591138fa18a10cf0e1f28 [^]
2017-03-07 17:49 markmm82 Review Assigned To => markmm82
2017-03-07 17:49 markmm82 Note Added: 0094808
2017-03-07 17:49 markmm82 Status resolved => closed
2017-03-07 17:49 markmm82 Fixed in Version => 3.0PR17Q2
2017-03-12 16:30 markmm82 Assigned To collazoandy4 => luisrs8608
2017-03-15 20:21 hudsonbot Checkin
2017-03-15 20:21 hudsonbot Note Added: 0095275


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker