Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035287
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajorsometimes2017-02-16 17:232017-03-15 20:20
ReporterJONHMView Statuspublic 
Assigned Tovmromanos 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision873ec13e7f74
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035287: Slow behavior in "Accounting" tab of [Financial Account] window

DescriptionA slow behavior was detected in "Accounting" tab of [Financial Account] window when having 7M+ records in fact_acct and 250000 in fin_finacc_transaction.
The result lasts up to 25 seconds or higher.
Steps To Reproduce1) Open [Financial Account] window and select one record
2) Switch to "Accounting" tab
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0094615)
hgbot (developer)
2017-02-24 14:36

Repository: erp/devel/pi
Changeset: 873ec13e7f748fbcf8447db2f369f20e7074f77f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Fri Feb 24 14:36:27 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/873ec13e7f748fbcf8447db2f369f20e7074f77f [^]

Fixed bug 35287: Slow behavior in Financial Account | Accounting tab

Added new index to improve query performance.
In the customer environment the total cost has been reduced from 6581196 to 1310605, and the query time from 18 seconds to 1.2 seconds.

The index is declared as partial index because, although the null ratio is going to be low (around 10% in real instances), it is very unlikely to search by "is null" in this column. So we can have a (small) benefit in declaring as partial index (faster inserts/deletes/updates when the column is null).

---
M src-db/database/model/tables/FACT_ACCT.xml
---
(0094616)
aferraz (developer)
2017-02-24 14:39

Code review OK
(0095235)
hudsonbot (developer)
2017-03-15 20:20

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-02-16 17:23 JONHM New Issue
2017-02-16 17:23 JONHM Assigned To => Triage Finance
2017-02-16 17:23 JONHM Modules => Core
2017-02-16 17:23 JONHM Triggers an Emergency Pack => No
2017-02-16 17:35 vmromanos Assigned To Triage Finance => vmromanos
2017-02-16 17:35 vmromanos Status new => acknowledged
2017-02-24 14:27 vmromanos Status acknowledged => scheduled
2017-02-24 14:36 hgbot Checkin
2017-02-24 14:36 hgbot Note Added: 0094615
2017-02-24 14:36 hgbot Status scheduled => resolved
2017-02-24 14:36 hgbot Resolution open => fixed
2017-02-24 14:36 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/873ec13e7f748fbcf8447db2f369f20e7074f77f [^]
2017-02-24 14:39 aferraz Review Assigned To => aferraz
2017-02-24 14:39 aferraz Note Added: 0094616
2017-02-24 14:39 aferraz Status resolved => closed
2017-02-24 14:39 aferraz Fixed in Version => 3.0PR17Q2
2017-03-15 20:20 hudsonbot Checkin
2017-03-15 20:20 hudsonbot Note Added: 0095235


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker