Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0035271
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformminorhave not tried2017-02-15 13:572017-11-20 12:51
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionea74193b74fa
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0035271: OBCriteria overhead

DescriptionOverhead in OBCriteria is high even after fixing 0020515, although now is much better as it is not locking.

Still big part of overhead is spent on org.hibernate.impl.SessionFactoryImpl.getImplementors.
Steps To ReproduceExecute test cases provided in 0020515, overhead is ~3x compared with OBQuery:

Query with 1 threads done in 3728 ms
Query with 2 threads done in 1743 ms
Query with 3 threads done in 1287 ms
Query with 4 threads done in 1187 ms
Query with 5 threads done in 1121 ms
Query with 6 threads done in 1067 ms
Query with 7 threads done in 1000 ms
Query with 8 threads done in 955 ms

Criteria with 1 threads done in 10717 ms
Criteria with 2 threads done in 4915 ms
Criteria with 3 threads done in 3317 ms
Criteria with 4 threads done in 2796 ms
Criteria with 5 threads done in 2563 ms
Criteria with 6 threads done in 2486 ms
Criteria with 7 threads done in 2265 ms
Criteria with 8 threads done in 2176 ms

TagsNo tags attached.
Attached Filespng file icon Selection_158.png [^] (23,313 bytes) 2017-02-15 14:01

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0020515 closedalostale OBCriteria creates contention at JVM 
related to feature request 0037064 closedcaristu upgrade hibernate 

-  Notes
(0094389)
alostale (developer)
2017-02-16 14:49

Reported to Hibernate: https://hibernate.atlassian.net/browse/HHH-11495 [^]
(0100481)
hgbot (developer)
2017-11-13 13:09

Repository: erp/devel/pi
Changeset: ea74193b74fa03750c0d26bcb2da2a1103079969
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Nov 09 10:41:46 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ea74193b74fa03750c0d26bcb2da2a1103079969 [^]

fixed 37115, fixed 35271: hibernate performance improvements

  * 37115: HQL constant parsing causes contention
     Backports Hibernate issues HHH-4959 and HHH-11377, preventing in most of
     the cases to verify whether a HQL token is a constant which invokes an
     expensive classForName.

  * 35271: OBCriteria overhead
     OBCriteria caused overhead because everytime a critieria was executed, entity
     implementors (java class) was checked. As for a given entity its implementors
     are constant, they can be safelly cached. Note this cache is fixed in size as,
     at most, it will contain an entry per entity. See HHH-11495.

---
M lib/runtime/hibernate3-patched.jar
---
(0100620)
caristu (developer)
2017-11-20 12:51

Verified with test cases provided in 0020515

- Issue History
Date Modified Username Field Change
2017-02-15 13:57 alostale New Issue
2017-02-15 13:57 alostale Assigned To => platform
2017-02-15 13:57 alostale Modules => Core
2017-02-15 13:57 alostale Triggers an Emergency Pack => No
2017-02-15 14:00 alostale Description Updated View Revisions
2017-02-15 14:01 alostale File Added: Selection_158.png
2017-02-15 14:01 alostale Relationship added related to 0020515
2017-02-15 14:01 alostale Status new => acknowledged
2017-02-16 14:49 alostale Note Added: 0094389
2017-10-13 12:41 alostale Relationship added related to 0037064
2017-11-13 13:09 hgbot Checkin
2017-11-13 13:09 hgbot Note Added: 0100481
2017-11-13 13:09 hgbot Status acknowledged => resolved
2017-11-13 13:09 hgbot Resolution open => fixed
2017-11-13 13:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ea74193b74fa03750c0d26bcb2da2a1103079969 [^]
2017-11-13 13:10 alostale Assigned To platform => alostale
2017-11-13 13:10 alostale Review Assigned To => caristu
2017-11-20 12:51 caristu Note Added: 0100620
2017-11-20 12:51 caristu Status resolved => closed
2017-11-20 12:51 caristu Fixed in Version => 3.0PR18Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker