Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034950
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2017-01-13 14:412017-03-15 20:18
ReporterNaroaIriarteView Statuspublic 
Assigned ToNaroaIriarte 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision9a02f5f50ace
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelAutomated tests
Regression date2017-01-17
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/48b0e99812e3 [^]
Triggers an Emergency PackNo
Summary

0034950: When a process is executing another process the refresh fails

DescriptionWhen a process is executed, and this process opens another, the refresh fails.
Steps To Reproduce1- Log in the ERP with QAAdmin user.
2- Open "Financial Account" window.
3- Select "Spain Bank" record and go to the "Imported Bank Statements" sub tab.
4- Create a new record: -In the name write: APRRegression30007Out
                        -In the two date fields set: 20-01-2017, and save the record.
5- Go to the "Bank Statement Lines" subtab and create a new record.
                        - In the "references number" put "30007Out".
                        - In the "business partner" choose "Vendor Madrid"
                        - In "transaction date" put 20-01-2017
                        - Save and click the "Process" process.
6- Go to "Financial Account" tab again and click on the "Match Statement" process. Click OK in the popup which shows.
7- Click on the "plus" button of the column "Match" of the record.
8- A new window will open, click on the "plus" icon of the payment field.
9- A new window will Open.
10- In the "To be paid to" selector, choose "Vendor Madrid".
11- In the "Payment method" selector choose "1 (Spain)".
12- Click the "Done" button.
13- Realize that the "Add new transaction" window stays there and it is broken


See the attached video from the minute 1.16 to the minute 3.10
TagsNo tags attached.
Attached Files? file icon text.ParseException __ 12-01-2017 17_39_54.avi [^] (3,041,626 bytes) 2017-01-13 14:41

- Relationships Relation Graph ] Dependency Graph ]
caused by feature request 00345023.0PR17Q2 closedNaroaIriarte The multi record selection for the processes must be allowed. 

-  Notes
(0093569)
hgbot (developer)
2017-01-16 09:47

Repository: erp/devel/pi
Changeset: 9a02f5f50aced0099095e536b70eeb099850c6ba
Author: Naroa Iriarte <naroa.iriarte <at> openbravo.com>
Date: Mon Jan 16 09:46:35 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9a02f5f50aced0099095e536b70eeb099850c6ba [^]

Fixed issue 34950: A null check condition added


There was the following condition in ob-parameter-window-view.js "if(this.button.multiProcess)...". The problem here is that there is no a null check for the "this.button" and in the cases of opening other pick and execute window inside another one was failing because the view could not be refreshed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/process/ob-parameter-window-view.js
---
(0093745)
alostale (developer)
2017-01-20 08:13

code reviewed and tested

covered in apr test cases
(0095099)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-01-13 14:41 NaroaIriarte New Issue
2017-01-13 14:41 NaroaIriarte Assigned To => NaroaIriarte
2017-01-13 14:41 NaroaIriarte File Added: text.ParseException __ 12-01-2017 17_39_54.avi
2017-01-13 14:41 NaroaIriarte Modules => Core
2017-01-13 14:41 NaroaIriarte Regression level => Automated tests
2017-01-13 14:41 NaroaIriarte Regression introduced in release => pi
2017-01-13 14:41 NaroaIriarte Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/48b0e99812e3 [^]
2017-01-13 14:41 NaroaIriarte Triggers an Emergency Pack => No
2017-01-13 14:42 NaroaIriarte Review Assigned To => alostale
2017-01-13 14:42 NaroaIriarte Status new => scheduled
2017-01-16 09:42 alostale Regression date => 2017-01-17
2017-01-16 09:42 alostale Priority urgent => immediate
2017-01-16 09:42 alostale Relationship added caused by 0034502
2017-01-16 09:47 hgbot Checkin
2017-01-16 09:47 hgbot Note Added: 0093569
2017-01-16 09:47 hgbot Status scheduled => resolved
2017-01-16 09:47 hgbot Resolution open => fixed
2017-01-16 09:47 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9a02f5f50aced0099095e536b70eeb099850c6ba [^]
2017-01-20 08:13 alostale Note Added: 0093745
2017-01-20 08:13 alostale Status resolved => closed
2017-01-20 08:13 alostale Fixed in Version => 3.0PR17Q2
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095099


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker