Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034806
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2016-12-22 10:282017-03-15 20:18
ReporterpsanjuanView Statuspublic 
Assigned Tomarkmm82 
PriorityhighResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision8b10f7e4693e
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version1.6.0_18
OS VersionProfessional ApplianceDatabase version8.3.9Ant version1.7.1
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034806: Some labels need to be changed in some reports if Enable Alternative UOM preference is enabled.

DescriptionSome labels need to be changed in some reports if Enable Alternative UOM preference is enabled.
Steps To ReproduceN/A
Proposed SolutionInvoiced Sales Order Report label "Quantity in" should be changed to "Qty in AUM"

Delivered Sales Order Report label "Quantity in" should be changed to "Qty in AUM"

Invoice Detail Report label "Qty in" should be changed to "Qty in AUM"

Shipment Report - label "Unit" should be changed to "UOM".
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00348753.0PR17Q1 closednonofrancisco Some labels need to be changed in some reports if Enable Alternative UOM preference is enabled. 

-  Notes
(0092999)
nonofrancisco (developer)
2016-12-26 21:23

Test Plan

Enable UoM Management preference

Run Invoiced Sales Order Report and verify the label "Qty in AUM" is present.

Run Delivered Sales Order Report and verify label "Qty in AUM" is present.

Run Invoice Detail Report label and verify label "Qty in AUM" is present.

Run Shipment Report and verify label "UOM" is present.
(0093165)
psanjuan (manager)
2017-01-04 11:50

Fix need to be backported to 17Q1
(0093240)
hgbot (developer)
2017-01-06 22:19

Repository: erp/devel/pi
Changeset: 8b10f7e4693eff471295d68f6b316aada176e035
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Mon Dec 26 14:22:32 2016 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/8b10f7e4693eff471295d68f6b316aada176e035 [^]

Fixes issue 34806: Labels need to be changed in some reports if using AUM

- Label 'Quantity in AUM' was changed to 'Qty in AUM'
- Label 'Unit' was changed to 'UOM'
- Some non reachable and needless code was removed

---
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
M src/org/openbravo/erpCommon/ad_reports/ReportInvoicesEditJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportInvoicesJR.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderInvoicedJasper.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderInvoicedJasper.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvidedJR.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvidedJR.jrxml
M src/org/openbravo/erpCommon/ad_reports/ReportShipmentEdition.jrxml
---
(0093283)
markmm82 (developer)
2017-01-09 19:52

Code review + Testing OK
(0093284)
hgbot (developer)
2017-01-09 20:42

Repository: erp/devel/pi
Changeset: 3d0a5d2000e424d410fbfb8f34acbc0579745e9e
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Jan 06 16:40:10 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/3d0a5d2000e424d410fbfb8f34acbc0579745e9e [^]

Related to issue 34806: Updated copyright

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoicesJR.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderInvoicedJasper.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvidedJR.java
---
(0093639)
vmromanos (developer)
2017-01-17 14:07

Reopened as the code format for the modified files is not correct
(0093647)
hgbot (developer)
2017-01-17 16:06

Repository: erp/devel/pi
Changeset: 3794b4067abb0cebd15412908e856a7b08f4b9e4
Author: Mark <markmm82 <at> gmail.com>
Date: Tue Jan 17 09:56:58 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/3794b4067abb0cebd15412908e856a7b08f4b9e4 [^]

Related to issue 34806: Backed out changeset 3d0a5d2000e4

Backed out this patch due to some code formats errors.

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoicesJR.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderInvoicedJasper.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvidedJR.java
---
(0093650)
hgbot (developer)
2017-01-17 16:23

Repository: erp/devel/pi
Changeset: cdb0e1a0747b098997cb6b19fe5a9f7d1499cef5
Author: Mark <markmm82 <at> gmail.com>
Date: Fri Jan 06 16:40:10 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/cdb0e1a0747b098997cb6b19fe5a9f7d1499cef5 [^]

Related to issue 34806: Updated copyright

---
M src/org/openbravo/erpCommon/ad_reports/ReportInvoicesJR.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderInvoicedJasper.java
M src/org/openbravo/erpCommon/ad_reports/ReportSalesOrderProvidedJR.java
---
(0093651)
markmm82 (developer)
2017-01-17 16:33

Code review + Testing OK
(0095070)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095072)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095103)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095105)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-12-22 10:28 psanjuan New Issue
2016-12-22 10:28 psanjuan Assigned To => Triage Finance
2016-12-22 10:28 psanjuan Modules => Core
2016-12-22 10:28 psanjuan Triggers an Emergency Pack => No
2016-12-22 18:05 markmm82 Assigned To Triage Finance => rqueralta
2016-12-23 16:29 markmm82 Assigned To rqueralta => nonofrancisco
2016-12-23 16:32 nonofrancisco Status new => scheduled
2016-12-26 21:23 nonofrancisco Note Added: 0092999
2017-01-04 11:50 psanjuan Note Added: 0093165
2017-01-06 22:19 hgbot Checkin
2017-01-06 22:19 hgbot Note Added: 0093240
2017-01-06 22:19 hgbot Status scheduled => resolved
2017-01-06 22:19 hgbot Resolution open => fixed
2017-01-06 22:19 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/8b10f7e4693eff471295d68f6b316aada176e035 [^]
2017-01-09 16:12 hgbot Checkin
2017-01-09 16:12 hgbot Note Added: 0093268
2017-01-09 16:12 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/8b10f7e4693eff471295d68f6b316aada176e035 [^] => http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/f52faf69b245e78143ec3f13e0b4c4b82f494438 [^]
2017-01-09 16:12 hgbot Checkin
2017-01-09 16:12 hgbot Note Added: 0093269
2017-01-09 17:59 markmm82 Status resolved => new
2017-01-09 17:59 markmm82 Resolution fixed => open
2017-01-09 18:00 markmm82 Status new => scheduled
2017-01-09 19:51 markmm82 Status scheduled => resolved
2017-01-09 19:51 markmm82 Fixed in Version => 3.0PR17Q2
2017-01-09 19:51 markmm82 Resolution open => fixed
2017-01-09 19:52 markmm82 Review Assigned To => markmm82
2017-01-09 19:52 markmm82 Note Added: 0093283
2017-01-09 19:52 markmm82 Status resolved => closed
2017-01-09 20:42 hgbot Checkin
2017-01-09 20:42 hgbot Note Added: 0093284
2017-01-17 14:07 vmromanos Note Added: 0093639
2017-01-17 14:07 vmromanos Status closed => new
2017-01-17 14:07 vmromanos Resolution fixed => open
2017-01-17 14:07 vmromanos Fixed in Version 3.0PR17Q2 =>
2017-01-17 16:06 hgbot Checkin
2017-01-17 16:06 hgbot Note Added: 0093647
2017-01-17 16:13 hgbot Checkin
2017-01-17 16:13 hgbot Note Added: 0093649
2017-01-17 16:23 hgbot Checkin
2017-01-17 16:23 hgbot Note Added: 0093650
2017-01-17 16:24 markmm82 Note Deleted: 0093649
2017-01-17 16:25 markmm82 Note Deleted: 0093268
2017-01-17 16:28 markmm82 Note Deleted: 0093269
2017-01-17 16:30 markmm82 Status new => scheduled
2017-01-17 16:30 markmm82 Assigned To nonofrancisco => markmm82
2017-01-17 16:32 markmm82 Status scheduled => resolved
2017-01-17 16:32 markmm82 Fixed in Version => 3.0PR17Q2
2017-01-17 16:32 markmm82 Fixed in SCM revision http://code.openbravo.com/erp/backports/3.0PR17Q1/rev/f52faf69b245e78143ec3f13e0b4c4b82f494438 [^] => http://code.openbravo.com/erp/devel/pi/rev/8b10f7e4693eff471295d68f6b316aada176e035 [^]
2017-01-17 16:32 markmm82 Resolution open => fixed
2017-01-17 16:33 markmm82 Note Added: 0093651
2017-01-17 16:33 markmm82 Status resolved => closed
2017-01-18 11:01 lorenzofidalgo Issue Monitored: lorenzofidalgo
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095070
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095072
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095103
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095105


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker