Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034781
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementtrivialhave not tried2016-12-20 11:122017-03-15 20:18
ReportershuehnerView Statuspublic 
Assigned Tocollazoandy4 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q2
StatusclosedFix in branchFixed in SCM revision15c491ac4730
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarkmm82
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034781: End Year Close -> Accounting tab -> Field: C_Year_Close_V_ID has no UI name

DescriptionOpening the End Year Close window and navigating to the Accounting tab shows a grid field by default which is missing a proper name and showing an ugly technical name to the user: C_Year_Close_V_ID.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0093042)
collazoandy4 (developer)
2016-12-28 17:11

Test Plan
 As International Group Admin Role
  Open End Year Close window
  Go to Accounting tab and verify that Period control column is shown
(0093155)
psanjuan (manager)
2017-01-04 10:07

Issue verified.
(0093156)
psanjuan (manager)
2017-01-04 10:15

Test plan above verified. Issue can be code reviewed and closed.
(0093714)
hgbot (developer)
2017-01-18 22:57

Repository: erp/devel/pi
Changeset: fc9791663f017ce80ba3fe921b6bd28b196ccd2b
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Wed Jan 04 13:01:58 2017 -0800
URL: http://code.openbravo.com/erp/devel/pi/rev/fc9791663f017ce80ba3fe921b6bd28b196ccd2b [^]

Fixes issue 34781: Field: C_Year_Close_V_ID has no UI name

The field C_Year_Close_V_ID in Accounting tab of the End Year Close window
has no UI name associeated now have Period control UI name

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0093715)
hgbot (developer)
2017-01-18 23:35

Repository: erp/devel/pi
Changeset: f0e34651e70ea800a006b6140e339447b1596d27
Author: Mark <markmm82 <at> gmail.com>
Date: Wed Jan 18 17:32:07 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/f0e34651e70ea800a006b6140e339447b1596d27 [^]

Related to issue 34781: Changed AD_ELEMENT related to C_Year_Close_V_ID column

Updated the AD_ELEMENT related to the C_Year_Close_V_ID column. After syncronyze
Terminology process field and column were updated too.

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0093716)
markmm82 (developer)
2017-01-18 23:37

Code review + Testing OK
(0093733)
hgbot (developer)
2017-01-19 15:52

Repository: erp/devel/pi
Changeset: 4b57aa0645af3e9611f9dda57984bba5d5c6ca80
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Jan 19 09:47:50 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/4b57aa0645af3e9611f9dda57984bba5d5c6ca80 [^]

Related to issue 34781: Backed out changeset f0e34651e70e

Due to API failures, this commit need to be backed out

---
M src-db/database/sourcedata/AD_COLUMN.xml
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0093734)
hgbot (developer)
2017-01-19 15:52

Repository: erp/devel/pi
Changeset: 725680fec4d27c968567e550ed0d7285572deaca
Author: Mark <markmm82 <at> gmail.com>
Date: Thu Jan 19 09:50:01 2017 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/725680fec4d27c968567e550ed0d7285572deaca [^]

Related to issue 34781: Backed out changeset fc9791663f01

Due to API failures, this commit need to be backed out

---
M src-db/database/sourcedata/AD_FIELD.xml
---
(0093739)
hgbot (developer)
2017-01-19 17:11

Repository: erp/devel/pi
Changeset: 15c491ac473024cd052b0b44f00363b6d75b42b4
Author: Alvaro Ferraz <alvaro.ferraz <at> openbravo.com>
Date: Thu Jan 19 17:10:54 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/15c491ac473024cd052b0b44f00363b6d75b42b4 [^]

Related to issue 34781: Fix API change

Change C_Year_Close_V_ID ad_field name to End Year Close in End Year Close window.
Do not display this field in Accounting tab.

---
M src-db/database/sourcedata/AD_ELEMENT.xml
M src-db/database/sourcedata/AD_FIELD.xml
---
(0093740)
markmm82 (developer)
2017-01-19 20:53

Code review + Testing OK
(0095109)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095110)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095111)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095112)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test
(0095113)
hudsonbot (developer)
2017-03-15 20:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/54e102bef53e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-12-20 11:12 shuehner New Issue
2016-12-20 11:12 shuehner Assigned To => Triage Finance
2016-12-20 11:12 shuehner Modules => Core
2016-12-20 11:12 shuehner Triggers an Emergency Pack => No
2016-12-20 21:23 markmm82 Assigned To Triage Finance => rqueralta
2016-12-20 21:25 markmm82 Status new => scheduled
2016-12-27 18:23 collazoandy4 Assigned To rqueralta => collazoandy4
2016-12-28 17:11 collazoandy4 Note Added: 0093042
2017-01-04 10:07 psanjuan Note Added: 0093155
2017-01-04 10:15 psanjuan Note Added: 0093156
2017-01-18 22:57 hgbot Checkin
2017-01-18 22:57 hgbot Note Added: 0093714
2017-01-18 22:57 hgbot Status scheduled => resolved
2017-01-18 22:57 hgbot Resolution open => fixed
2017-01-18 22:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fc9791663f017ce80ba3fe921b6bd28b196ccd2b [^]
2017-01-18 23:35 hgbot Checkin
2017-01-18 23:35 hgbot Note Added: 0093715
2017-01-18 23:37 markmm82 Review Assigned To => markmm82
2017-01-18 23:37 markmm82 Note Added: 0093716
2017-01-18 23:37 markmm82 Status resolved => closed
2017-01-18 23:37 markmm82 Fixed in Version => 3.0PR17Q2
2017-01-19 11:08 aferraz Status closed => new
2017-01-19 11:08 aferraz Resolution fixed => open
2017-01-19 11:08 aferraz Fixed in Version 3.0PR17Q2 =>
2017-01-19 15:52 hgbot Checkin
2017-01-19 15:52 hgbot Note Added: 0093733
2017-01-19 15:52 hgbot Checkin
2017-01-19 15:52 hgbot Note Added: 0093734
2017-01-19 16:03 markmm82 Status new => scheduled
2017-01-19 17:11 hgbot Checkin
2017-01-19 17:11 hgbot Note Added: 0093739
2017-01-19 20:53 markmm82 Note Added: 0093740
2017-01-19 20:53 markmm82 Status scheduled => resolved
2017-01-19 20:53 markmm82 Fixed in Version => 3.0PR17Q2
2017-01-19 20:53 markmm82 Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/fc9791663f017ce80ba3fe921b6bd28b196ccd2b [^] => http://code.openbravo.com/erp/devel/pi/rev/15c491ac473024cd052b0b44f00363b6d75b42b4 [^]
2017-01-19 20:53 markmm82 Resolution open => fixed
2017-01-19 20:57 markmm82 Status resolved => closed
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095109
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095110
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095111
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095112
2017-03-15 20:18 hudsonbot Checkin
2017-03-15 20:18 hudsonbot Note Added: 0095113


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker