Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034453
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2016-11-09 15:082016-12-16 18:39
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision31a1cfd3b0ae
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034453: transaction is leaked if HeartbeatProcess fails

DescriptionIf HeartbeatProcess fails in a specific part of the execute method and the beat type is "SCHEDULED_BEAT", a require explicit commit is not done. See this code here[1].

The problem have found in CDS enviroment. In this enviroment HeartbeatProcess fails (status: ERR) for a unknown reason. [See attached HeartbeatProcessErrorLog file] Then the commit is not done and a transaction is opened for hours.

[1].- https://code.openbravo.com/erp/devel/pi/file/e0bcd0b2606d/src/org/openbravo/erpCommon/ad_process/HeartbeatProcess.java#l156 [^]
Steps To ReproduceAsk ALopetegui for enviroment
Proposed SolutionMove this piece of code to finally block maybe is enough.
TagsNo tags attached.
Attached Files file icon HeartbeatProcessErrorLog [^] (4,204 bytes) 2016-12-16 13:17 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0029622 closedjarmendariz The heartbeat background process fails if the ad_session table is empty 

-  Notes
(0092420)
hgbot (developer)
2016-12-15 16:48

Repository: erp/devel/pi
Changeset: 31a1cfd3b0aef7ee4905acda5e680ba935124e7b
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Thu Dec 15 16:45:04 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/31a1cfd3b0aef7ee4905acda5e680ba935124e7b [^]

Fixed issue 34453: transaction is leaked if HeartbeatProcess fails.

If HeartbeatProcess fails in a specific part of the execute method and
the beat type is "SCHEDULED_BEAT", the require explicit commit is not done.

Now, a require explicit commit is done in finally blocks in order to ensures
that always is executed.

---
M src/org/openbravo/erpCommon/ad_process/HeartbeatProcess.java
---
(0092483)
caristu (developer)
2016-12-16 12:55

reopened due to code review:
https://docs.google.com/spreadsheets/d/18l2biKWeG6iGDIPqO6VuYQ_TtP_6YxyQU4KSrPvQlJ8/edit#gid=0 [^]
(0092494)
hgbot (developer)
2016-12-16 13:25

Repository: erp/devel/pi
Changeset: 56b8427f2716119038d15294a35e3a2786515b5c
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Dec 16 13:22:24 2016 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/56b8427f2716119038d15294a35e3a2786515b5c [^]

Related with issue 34453:Added missing catch block for the commitAndClose

---
M src/org/openbravo/erpCommon/ad_process/HeartbeatProcess.java
---
(0092498)
caristu (developer)
2016-12-16 13:55

Reviewed.
(0092722)
hudsonbot (developer)
2016-12-16 18:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test
(0092728)
hudsonbot (developer)
2016-12-16 18:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-11-09 15:08 inigosanchez New Issue
2016-11-09 15:08 inigosanchez Assigned To => iciordia
2016-11-09 15:08 inigosanchez Modules => Core
2016-11-09 15:08 inigosanchez Triggers an Emergency Pack => No
2016-11-09 15:11 inigosanchez Assigned To iciordia => platform
2016-11-09 15:12 inigosanchez Issue Monitored: ALopetegui
2016-12-01 12:53 alostale Summary If HeartbeatProcess fails a require explicit commit couldn't be execute => transaction is leaked if HeartbeatProcess fails
2016-12-01 12:53 alostale Status new => acknowledged
2016-12-01 13:20 alostale Priority low => normal
2016-12-01 14:03 alostale Priority normal => high
2016-12-15 15:23 inigosanchez Assigned To platform => inigosanchez
2016-12-15 15:23 inigosanchez Status acknowledged => scheduled
2016-12-15 16:48 hgbot Checkin
2016-12-15 16:48 hgbot Note Added: 0092420
2016-12-15 16:48 hgbot Status scheduled => resolved
2016-12-15 16:48 hgbot Resolution open => fixed
2016-12-15 16:48 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/31a1cfd3b0aef7ee4905acda5e680ba935124e7b [^]
2016-12-15 16:48 inigosanchez Review Assigned To => caristu
2016-12-16 12:40 caristu Relationship added related to 0029622
2016-12-16 12:55 caristu Note Added: 0092483
2016-12-16 12:55 caristu Status resolved => new
2016-12-16 12:55 caristu Resolution fixed => open
2016-12-16 13:14 inigosanchez Status new => scheduled
2016-12-16 13:17 inigosanchez Description Updated View Revisions
2016-12-16 13:17 inigosanchez File Added: HeartbeatProcessErrorLog
2016-12-16 13:25 hgbot Checkin
2016-12-16 13:25 hgbot Note Added: 0092494
2016-12-16 13:26 inigosanchez Status scheduled => resolved
2016-12-16 13:26 inigosanchez Resolution open => fixed
2016-12-16 13:55 caristu Note Added: 0092498
2016-12-16 13:55 caristu Status resolved => closed
2016-12-16 13:55 caristu Fixed in Version => 3.0PR17Q1
2016-12-16 18:39 hudsonbot Checkin
2016-12-16 18:39 hudsonbot Note Added: 0092722
2016-12-16 18:39 hudsonbot Checkin
2016-12-16 18:39 hudsonbot Note Added: 0092728


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker