Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0034180
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2016-10-10 11:032016-12-16 18:38
ReporterdaniOpenbravoView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR17Q1
StatusclosedFix in branchFixed in SCM revision8f17df764d0f
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version
OS Version14.04Database version9.3Ant version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0034180: Missing code to copy some tables from AD dataset which makes impossible importing translations

DescriptionSome code is missing to copy several tables from AD Dataset. That makes impossible to import translations for those tables (that pl is in charge to populate _TRL tables from base table, and then xml import just does update sql's).
We noticed that on table M_OFFER_TYPE which is part of dataset AD. However, cross-checking ad_dataset tables having matching trl_tables with "inserts in ad_create_languages" shows that maybe more are missing.
Phidias has reported for BUT the same problem in these tables:
- AD_MESSAGE_TRL_fr_FR
- AD_REF_LIST_TRL_fr_FR
- AD_TEXTINTERFACES_TRL_fr_FR
- AD_FIELD_TRL_fr_FR
- OBUIAPP_PROCESS_TRL_fr_FR
- OBUISEL_SELECTOR_FIELD_TRL_fr_FR
Steps To ReproduceIn backend:
- Add a translation for some M_OFFER_TYPE record.
- realice that those translations are not applied correctly. In BUT customer we had to export those one to their template.
Proposed SolutionSHU proposed (email: "Missing AD tables in ad_create_languages"):
1. Small bugfix to add at least missing m_offer_type to the pl.
2. Maybe add some code to cross-check ad_tables with that pl function (note need to take into account some ad_module_id<>0 is handled via extra pl's in extension point.
idea: unit or ci test to run above pl for a language -> after that verify that numRows in new trl-table filtered for that language == numRows in base-table.
Ideally make sure every table in AD has at least 1 row somewhere (at least for that test-case).


TagsSER-QA
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0090720)
hgbot (developer)
2016-10-20 13:09

Repository: erp/devel/pi
Changeset: ae110fab1bff7f5b5370e769cb7899b67f096ab3
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Oct 19 15:41:26 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/ae110fab1bff7f5b5370e769cb7899b67f096ab3 [^]

Fixed issue 34180: A missing code in AD_LANGUAGE_CREATE function.

The problem was the missing code in AD_LANGUAGE_CREATE function
related with M_Offer_Type table. A translation problem in
"Discounts and Promotions Types" is caused by this missing code.

The problem has resolved by adding the missing code related with
M_Offer_Type. Now M_Offer_Type is managed properly in
AD_LANGUAGE_CREATE function.

---
M src-db/database/model/functions/AD_LANGUAGE_CREATE.xml
---
(0090764)
caristu (developer)
2016-10-21 13:00

Reopened: https://docs.google.com/spreadsheets/d/18l2biKWeG6iGDIPqO6VuYQ_TtP_6YxyQU4KSrPvQlJ8/edit#gid=0 [^]

Description column of M_Offer_Type_Trl is not being populated by the procedure.
(0090774)
hgbot (developer)
2016-10-21 14:20

Repository: erp/devel/pi
Changeset: 8f17df764d0f43196fc331890e4b1ec83d812d8d
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Fri Oct 21 14:16:10 2016 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/8f17df764d0f43196fc331890e4b1ec83d812d8d [^]

Related with issue 34180: M_Offer_Type_Trl.Description column is not populated

---
M src-db/database/model/functions/AD_LANGUAGE_CREATE.xml
---
(0090776)
caristu (developer)
2016-10-21 15:20

Code review + tested OK: using the verify languages process, the records are created properly in the M_Offer_Type_Trl table.
(0092538)
hudsonbot (developer)
2016-12-16 18:37

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test
(0092543)
hudsonbot (developer)
2016-12-16 18:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/dc8bf00badd0 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2016-10-10 11:03 daniOpenbravo New Issue
2016-10-10 11:03 daniOpenbravo Assigned To => alostale
2016-10-10 11:03 daniOpenbravo Modules => Core
2016-10-10 11:03 daniOpenbravo Triggers an Emergency Pack => No
2016-10-10 11:04 daniOpenbravo Tag Attached: SER-QA
2016-10-10 11:04 daniOpenbravo Issue Monitored: daniOpenbravo
2016-10-18 14:32 inigosanchez Status new => scheduled
2016-10-18 14:32 inigosanchez Assigned To alostale => inigosanchez
2016-10-20 13:01 inigosanchez Review Assigned To => caristu
2016-10-20 13:09 hgbot Checkin
2016-10-20 13:09 hgbot Note Added: 0090720
2016-10-20 13:09 hgbot Status scheduled => resolved
2016-10-20 13:09 hgbot Resolution open => fixed
2016-10-20 13:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ae110fab1bff7f5b5370e769cb7899b67f096ab3 [^]
2016-10-21 13:00 caristu Note Added: 0090764
2016-10-21 13:00 caristu Status resolved => new
2016-10-21 13:00 caristu Resolution fixed => open
2016-10-21 14:20 hgbot Checkin
2016-10-21 14:20 hgbot Note Added: 0090774
2016-10-21 14:20 inigosanchez Status new => scheduled
2016-10-21 14:20 inigosanchez Status scheduled => resolved
2016-10-21 14:20 inigosanchez Resolution open => fixed
2016-10-21 14:21 inigosanchez Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/ae110fab1bff7f5b5370e769cb7899b67f096ab3 [^] => http://code.openbravo.com/erp/devel/pi/rev/8f17df764d0f43196fc331890e4b1ec83d812d8d [^]
2016-10-21 15:20 caristu Note Added: 0090776
2016-10-21 15:20 caristu Status resolved => closed
2016-10-21 15:20 caristu Fixed in Version => 3.0PR17Q1
2016-12-16 18:37 hudsonbot Checkin
2016-12-16 18:37 hudsonbot Note Added: 0092538
2016-12-16 18:38 hudsonbot Checkin
2016-12-16 18:38 hudsonbot Note Added: 0092543


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker